aboutsummaryrefslogtreecommitdiff
path: root/games/libretro-fbneo/Makefile
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-06-01 07:47:27 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-06-01 07:47:27 +0000
commitccae0a75869745bd0bd15f3610cf3bd5bf8a0c88 (patch)
tree6a41b736bf759a31aa8242684a9c8964577b6e8f /games/libretro-fbneo/Makefile
parenta3e0aed9e89dda4a12e5b5e354be016c9e56d0e1 (diff)
downloadports-ccae0a75869745bd0bd15f3610cf3bd5bf8a0c88.tar.gz
ports-ccae0a75869745bd0bd15f3610cf3bd5bf8a0c88.zip
Notes
Diffstat (limited to 'games/libretro-fbneo/Makefile')
-rw-r--r--games/libretro-fbneo/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/games/libretro-fbneo/Makefile b/games/libretro-fbneo/Makefile
new file mode 100644
index 000000000000..0f6000bae6c6
--- /dev/null
+++ b/games/libretro-fbneo/Makefile
@@ -0,0 +1,36 @@
+# $FreeBSD$
+
+PORTNAME= libretro-fbneo
+PORTVERSION= 0.20200504
+CATEGORIES= games
+
+MAINTAINER= menelkir@itroll.org
+COMMENT= Final Burn Alpha fork for libretro
+
+LICENSE= FBNeo
+LICENSE_NAME= FBNeo
+LICENSE_FILE= ${WRKSRC}/src/license.txt
+LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
+
+USES= gmake gl
+USE_LDCONFIG= yes
+USE_GL= gl
+
+BUILD_DEPEND= devel/nasm
+
+PLIST_FILES= lib/libretro/fbneo_libretro.so
+
+NO_CDROM= Commercial users must seek permission from copyright holders.
+
+USE_GITHUB= yes
+GH_ACCOUNT= libretro
+GH_PROJECT= FBNeo
+GH_TAGNAME= 09cff81
+
+MAKEFILE= Makefile.freebsd
+
+do-install:
+ ${MKDIR} ${STAGEDIR}/${PREFIX}/lib/libretro;
+ ${INSTALL_LIB} ${WRKSRC}/src/burner/libretro/fbneo_libretro.so ${STAGEDIR}/${PREFIX}/lib/libretro;
+
+.include <bsd.port.mk>