aboutsummaryrefslogtreecommitdiff
path: root/games/libretro-fbneo
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-08-25 16:33:06 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-08-25 16:33:06 +0000
commita7c4f34799302370ae15029e22e0a81adc5c1af9 (patch)
treecdce25e26845cfa162228c77778e3c825a424d04 /games/libretro-fbneo
parent1a211a1760d55b63ad5b0b9a3910070fb3679b09 (diff)
downloadports-a7c4f34799302370ae15029e22e0a81adc5c1af9.tar.gz
ports-a7c4f34799302370ae15029e22e0a81adc5c1af9.zip
games/libretro-fbneo: fix build on powerpc*
Merge upstream patch to solve: undefined reference to __mftb() and use newer GCC to solve: cc1: error: unrecognized command line option "-Wno-pedantic"cc1: error: unrecognized command line option "-Wno-pedantic" MFH: 2020Q3 (fix build blanket)
Notes
Notes: svn path=/head/; revision=546191
Diffstat (limited to 'games/libretro-fbneo')
-rw-r--r--games/libretro-fbneo/Makefile2
-rw-r--r--games/libretro-fbneo/files/patch-src_burner_libretro_libretro-common_features_features__cpu.c20
2 files changed, 21 insertions, 1 deletions
diff --git a/games/libretro-fbneo/Makefile b/games/libretro-fbneo/Makefile
index cb3f238415d2..c73d699b763e 100644
--- a/games/libretro-fbneo/Makefile
+++ b/games/libretro-fbneo/Makefile
@@ -12,7 +12,7 @@ LICENSE_NAME= FBNeo
LICENSE_FILE= ${WRKSRC}/src/license.txt
LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
-USES= gmake gl
+USES= compiler:c11 gmake gl
USE_LDCONFIG= yes
USE_GL= gl
diff --git a/games/libretro-fbneo/files/patch-src_burner_libretro_libretro-common_features_features__cpu.c b/games/libretro-fbneo/files/patch-src_burner_libretro_libretro-common_features_features__cpu.c
new file mode 100644
index 000000000000..058376411e48
--- /dev/null
+++ b/games/libretro-fbneo/files/patch-src_burner_libretro_libretro-common_features_features__cpu.c
@@ -0,0 +1,20 @@
+--- src/burner/libretro/libretro-common/features/features_cpu.c.orig 2020-08-25 12:19:30 UTC
++++ src/burner/libretro/libretro-common/features/features_cpu.c
+@@ -167,7 +167,7 @@ retro_perf_tick_t cpu_features_get_perf_counter(void)
+ tv_sec = (long)((ularge.QuadPart - epoch) / 10000000L);
+ tv_usec = (long)(system_time.wMilliseconds * 1000);
+ time_ticks = (1000000 * tv_sec + tv_usec);
+-#elif defined(__linux__) || defined(__QNX__) || defined(__MACH__)
++#elif defined(_POSIX_MONOTONIC_CLOCK) || defined(__QNX__) || defined(ANDROID) || defined(__MACH__) || defined(__PSL1GHT__)
+ struct timespec tv = {0};
+ if (ra_clock_gettime(CLOCK_MONOTONIC, &tv) == 0)
+ time_ticks = (retro_perf_tick_t)tv.tv_sec * 1000000000 +
+@@ -181,7 +181,7 @@ retro_perf_tick_t cpu_features_get_perf_counter(void)
+ time_ticks = (retro_perf_tick_t)a | ((retro_perf_tick_t)d << 32);
+ #elif defined(__ARM_ARCH_6__)
+ __asm__ volatile( "mrc p15, 0, %0, c9, c13, 0" : "=r"(time_ticks) );
+-#elif defined(__CELLOS_LV2__) || defined(_XBOX360) || defined(__powerpc__) || defined(__ppc__) || defined(__POWERPC__)
++#elif defined(__CELLOS_LV2__) || defined(_XBOX360)
+ time_ticks = __mftb();
+ #elif defined(GEKKO)
+ time_ticks = gettime();