aboutsummaryrefslogtreecommitdiff
path: root/games/libretro-xrick/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2020-12-18 12:16:23 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2020-12-18 12:16:23 +0000
commita33b20469b6541c2f5eafd18243d98c2773ab46d (patch)
tree820021dfc0d483d14239dc24bdcde0d30826771b /games/libretro-xrick/Makefile
parent4557210d3fe5379ca26781e3bc54768b8053aca9 (diff)
downloadports-a33b20469b6541c2f5eafd18243d98c2773ab46d.tar.gz
ports-a33b20469b6541c2f5eafd18243d98c2773ab46d.zip
Notes
Diffstat (limited to 'games/libretro-xrick/Makefile')
-rw-r--r--games/libretro-xrick/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/games/libretro-xrick/Makefile b/games/libretro-xrick/Makefile
new file mode 100644
index 000000000000..32d3ace7d902
--- /dev/null
+++ b/games/libretro-xrick/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= libretro-xrick
+PORTVERSION= 0.20201218
+CATEGORIES= games
+
+MAINTAINER= menelkir@itroll.org
+COMMENT= Libretro implementation of "Rick Dangerous"
+
+LICENSE= GPLv2
+
+USES= gmake localbase sdl dos2unix
+USE_SDL= sdl
+
+USE_GITHUB= yes
+GH_ACCOUNT= libretro
+GH_PROJECT= xrick-libretro
+GH_TAGNAME= 0aad6c6
+
+MAKEFILE= Makefile.libretro
+DOS2UNIX_FILES= ${MAKEFILE}
+
+PLIST_FILES= lib/libretro/xrick_libretro.so
+
+do-install:
+ ${MKDIR} ${STAGEDIR}/${PREFIX}/lib/libretro
+ ${INSTALL_LIB} ${WRKSRC}/xrick_libretro.so ${STAGEDIR}/${PREFIX}/lib/libretro
+
+.include <bsd.port.mk>