aboutsummaryrefslogtreecommitdiff
path: root/games/libshhcards
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-09-28 02:09:00 +0000
committerSteve Price <steve@FreeBSD.org>1998-09-28 02:09:00 +0000
commit0e58a72c59658581835875735b98650e180f9811 (patch)
tree1324ad37c1a5f0ed723f968536c5b2f5c6c74a09 /games/libshhcards
parent0ba533296d3efd6cd85b78939a120f823c45c6ca (diff)
downloadports-0e58a72c59658581835875735b98650e180f9811.tar.gz
ports-0e58a72c59658581835875735b98650e180f9811.zip
Conver to ELF.
Notes
Notes: svn path=/head/; revision=13489
Diffstat (limited to 'games/libshhcards')
-rw-r--r--games/libshhcards/Makefile14
-rw-r--r--games/libshhcards/files/patch-aa24
-rw-r--r--games/libshhcards/pkg-plist6
3 files changed, 33 insertions, 11 deletions
diff --git a/games/libshhcards/Makefile b/games/libshhcards/Makefile
index 689ed4a29919..90391fe298d4 100644
--- a/games/libshhcards/Makefile
+++ b/games/libshhcards/Makefile
@@ -3,7 +3,7 @@
# Date created: 12 April 1998
# Whom: Andrey Zakhvatov
#
-# $Id: Makefile,v 1.1.1.1 1998/05/02 18:02:43 mph Exp $
+# $Id: Makefile,v 1.2 1998/08/05 09:30:56 asami Exp $
#
DISTNAME= shhcards-1.0.3
@@ -16,13 +16,21 @@ MAINTAINER= andy@icc.surw.chel.su
USE_GMAKE= yes
USE_X_PREFIX= yes
+SOLIB= libshhcards.so
do-install:
@ ${INSTALL_DATA} ${WRKSRC}/shhcards.h ${PREFIX}/include
- @ ${INSTALL_DATA} ${WRKSRC}/libshhcards.so.1.0.3 ${PREFIX}/lib
- @ ln -s ${PREFIX}/lib/libshhcards.so.1.0.3 ${PREFIX}/lib/libshhcards.so
+ @ ${INSTALL_DATA} ${WRKSRC}/${SOLIB}.${SOVERSION} ${PREFIX}/lib
+ @ ${LN} -sf ${SOLIB}.${SOVERSION} ${PREFIX}/lib/${SOLIB}
@ ${MKDIR} ${PREFIX}/share/doc/libshhcards
@ ${INSTALL_DATA} ${WRKSRC}/CREDITS ${PREFIX}/share/doc/libshhcards
@ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/libshhcards
+ @ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.mk>
+
+.if ${PORTOBJFORMAT} == "elf"
+SOVERSION= 1
+.else
+SOVERSION= 1.0
+.endif
diff --git a/games/libshhcards/files/patch-aa b/games/libshhcards/files/patch-aa
index 3e8689482157..f362a9722d6f 100644
--- a/games/libshhcards/files/patch-aa
+++ b/games/libshhcards/files/patch-aa
@@ -1,6 +1,16 @@
---- Makefile.orig Sun Mar 23 04:02:53 1997
-+++ Makefile Fri May 1 22:29:34 1998
-@@ -8,7 +8,7 @@
+--- Makefile.orig Sun Mar 23 03:02:53 1997
++++ Makefile Sun Sep 27 16:54:55 1998
+@@ -3,12 +3,16 @@
+ VERMAJ = 1
+ VERMIN = 0
+ VERPAT = 3
+-VERSION = $(VERMAJ).$(VERMIN).$(VERPAT)
++ifeq ($(PORTOBJFORMAT),elf)
++VERSION = $(VERMAJ)
++else
++VERSION = $(VERMAJ).$(VERMIN)
++endif
+
###########################################################################
# Define SHARED as 1 for Linux shared ELF library
@@ -9,7 +19,7 @@
ifeq ($(SHARED),1)
LIBTARGET = lib$(DIST).so.$(VERSION)
-@@ -28,8 +28,8 @@
+@@ -28,8 +32,8 @@
INSTALL = install -m 644
MKDIRP = install -d -m 755
@@ -20,12 +30,16 @@
###########################################################################
-@@ -87,7 +87,7 @@
+@@ -87,7 +91,11 @@
$(LIBTARGET): $(LIBOBJS)
ifeq ($(SHARED),1)
- $(CC) -shared -Wl,-soname,$(LIBTARGETSOMAJ) -o $(LIBTARGET) $(LIBOBJS)
++ifeq ($(PORTOBJFORMAT),elf)
++ $(CC) -shared -soname $(LIBTARGET) -o $(LIBTARGET) $(LIBOBJS)
++else
+ $(CC) -shared -o $(LIBTARGET) $(LIBOBJS)
++endif
else
ar rcs $(LIBTARGET) $(LIBOBJS)
endif
diff --git a/games/libshhcards/pkg-plist b/games/libshhcards/pkg-plist
index a836be4eb741..ba3056287184 100644
--- a/games/libshhcards/pkg-plist
+++ b/games/libshhcards/pkg-plist
@@ -1,8 +1,8 @@
include/shhcards.h
-lib/libshhcards.so.1.0.3
lib/libshhcards.so
-@exec /sbin/ldconfig -m %D/lib
-@unexec /sbin/ldconfig -m %D/lib
+lib/libshhcards.so.1
+@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %D/lib
+@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %D/lib
share/doc/libshhcards/CREDITS
share/doc/libshhcards/README
@dirrm share/doc/libshhcards