aboutsummaryrefslogtreecommitdiff
path: root/games/lincity
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2002-11-19 04:53:54 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2002-11-19 04:53:54 +0000
commit944a6bf4597b457656ea5f70c22e2dca0eecea32 (patch)
tree90920d808af8273c78ae4aef9f5ea4e28f58ab7b /games/lincity
parentb266749454c1584d7706ad2e7edac11de5e99ca1 (diff)
downloadports-944a6bf4597b457656ea5f70c22e2dca0eecea32.tar.gz
ports-944a6bf4597b457656ea5f70c22e2dca0eecea32.zip
Make games/lincity compiling on -current again.
Noticed on: bento
Notes
Notes: svn path=/head/; revision=70453
Diffstat (limited to 'games/lincity')
-rw-r--r--games/lincity/Makefile1
-rw-r--r--games/lincity/files/patch-ab14
-rw-r--r--games/lincity/files/patch-ac16
-rw-r--r--games/lincity/files/patch-ad13
4 files changed, 35 insertions, 9 deletions
diff --git a/games/lincity/Makefile b/games/lincity/Makefile
index eaedaec75825..ec2a4b85bb63 100644
--- a/games/lincity/Makefile
+++ b/games/lincity/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lincity
PORTVERSION= 1.11
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ftp://ftp.demon.co.uk/pub/unix/linux/games/
diff --git a/games/lincity/files/patch-ab b/games/lincity/files/patch-ab
index a393527e2c79..6e0ec8b94276 100644
--- a/games/lincity/files/patch-ab
+++ b/games/lincity/files/patch-ab
@@ -1,6 +1,14 @@
---- lcx11.cxx.orig Thu Feb 25 20:17:54 1999
-+++ lcx11.cxx Sat Sep 25 17:47:12 1999
-@@ -715,7 +715,7 @@
+--- lcx11.cxx.orig Fri Feb 26 02:17:54 1999
++++ lcx11.cxx Tue Nov 19 05:35:40 2002
+@@ -3,6 +3,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <unistd.h>
+ #include <math.h>
+ #ifdef IRIX
+@@ -715,7 +716,7 @@
#ifdef USE_IMAGES
Fgl_putbox_low (display.win, 0, 0,
x1, y1, x2 - x1, y2 - y1,
diff --git a/games/lincity/files/patch-ac b/games/lincity/files/patch-ac
index 3d1c5941ef19..f32ddbc31b5a 100644
--- a/games/lincity/files/patch-ac
+++ b/games/lincity/files/patch-ac
@@ -1,8 +1,18 @@
---- main.cxx.orig Thu Feb 25 20:17:54 1999
-+++ main.cxx Sat Sep 25 17:56:44 1999
-@@ -780,5 +780,4 @@
+--- main.cxx.orig Fri Feb 26 02:17:54 1999
++++ main.cxx Tue Nov 19 05:27:27 2002
+@@ -4,6 +4,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #if !defined (WIN32)
+ #include <strings.h>
+ #endif
+@@ -779,7 +780,6 @@
+ DIR *dp;
if ((dp = opendir (dir)) == NULL)
{
- closedir (dp);
return 0;
}
+ closedir (dp);
diff --git a/games/lincity/files/patch-ad b/games/lincity/files/patch-ad
index 99dd6211d988..f3e2f0f016d9 100644
--- a/games/lincity/files/patch-ad
+++ b/games/lincity/files/patch-ad
@@ -1,6 +1,13 @@
---- Imakefile.orig Sun Feb 14 07:55:02 1999
-+++ Imakefile Tue Sep 12 02:35:21 2000
-@@ -15,4 +15,4 @@
+--- Imakefile.orig Sat Feb 13 23:55:02 1999
++++ Imakefile Tue Nov 19 05:52:36 2002
+@@ -9,10 +9,11 @@
+ LOCAL_LIBRARIES = $(XLIB)
+ DEPLIBS = $(DEPXLIB)
+ SYS_LIBRARIES = -lm
++ CC = $(CXX)
+
+ SRCS = main.cxx mouse.cxx screen.cxx mps.cxx typeinit.cxx\
+ engine.cxx transport.cxx market.cxx help.cxx lcx11.cxx
OBJS = xmain.o xmouse.o xscreen.o xmps.o xtypeinit.o\
xengine.o xtransport.o xmarket.o xhelp.o lcx11.o