aboutsummaryrefslogtreecommitdiff
path: root/games/linux-doom3-demo
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-09-05 19:23:42 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-09-05 19:23:42 +0000
commit82a87de90c337aae160ac254606dad78d0d78d11 (patch)
tree516db145d6cf5fd4d2666f811272aad577272ac5 /games/linux-doom3-demo
parentf22162b04be45bf28d125c67ee0a841fb1ae4b55 (diff)
downloadports-82a87de90c337aae160ac254606dad78d0d78d11.tar.gz
ports-82a87de90c337aae160ac254606dad78d0d78d11.zip
- Replace Mk/bsd.linux-apps.mk and Mk/bsd.linux-rpm.mk with
Mk/Uses/linux.mk. - Replace USE_LINUX=yes with USES+=linux and USE_LINUX=(.*) with USES+=linux:\1 in all ports. - Replace USE_LINUX_APPS with USE_LINUX in all ports. - Use INSTALL_SCRIPT instead of INSTALL_PROGRAM to install scripts in some ports. - When USE_LINUX_RPM is defined, simplify the way DISTFILES and EXTRACT_ONLY are defined. - Remove BRANDELF_DIRS and BRANDELF_FILES handling. In the very rare cases that it is still necessary ports can run ${BRANDELF} from post-patch. - Remove AUTOMATIC_PLIST handling. Only one port used it. - Fix Linux MASTER_SITES. - Replace OVERRIDE_LINUX_BASE_PORT and OVERRIDE_LINUX_NONBASE_PORTS with default versions framework. - bsd.port.mk: - Move Linux related bits to Uses/linux.mk, except USE_LINUX_PREFIX. - Put USE_LINUX_PREFIX handling after USES processing. - Define DOCSDIR, DATADIR, etc. after handling USE_LINUX_PREFIX so it can give these variables a different default value. - When a package needs to run Linux ldconfig check before installation if Linux support is enabled. - emulators/linux_base-*: - Use USES=linux and remove duplication. - Remove files/lp. FreeBSD or CUPS lp(1) should work. - Remove files/yp.conf. No longer seems to be used. - Remove pkg-deinstall and move pkg-install into pkg-plist. - Update pkg-descr and pkg-message. - Fix handling of ldconfig cache in pkg-plist. - devel/fb-adb: Use a Linux shell to run a Linux script but patch the script to use FreeBSD mkdir so mkdir -p $path creates $path and not /compat/linux/$path. PR: 211645 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=421387
Diffstat (limited to 'games/linux-doom3-demo')
-rw-r--r--games/linux-doom3-demo/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/games/linux-doom3-demo/Makefile b/games/linux-doom3-demo/Makefile
index c0fd23a122ee..64cfbf97835a 100644
--- a/games/linux-doom3-demo/Makefile
+++ b/games/linux-doom3-demo/Makefile
@@ -17,8 +17,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= DOOM III demo for Linux
ONLY_FOR_ARCHS= i386 amd64
-USE_LINUX= yes
-USE_LINUX_APPS= xorglibs
+USES= linux
+USE_LINUX= xorglibs
NO_CDROM= Redistribution is limited, see license; Requested by id Software
NO_BUILD= yes
NO_WRKSUBDIR= yes
@@ -31,7 +31,7 @@ SUB_LIST= DOOMDIR="${DOOMDIR}"
OPTIONS_DEFINE= DOCS NVIDIA_GL
NVIDIA_GL_RUN_DEPENDS= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-NVIDIA_GL_USE_OFF= linux_apps=dri
+NVIDIA_GL_USE_OFF= LINUX=dri
do-extract: