aboutsummaryrefslogtreecommitdiff
path: root/games/linux-etqw-server
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-12-01 11:18:03 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-12-01 11:18:03 +0000
commit8664861b1a575bcf859a90c6fea2b05a1187f1f0 (patch)
tree33a19b5745c1e5e7cbfa4a5ab2c30f6971177e74 /games/linux-etqw-server
parent30de4c11b252c73c33417ac534886e9651b233f1 (diff)
downloadports-8664861b1a575bcf859a90c6fea2b05a1187f1f0.tar.gz
ports-8664861b1a575bcf859a90c6fea2b05a1187f1f0.zip
Don't quote {} in find -exec calls.
Braces are not shell metacharacters, and they do not need to be quoted. By the time find parses its arguments and dicovers them, the quoting will have been removed by the shell anyway. Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=427491
Diffstat (limited to 'games/linux-etqw-server')
-rw-r--r--games/linux-etqw-server/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/games/linux-etqw-server/Makefile b/games/linux-etqw-server/Makefile
index 0e0fcf828890..395c1b0ee0f2 100644
--- a/games/linux-etqw-server/Makefile
+++ b/games/linux-etqw-server/Makefile
@@ -43,17 +43,17 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/data/etqwded.x86 ${STAGEDIR}${ETQWDIR}
@cd ${WRKSRC}/data && \
${FIND} -E . -type f -iregex ".*\.so\.[0-9]+" \
- -exec ${INSTALL_DATA} "{}" "${STAGEDIR}${ETQWDIR}/{}" \;
+ -exec ${INSTALL_DATA} {} "${STAGEDIR}${ETQWDIR}/{}" \;
@${MKDIR} ${STAGEDIR}${ETQWDIR}/base/bots
@cd ${WRKSRC}/data && \
${FIND} base -type f \
- -exec ${INSTALL_DATA} "{}" "${STAGEDIR}${ETQWDIR}/{}" \;
+ -exec ${INSTALL_DATA} {} "${STAGEDIR}${ETQWDIR}/{}" \;
@${MKDIR} ${STAGEDIR}${ETQWDIR}/pb/htm
@cd ${WRKSRC}/data && \
${FIND} pb -type f \
- -exec ${INSTALL_DATA} "{}" "${STAGEDIR}${ETQWDIR}/{}" \;
+ -exec ${INSTALL_DATA} {} "${STAGEDIR}${ETQWDIR}/{}" \;
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for FILE in EULA.txt README.txt copyrights.txt etqwtv.txt readme_1_5_patch.txt server_readme.txt pb/PBEULA.txt