aboutsummaryrefslogtreecommitdiff
path: root/games/linux-nwnclient
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2009-09-16 17:29:39 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2009-09-16 17:29:39 +0000
commit41a568dc35b5c4f839434755d226d264b8bfcdc8 (patch)
treed6d469c539241c09f06f7d3bbe310a3e8a8451e8 /games/linux-nwnclient
parentaaf3f85a784260fac236cc1a035e59f9765bb590 (diff)
downloadports-41a568dc35b5c4f839434755d226d264b8bfcdc8.tar.gz
ports-41a568dc35b5c4f839434755d226d264b8bfcdc8.zip
. respect using USE_LINUX_APPS;
. respect using linux libglu. Approved by: scf (maintainer, at emulation@) Feature safe: yes
Notes
Notes: svn path=/head/; revision=241531
Diffstat (limited to 'games/linux-nwnclient')
-rw-r--r--games/linux-nwnclient/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/games/linux-nwnclient/Makefile b/games/linux-nwnclient/Makefile
index 720250126362..143ee0b5d663 100644
--- a/games/linux-nwnclient/Makefile
+++ b/games/linux-nwnclient/Makefile
@@ -19,19 +19,19 @@ COMMENT= Neverwinter Nights Linux (x86) Client
RUN_DEPENDS= ${LOCALBASE}/share/nwndata/NWNv129.txt:${PORTSDIR}/games/nwndata
-.ifdef WITH_NVIDIA_GL
-RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver \
- ${LINUXBASE}/usr/X11R6/lib/libGLU.so.1:${PORTSDIR}/graphics/linux-libGLU
-.else
-USE_LINUX_APPS+=dri
-.endif
-
NO_BUILD= yes
ONLY_FOR_ARCHS= i386
USE_LINUX= yes
USE_LINUX_APPS= sdl12 xorglibs
NWNDATADIR= ${LOCALBASE}/share/nwndata
+.ifdef WITH_NVIDIA_GL
+RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
+USE_LINUX_APPS+=libglu
+.else
+USE_LINUX_APPS+=dri
+.endif
+
PLIST_SUB+= NWNVERSION="${PORTVERSION:S/.//}"
do-extract: