aboutsummaryrefslogtreecommitdiff
path: root/games/linux-nwnclient
diff options
context:
space:
mode:
authorJohannes Jost Meixner <xmj@FreeBSD.org>2014-09-01 17:25:43 +0000
committerJohannes Jost Meixner <xmj@FreeBSD.org>2014-09-01 17:25:43 +0000
commit43c5efbfdd041663d60af4dfd0375dcfc757018a (patch)
treeffc4f21193d4ab80a5fefdf9e5de36b64d78ba75 /games/linux-nwnclient
parent37e4710f8a0e0f76832ae617b93a478b0a3e93ee (diff)
downloadports-43c5efbfdd041663d60af4dfd0375dcfc757018a.tar.gz
ports-43c5efbfdd041663d60af4dfd0375dcfc757018a.zip
games/linux-nwnclient: Stage
* StageDir PR: 187869 Submitted by: myself Approved by: swills (mentor) Approved by: scf (maintainer)
Notes
Notes: svn path=/head/; revision=366907
Diffstat (limited to 'games/linux-nwnclient')
-rw-r--r--games/linux-nwnclient/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/games/linux-nwnclient/Makefile b/games/linux-nwnclient/Makefile
index 42683c611641..17ca0618cec7 100644
--- a/games/linux-nwnclient/Makefile
+++ b/games/linux-nwnclient/Makefile
@@ -35,7 +35,6 @@ USE_LINUX_APPS+=dri
OPTIONS_DEFINE= NWMOVIES
NWMOVIES_DESC= Support for movies using BinkPlayer
-NO_STAGE= yes
.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
@@ -86,17 +85,17 @@ do-configure:
<${FILESDIR}/nwn.sh >${WRKDIR}/nwn
do-install:
- ${MKDIR} ${DATADIR}
+ ${MKDIR} ${STAGEDIR}${DATADIR}
(cd ${WRKSRC} && ${FIND} . -print | \
- ${CPIO} -pdmuv -R${SHAREOWN}:${SHAREGRP} ${DATADIR})
- ${FIND} ${DATADIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 0755
- ${FIND} ${DATADIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 0644
- (cd ${DATADIR} && ${CHMOD} 0755 dmclient nwmain nwserver)
+ ${CPIO} -pdmuv -R${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DATADIR})
+ ${FIND} ${STAGEDIR}${DATADIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 0755
+ ${FIND} ${STAGEDIR}${DATADIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 0644
+ (cd ${STAGEDIR}${DATADIR} && ${CHMOD} 0755 dmclient nwmain nwserver)
.if defined(BINKPLAYERFILE)
- (cd ${DATADIR} && ${CHMOD} 0755 nwmovies/BinkPlayer)
- (cd ${DATADIR}/nwmovies && ${LN} -s /compat/linux/usr/lib/libX11.so.6 libX11.so)
- ${INSTALL_SCRIPT} ${FILESDIR}/nwmovies.pl ${DATADIR}
+ (cd ${STAGEDIR}${DATADIR} && ${CHMOD} 0755 nwmovies/BinkPlayer)
+ (cd ${STAGEDIR}${DATADIR}/nwmovies && ${LN} -s /compat/linux/usr/lib/libX11.so.6 libX11.so)
+ ${INSTALL_SCRIPT} ${FILESDIR}/nwmovies.pl ${STAGEDIR}${DATADIR}
.endif
- ${INSTALL_SCRIPT} ${WRKDIR}/nwn ${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKDIR}/nwn ${STAGEDIR}${PREFIX}/bin/
.include <bsd.port.post.mk>