aboutsummaryrefslogtreecommitdiff
path: root/games/linux-quake4
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-05-31 14:40:56 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-05-31 14:40:56 +0000
commit8199e9dc487a0e6b99c306fa637033bf11374c41 (patch)
treefd7ac6263851705bfeae2fb7d9dce6af494453c8 /games/linux-quake4
parentfe6302c7633911c7e779bee40e0b1c093ff8260a (diff)
downloadports-8199e9dc487a0e6b99c306fa637033bf11374c41.tar.gz
ports-8199e9dc487a0e6b99c306fa637033bf11374c41.zip
- adopt optionsNG for games
- trim historical headers and trim comments - some Makefile cleanup Approved by: portmgr (bapt)
Notes
Notes: svn path=/head/; revision=319495
Diffstat (limited to 'games/linux-quake4')
-rw-r--r--games/linux-quake4/Makefile25
-rw-r--r--games/linux-quake4/pkg-plist4
2 files changed, 14 insertions, 15 deletions
diff --git a/games/linux-quake4/Makefile b/games/linux-quake4/Makefile
index 858d9f206c33..caadad586b55 100644
--- a/games/linux-quake4/Makefile
+++ b/games/linux-quake4/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Quake 4
-# Date created: 21 Oct 2005
-# Whom: Ed Schouten <ed@fxq.nl>
-#
+# Created by: Ed Schouten <ed@fxq.nl>
# $FreeBSD$
-#
PORTNAME= quake4
PORTVERSION= 1.4.2
@@ -28,15 +24,18 @@ PLIST_SUB+= Q4DIR="${Q4DIR}" \
LINUXBASE="${LINUXBASE}"
SUB_FILES= pkg-message
-OPTIONS= SMP "Install threaded version" on \
- GERMANY "Germany version" off
+OPTIONS_DEFINE= THREADS GERMANY
+GERMANY_DESC= Germany version
+OPTIONS_DEFAULT= THREADS
+
+.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_SMP)
-PLIST_SUB+= SMP=""
+.if ${PORT_OPTIONS:MTHREADS}
+PLIST_SUB+= THREADS=""
.else
-PLIST_SUB+= SMP="@comment "
+PLIST_SUB+= THREADS="@comment "
.endif
do-extract:
@@ -63,7 +62,7 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PKGNAMEPREFIX}${FILE}.sh ${PREFIX}/bin/${PKGNAMEPREFIX}${FILE}
${INSTALL_PROGRAM} ${WRKSRC}/bin/FreeBSD/x86/${FILE}.x86 ${PREFIX}/${Q4DIR}
.endfor
-.if !defined(WITHOUT_SMP)
+.if ${PORT_OPTIONS:MTHREADS}
${INSTALL_SCRIPT} ${WRKSRC}/${PKGNAMEPREFIX}quake4smp.sh ${PREFIX}/bin/${PKGNAMEPREFIX}quake4smp
${INSTALL_PROGRAM} ${WRKSRC}/bin/FreeBSD/x86/quake4smp.x86 ${PREFIX}/${Q4DIR}
.endif
@@ -82,7 +81,7 @@ do-install:
-exec ${INSTALL_DATA} "{}" "${PREFIX}/${Q4DIR}/{}" \;
# All version (except germany) or only germany version
-.if defined(WITH_GERMANY)
+.if ${PORT_OPTIONS:MGERMANY}
@cd ${WRKSRC}/germany && \
${FIND} -E q4base -type f -iregex ".*\.(pk4)" \
-exec ${INSTALL_DATA} "{}" "${PREFIX}/${Q4DIR}/{}" \;
@@ -93,7 +92,7 @@ do-install:
.endif
# Documentation
-.if !defined (NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@cd ${WRKSRC}/Docs && \
${FIND} * -type d -exec ${MKDIR} "${DOCSDIR}/{}" \; && \
${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DOCSDIR}/{}" \;
diff --git a/games/linux-quake4/pkg-plist b/games/linux-quake4/pkg-plist
index 19640fb8a0ef..067276c60352 100644
--- a/games/linux-quake4/pkg-plist
+++ b/games/linux-quake4/pkg-plist
@@ -1,4 +1,4 @@
-%%SMP%%bin/linux-quake4smp
+%%THREADS%%bin/linux-quake4smp
bin/linux-q4ded
bin/linux-quake4
%%Q4DIR%%/pb/htm/la001307.htm
@@ -58,7 +58,7 @@ bin/linux-quake4
%%Q4DIR%%/q4base/zpak_spanish_02.pk4.off
%%Q4DIR%%/q4base/zpak_spanish_03.pk4.off
%%Q4DIR%%/q4base/zpak_spanish_04.pk4.off
-%%SMP%%%%Q4DIR%%/quake4smp.x86
+%%THREADS%%%%Q4DIR%%/quake4smp.x86
%%Q4DIR%%/q4ded.x86
%%Q4DIR%%/quake4.x86
%%PORTDOCS%%%%DOCSDIR%%/ENG/License.txt