aboutsummaryrefslogtreecommitdiff
path: root/games/linux-rtcw
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-06-18 14:45:21 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-06-18 14:45:21 +0000
commit59c0cb50abfc14cb48d8903ba9155d67e9a5ecb2 (patch)
treebde9bc33d7e43d6cd0a3bf9d5249a40962495ecb /games/linux-rtcw
parentda2ef4f03e0dc92595ab49212b4d130f54b3a515 (diff)
downloadports-59c0cb50abfc14cb48d8903ba9155d67e9a5ecb2.tar.gz
ports-59c0cb50abfc14cb48d8903ba9155d67e9a5ecb2.zip
Notes
Diffstat (limited to 'games/linux-rtcw')
-rw-r--r--games/linux-rtcw/Makefile63
-rw-r--r--games/linux-rtcw/distinfo2
-rw-r--r--games/linux-rtcw/pkg-descr10
-rw-r--r--games/linux-rtcw/pkg-message15
-rw-r--r--games/linux-rtcw/pkg-plist57
5 files changed, 147 insertions, 0 deletions
diff --git a/games/linux-rtcw/Makefile b/games/linux-rtcw/Makefile
new file mode 100644
index 000000000000..00db4da8c571
--- /dev/null
+++ b/games/linux-rtcw/Makefile
@@ -0,0 +1,63 @@
+# Created by: Nik Clayton <nik@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= rtcw
+DISTVERSION= 1.41b
+CATEGORIES= games linux
+MASTER_SITES= ${MASTER_SITE_IDSOFTWARE}
+MASTER_SITE_SUBDIR= wolf/linux
+PKGNAMEPREFIX= linux-
+DISTNAME= wolf-linux-${DISTVERSION}.x86
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Return to Castle Wolfenstein (Linux version)
+
+USE_MAKESELF= yes
+USE_LINUX= yes
+USE_LINUX_APPS= dri xorglibs
+NO_WRKSUBDIR= yes
+
+WRAPPERS= wolf wolfded wolfsp
+
+# Ignore older version which seems to be newer
+PORTSCOUT= skipv:1.41-3
+
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+# XXX: should probably be converted to use the LICENSE framework
+post-extract:
+ @${MV} ${WRKSRC}/pb/PB_EULA.txt ${WRKSRC}
+
+do-build:
+.for f in ${WRAPPERS}
+ (${ECHO_CMD} "#!${SH}"; ${ECHO_CMD}; \
+ ${ECHO_CMD} "cd ${DATADIR} || exit 1"; \
+ ${ECHO_CMD} 'exec ./${f} "$$@"') > ${WRKDIR}/${f}
+.endfor
+
+do-install:
+ @${MKDIR} ${DATADIR}
+.for f in ${WRAPPERS}
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/Linux/x86/${f}.x86 ${DATADIR}/${f}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${f} ${PREFIX}/bin
+.endfor
+ ${CP} -a ${WRKSRC}/main ${WRKSRC}/pb ${DATADIR}
+ @${MKDIR} ${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/Wolf[MS]P.xpm ${PREFIX}/share/pixmaps
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && \
+ ${INSTALL_DATA} CHANGES INSTALL QUICKSTART *.txt ${DOCSDIR}
+ ${CP} -a ${WRKSRC}/Docs ${DOCSDIR}
+.endif
+
+post-install:
+ @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
+
+.include <bsd.port.mk>
diff --git a/games/linux-rtcw/distinfo b/games/linux-rtcw/distinfo
new file mode 100644
index 000000000000..ff611ab6cf75
--- /dev/null
+++ b/games/linux-rtcw/distinfo
@@ -0,0 +1,2 @@
+SHA256 (wolf-linux-1.41b.x86.run) = 2921425c1b429147c1bc6f0c6a8664bec502ae86a2d6bccfaa1162f75dce89f3
+SIZE (wolf-linux-1.41b.x86.run) = 73940068
diff --git a/games/linux-rtcw/pkg-descr b/games/linux-rtcw/pkg-descr
new file mode 100644
index 000000000000..47e643aa78d1
--- /dev/null
+++ b/games/linux-rtcw/pkg-descr
@@ -0,0 +1,10 @@
+Return to Castle Wolfenstein is a remake of sorts of the id's early, seminal
+first-person shooter, Wolfenstein 3D. However, with the advances in graphics
+technology and gameplay design since the original game, without the name and
+the occasional in-game references, it would be unrecognizable as a remake.
+
+Unlike the original Wolfenstein 3D, only a handful of the single player
+missions in Return to Castle Wolfenstein takes place in the infamous castle
+and prison.
+
+WWW: http://www.idsoftware.com/games/wolfenstein/rtcw/
diff --git a/games/linux-rtcw/pkg-message b/games/linux-rtcw/pkg-message
new file mode 100644
index 000000000000..1dac7d4050fb
--- /dev/null
+++ b/games/linux-rtcw/pkg-message
@@ -0,0 +1,15 @@
+==============================================================================
+
+ Linux version of Return to Castle Wolfenstein has been installed.
+
+ To be able to play the game, you need to copy the files "mp_pak0.pk3",
+ "pak0.pk3", and "sp_pak1.pk3" from the RtCW distribution (in the "main"
+ subdirectory) to your $HOME/.wolf/main directory.
+
+ Below is the list of required packfiles, with their MD5 checksums:
+
+ MD5 (main/mp_pak0.pk3) = 62641cffd9a8ad0f62cc1cca867d51f8
+ MD5 (main/pak0.pk3) = ce92b11df889cb0a045762bb5fd7cde5
+ MD5 (main/sp_pak1.pk3) = a0d3fe956f85f40c8efd6babe0d09832
+
+==============================================================================
diff --git a/games/linux-rtcw/pkg-plist b/games/linux-rtcw/pkg-plist
new file mode 100644
index 000000000000..c586a4407328
--- /dev/null
+++ b/games/linux-rtcw/pkg-plist
@@ -0,0 +1,57 @@
+bin/wolf
+bin/wolfded
+bin/wolfsp
+%%DATADIR%%/main/cgame.mp.i386.so
+%%DATADIR%%/main/cgamei386.so
+%%DATADIR%%/main/mp_bin.pk3
+%%DATADIR%%/main/mp_pak1.pk3
+%%DATADIR%%/main/mp_pak2.pk3
+%%DATADIR%%/main/mp_pak3.pk3
+%%DATADIR%%/main/mp_pak4.pk3
+%%DATADIR%%/main/mp_pak5.pk3
+%%DATADIR%%/main/mp_pakmaps0.pk3
+%%DATADIR%%/main/mp_pakmaps1.pk3
+%%DATADIR%%/main/mp_pakmaps2.pk3
+%%DATADIR%%/main/mp_pakmaps3.pk3
+%%DATADIR%%/main/mp_pakmaps4.pk3
+%%DATADIR%%/main/mp_pakmaps5.pk3
+%%DATADIR%%/main/mp_pakmaps6.pk3
+%%DATADIR%%/main/qagame.mp.i386.so
+%%DATADIR%%/main/qagamei386.so
+%%DATADIR%%/main/rotate.cfg
+%%DATADIR%%/main/scripts/translation.cfg
+%%DATADIR%%/main/sp_pak2.pk3
+%%DATADIR%%/main/sp_pak3.pk3
+%%DATADIR%%/main/ui.mp.i386.so
+%%DATADIR%%/main/uii386.so
+%%DATADIR%%/pb/htm/la001289.htm
+%%DATADIR%%/pb/htm/la001293.htm
+%%DATADIR%%/pb/htm/lc000989.htm
+%%DATADIR%%/pb/htm/lc000993.htm
+%%DATADIR%%/pb/htm/ls000989.htm
+%%DATADIR%%/pb/htm/ls000993.htm
+%%DATADIR%%/pb/htm/ma001289.htm
+%%DATADIR%%/pb/htm/ma001293.htm
+%%DATADIR%%/pb/htm/mc000989.htm
+%%DATADIR%%/pb/htm/mc000993.htm
+%%DATADIR%%/pb/htm/ms000989.htm
+%%DATADIR%%/pb/htm/ms000993.htm
+%%DATADIR%%/pb/htm/wa001289.htm
+%%DATADIR%%/pb/htm/wa001293.htm
+%%DATADIR%%/pb/htm/wc000989.htm
+%%DATADIR%%/pb/htm/wc000993.htm
+%%DATADIR%%/pb/htm/ws000989.htm
+%%DATADIR%%/pb/htm/ws000993.htm
+%%DATADIR%%/pb/pbag.so
+%%DATADIR%%/pb/pbcl.so
+%%DATADIR%%/pb/pbsv.so
+%%DATADIR%%/wolf
+%%DATADIR%%/wolfded
+%%DATADIR%%/wolfsp
+share/pixmaps/WolfMP.xpm
+share/pixmaps/WolfSP.xpm
+@dirrm %%DATADIR%%/pb/htm
+@dirrm %%DATADIR%%/pb
+@dirrm %%DATADIR%%/main/scripts
+@dirrm %%DATADIR%%/main
+@dirrm %%DATADIR%%