aboutsummaryrefslogtreecommitdiff
path: root/games/linux-steam-utils
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2021-03-08 01:36:03 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-03-08 01:36:03 +0000
commitaf09ec22887610ef4007db74582b8aba60ee439b (patch)
tree4c9e3845760c7060bc2036dc8fc8f4b143f88ecb /games/linux-steam-utils
parentaaf022782c5061985e5d8ff2eaf2536158850314 (diff)
downloadports-af09ec22887610ef4007db74582b8aba60ee439b.tar.gz
ports-af09ec22887610ef4007db74582b8aba60ee439b.zip
games/linux-steam-utils: update to 20210303
Changes: https://github.com/shkhln/linuxulator-steam-utils/compare/20201010...20210303 PR: 254104 Submitted by: Alex S <iwtcex AT gmail DOT com> (maintainer)
Notes
Notes: svn path=/head/; revision=567815
Diffstat (limited to 'games/linux-steam-utils')
-rw-r--r--games/linux-steam-utils/Makefile20
-rw-r--r--games/linux-steam-utils/distinfo6
-rw-r--r--games/linux-steam-utils/pkg-message26
-rw-r--r--games/linux-steam-utils/pkg-plist16
4 files changed, 42 insertions, 26 deletions
diff --git a/games/linux-steam-utils/Makefile b/games/linux-steam-utils/Makefile
index 91fb9d5ee339..810f34228d98 100644
--- a/games/linux-steam-utils/Makefile
+++ b/games/linux-steam-utils/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= steam-utils
-DISTVERSION= 20201010
+DISTVERSION= 20210303
CATEGORIES= games linux
PKGNAMEPREFIX= linux-
@@ -18,26 +18,26 @@ RUN_DEPENDS= ca_root_nss>=0:security/ca_root_nss \
liberation-fonts-ttf>=0:x11-fonts/liberation-fonts-ttf
USES= linux
-USE_LINUX= devtools:build dbuslibs gtk2 dri nss alsa-plugins-oss
-USE_RUBY= yes
-
-RUBY_NO_BUILD_DEPENDS= yes
USE_GITHUB= yes
GH_ACCOUNT= shkhln
GH_PROJECT= linuxulator-steam-utils
-ALL_TARGET= build
+USE_LINUX= devtools:build dbuslibs gtk2 dri nss alsa-plugins-oss
+USE_RUBY= yes
+
+RUBY_NO_BUILD_DEPENDS= yes
+
MAKE_ARGS+= PREFIX=${STAGEDIR}${PREFIX}
+ALL_TARGET= build
+
+PORTSCOUT= ignore:1
.include <bsd.port.options.mk>
post-install:
-.for executable in steam steam-install
+.for executable in steam steam-install lsu-pkg32 lsu-register-proton lsu-wine-env
${LN} -s ../steam-utils/bin/${executable} ${STAGEDIR}${PREFIX}/bin/${executable}
.endfor
-.if ${OSVERSION} >= 1300082
- ${REINPLACE_CMD} -e '/fmodfix.so/d' ${TMPPLIST}
-.endif
.include <bsd.port.mk>
diff --git a/games/linux-steam-utils/distinfo b/games/linux-steam-utils/distinfo
index 357ac50ff6a7..73cc4f9622ff 100644
--- a/games/linux-steam-utils/distinfo
+++ b/games/linux-steam-utils/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1602306918
-SHA256 (shkhln-linuxulator-steam-utils-20201010_GH0.tar.gz) = 93a3d20cf39b77d5062d434478302879017af14e1c835582f5b583e016c4f40d
-SIZE (shkhln-linuxulator-steam-utils-20201010_GH0.tar.gz) = 18761
+TIMESTAMP = 1615131367
+SHA256 (shkhln-linuxulator-steam-utils-20210303_GH0.tar.gz) = 9e2e6c01ebf4af38709ec11270ab97b8c3c97fa8800d14b371ea4ea3a62c0fbb
+SIZE (shkhln-linuxulator-steam-utils-20210303_GH0.tar.gz) = 17932
diff --git a/games/linux-steam-utils/pkg-message b/games/linux-steam-utils/pkg-message
index 05235076e865..1073dbdab2ab 100644
--- a/games/linux-steam-utils/pkg-message
+++ b/games/linux-steam-utils/pkg-message
@@ -4,22 +4,34 @@
Please note, this is an unofficial wrapper for the Steam client
and as such it is supported on a best effort basis.
+Limitations:
+
+- Sandbox is disabled for the web browser component.
+- Valve Anti-Cheat doesn't work with FreeBSD < 13.
+- No controller input, no streaming, no VR.
+- No support for Linux Proton builds.
+
Additional dependencies:
-- If you use a NVIDIA card, you need to install a suitable
+- If you use an NVIDIA card, you need to install a suitable
x11/linux-nvidia-libs(-xxx) port.
-Setup:
+Steam setup:
1. Create a dedicated FreeBSD non-wheel user account for Steam. Switch to it.
2. Run `steam-install` to download the Steam bootstrap executable.
3. Run `steam` to download updates and start Steam.
-Limitations:
+For the list of tested Linux games see https://github.com/shkhln/linuxulator-steam-utils/wiki/Compatibility.
-- Sandbox is disabled for the web browser component.
-- Valve Anti-Cheat doesn't seem to work properly.
-- No controller input, no streaming, no VR.
-- No Proton (Steam Play).
+Native Proton setup (optional, semi-experimental):
+
+1. Run `sudo pkg install wine-proton libc6-shim python3` and `lsu-pkg32 install wine-proton mesa-dri`.
+2. In Steam install Proton 5.13 (appid 1420170) and Steam Linux Runtime - Soldier (appid 1391110).
+3. Run `lsu-register-proton` to register emulators/wine-proton as a compatibility tool.
+4. Restart Steam.
+
+To enable emulators/wine-proton right click a game title in Steam,
+click Properties, click Compatibility, select emulators/wine-proton.
EOM
}
]
diff --git a/games/linux-steam-utils/pkg-plist b/games/linux-steam-utils/pkg-plist
index 37622871a7c6..f3d6ae836443 100644
--- a/games/linux-steam-utils/pkg-plist
+++ b/games/linux-steam-utils/pkg-plist
@@ -1,27 +1,31 @@
+bin/lsu-pkg32
+bin/lsu-register-proton
+bin/lsu-wine-env
bin/steam
bin/steam-install
+steam-utils/bin/lsu-pkg32
+steam-utils/bin/lsu-register-proton
+steam-utils/bin/lsu-wine-env
steam-utils/bin/steam
steam-utils/bin/steam-install
steam-utils/lib32/fakenm/libnm-glib.so.4
steam-utils/lib32/fakepulse/libpulse.so.0
steam-utils/lib32/fakeudev/libudev.so.0
-steam-utils/lib32/fmodfix/fmodfix.so
+steam-utils/lib32/monofix/monofix.so
steam-utils/lib32/pathfix/pathfix.so
@comment steam-utils/lib32/protonfix/protonfix.so
steam-utils/lib32/steamfix/steamfix.so
steam-utils/lib64/fakepulse/libpulse.so.0
steam-utils/lib64/fakeudev/libudev.so.0
-steam-utils/lib64/fmodfix/fmodfix.so
+steam-utils/lib64/monofix/monofix.so
steam-utils/lib64/pathfix/pathfix.so
@comment steam-utils/lib64/protonfix/protonfix.so
steam-utils/lib64/webfix/webfix.so
steam-utils/lxbin/dbus-launch
-steam-utils/lxbin/fhelper32
-steam-utils/lxbin/fhelper64
steam-utils/lxbin/file
steam-utils/lxbin/file.rb
-steam-utils/lxbin/patch-steam
-steam-utils/lxbin/patch-steam.rb
+steam-utils/lxbin/lsu-proton
@comment steam-utils/lxbin/python3
steam-utils/lxbin/upgrade-steam-runtime
steam-utils/lxbin/upgrade-steam-runtime.rb
+steam-utils/lxbin/xrandr