aboutsummaryrefslogtreecommitdiff
path: root/games/linux-unigine-heaven
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-02-09 03:53:52 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-02-09 03:53:52 +0000
commit45293e29168cc1578d82257db9850c9087c0111a (patch)
treefc2126de98f822f10a5c426a365162cdc96104bb /games/linux-unigine-heaven
parent1ec9be811c20995bf11f8e8dca04e38c947765b1 (diff)
downloadports-45293e29168cc1578d82257db9850c9087c0111a.tar.gz
ports-45293e29168cc1578d82257db9850c9087c0111a.zip
New port: games/linux-unigine-heaven
Heaven Benchmark immerses a user into a magical steampunk world of shiny brass, wood and gears. Nested on flying islands, a tiny village with its cozy, sun-heated cobblestone streets, an elaborately crafted dirigible above the expanse of fluffy clouds, and a majestic dragon on the central square gives a true sense of adventure. An interactive experience with fly-by and walk-through modes allows for exploring all corners of this world powered by the cutting-edge UNIGINE Engine that leverages the most advanced capabilities of graphics APIs and turns this benchmark into a visual masterpiece. This port includes the linux-binaries of the basic (free-to-use) version of the benchmark. WWW: http://unigine.com/products/heaven/ PR: 194472 Submitted by: Hannes Hauswedell <h2+fbsdports@fsfe.org> Reviewed by: marino, d.akiyakov@gmail.com
Notes
Notes: svn path=/head/; revision=408535
Diffstat (limited to 'games/linux-unigine-heaven')
-rw-r--r--games/linux-unigine-heaven/Makefile54
-rw-r--r--games/linux-unigine-heaven/distinfo2
-rw-r--r--games/linux-unigine-heaven/pkg-descr14
-rw-r--r--games/linux-unigine-heaven/pkg-plist66
4 files changed, 136 insertions, 0 deletions
diff --git a/games/linux-unigine-heaven/Makefile b/games/linux-unigine-heaven/Makefile
new file mode 100644
index 000000000000..b8ee531bfb06
--- /dev/null
+++ b/games/linux-unigine-heaven/Makefile
@@ -0,0 +1,54 @@
+# Created by: Hannes Hauswedell <h2+fbsdports@fsfe.org>
+# $FreeBSD$
+
+PORTNAME= unigine-heaven
+PORTVERSION= 4.0
+CATEGORIES= games linux
+MASTER_SITES= http://de1-dl.techpowerup.com/Benchmarking/ \
+ http://nl1-dl.techpowerup.com/Benchmarking/ \
+ http://uk1-dl.techpowerup.com/Benchmarking/ \
+ http://us1-dl.techpowerup.com/Benchmarking/ \
+ http://us2-dl.techpowerup.com/Benchmarking/
+PKGNAMEPREFIX= linux-
+DISTNAME= Unigine_Heaven-${PORTVERSION}
+EXTRACT_SUFX= .run
+
+MAINTAINER= h2+fbsdports@fsfe.org
+COMMENT= Unigine Heaven Benchmark, basic version, linux binaries
+
+LICENSE= Proprietary
+LICENSE_NAME= Unigine "Basic" License
+LICENSE_TEXT= Binary only, License text not available. Free-to-use + no-redistribution implied from homepage
+LICENSE_PERMS= no-dist-sell no-pkg-sell no-dist-mirror no-pkg-mirror
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX= yes
+USE_LINUX_APPS= xorglibs openal-soft
+USE_LDCONFIG= yes
+NO_BUILD= yes
+
+OPTIONS_DEFINE= NVIDIA_GL
+NVIDIA_GL_DESC= Use GL driver from nvidia-driver
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNVIDIA_GL}
+RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
+.else
+USE_LINUX_APPS+=dri
+.endif
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ cd ${WRKSRC} && ${TAIL} -n 1098568 ${_DISTDIR}/${DISTFILES} | ${TAR} zxf -
+ ${PRINTF} "#\!/bin/sh\ncd ${DATADIR}/bin/\n" > ${WRKDIR}/${PORTNAME}
+ ${ECHO} 'export LD_LIBRARY_PATH=./x86:$$LD_LIBRARY_PATH' >> ${WRKDIR}/${PORTNAME}
+ ${ECHO} './browser_x86 -config ../data/launcher/launcher.xml' >> ${WRKDIR}/${PORTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PKGNAMEPREFIX}${PORTNAME}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} ./data ${STAGEDIR}${DATADIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} ./bin ${STAGEDIR}${DATADIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} ./documentation ${STAGEDIR}${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/games/linux-unigine-heaven/distinfo b/games/linux-unigine-heaven/distinfo
new file mode 100644
index 000000000000..801185ca2fc9
--- /dev/null
+++ b/games/linux-unigine-heaven/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Unigine_Heaven-4.0.run) = 90e6f95bb3c0d92f557a948ca6754b1b1bead07a063ec2af0ce03ef8e7ac74f3
+SIZE (Unigine_Heaven-4.0.run) = 286329188
diff --git a/games/linux-unigine-heaven/pkg-descr b/games/linux-unigine-heaven/pkg-descr
new file mode 100644
index 000000000000..e95ed824c483
--- /dev/null
+++ b/games/linux-unigine-heaven/pkg-descr
@@ -0,0 +1,14 @@
+Heaven Benchmark immerses a user into a magical steampunk world of
+shiny brass, wood and gears. Nested on flying islands, a tiny village
+with its cozy, sun-heated cobblestone streets, an elaborately crafted
+dirigible above the expanse of fluffy clouds, and a majestic dragon
+on the central square gives a true sense of adventure. An interactive
+experience with fly-by and walk-through modes allows for exploring
+all corners of this world powered by the cutting-edge UNIGINE Engine
+that leverages the most advanced capabilities of graphics APIs and
+turns this benchmark into a visual masterpiece.
+
+This port includes the linux-binaries of the basic (free-to-use)
+version of the benchmark.
+
+WWW: http://unigine.com/products/heaven/
diff --git a/games/linux-unigine-heaven/pkg-plist b/games/linux-unigine-heaven/pkg-plist
new file mode 100644
index 000000000000..262db4edacf2
--- /dev/null
+++ b/games/linux-unigine-heaven/pkg-plist
@@ -0,0 +1,66 @@
+@mode 755
+bin/linux-unigine-heaven
+%%DATADIR%%/bin/browser_x64
+%%DATADIR%%/bin/browser_x86
+%%DATADIR%%/bin/heaven_x64
+%%DATADIR%%/bin/heaven_x86
+@mode
+%%DATADIR%%/bin/libAppStereo_x64.so
+%%DATADIR%%/bin/libAppStereo_x86.so
+%%DATADIR%%/bin/libAppSurround_x64.so
+%%DATADIR%%/bin/libAppSurround_x86.so
+%%DATADIR%%/bin/libAppWall_x64.so
+%%DATADIR%%/bin/libAppWall_x86.so
+%%DATADIR%%/bin/libGPUMonitor_x64.so
+%%DATADIR%%/bin/libGPUMonitor_x86.so
+%%DATADIR%%/bin/libQtCoreUnigine_x64.so.4
+%%DATADIR%%/bin/libQtCoreUnigine_x86.so.4
+%%DATADIR%%/bin/libQtGuiUnigine_x64.so.4
+%%DATADIR%%/bin/libQtGuiUnigine_x86.so.4
+%%DATADIR%%/bin/libQtNetworkUnigine_x64.so.4
+%%DATADIR%%/bin/libQtNetworkUnigine_x86.so.4
+%%DATADIR%%/bin/libQtWebKitUnigine_x64.so.4
+%%DATADIR%%/bin/libQtWebKitUnigine_x86.so.4
+%%DATADIR%%/bin/libQtXmlUnigine_x64.so.4
+%%DATADIR%%/bin/libQtXmlUnigine_x86.so.4
+%%DATADIR%%/bin/libUnigine_x64.so
+%%DATADIR%%/bin/libUnigine_x86.so
+%%DATADIR%%/bin/x64/libopenal.so
+%%DATADIR%%/bin/x86/libopenal.so
+%%DATADIR%%/data/core.ung
+%%DATADIR%%/data/heaven-version
+%%DATADIR%%/data/heaven.ung
+%%DATADIR%%/data/heaven_4.0.cfg
+%%DATADIR%%/data/launcher/banners/oil-rush-v1/code.js
+%%DATADIR%%/data/launcher/banners/oil-rush-v1/content.html
+%%DATADIR%%/data/launcher/banners/oil-rush-v1/oil-rush-v1.banner
+%%DATADIR%%/data/launcher/banners/oil-rush-v1/style.css
+%%DATADIR%%/data/launcher/banners/update/content.html
+%%DATADIR%%/data/launcher/banners/update/style.css
+%%DATADIR%%/data/launcher/banners/update/update.banner
+%%DATADIR%%/data/launcher/icon.png
+%%DATADIR%%/data/launcher/interface.html
+%%DATADIR%%/data/launcher/js/browser.js
+%%DATADIR%%/data/launcher/js/heaven-ui-logic.js
+%%DATADIR%%/data/launcher/js/hquality.js
+%%DATADIR%%/data/launcher/js/jquery-ui.selectmenu.js
+%%DATADIR%%/data/launcher/launcher.xml
+%%DATADIR%%/data/launcher/style/images/background-pro.png
+%%DATADIR%%/data/launcher/style/images/background.png
+%%DATADIR%%/data/launcher/style/images/button_run_selected.png
+%%DATADIR%%/data/launcher/style/images/button_run_simple.png
+%%DATADIR%%/data/launcher/style/images/button_unigine_selected.png
+%%DATADIR%%/data/launcher/style/images/button_unigine_simple.png
+%%DATADIR%%/data/launcher/style/images/checkbox.png
+%%DATADIR%%/data/launcher/style/images/get_products_selected.png
+%%DATADIR%%/data/launcher/style/images/get_products_simple.png
+%%DATADIR%%/data/launcher/style/images/other_products_icon.png
+%%DATADIR%%/data/launcher/style/images/other_products_icon_selected.png
+%%DATADIR%%/data/launcher/style/images/upgrade_icon.png
+%%DATADIR%%/data/launcher/style/images/upgrade_icon_selected.png
+%%DATADIR%%/data/launcher/style/images/upgrade_selected.png
+%%DATADIR%%/data/launcher/style/images/upgrade_simple.png
+%%DATADIR%%/data/launcher/style/jquery-ui.selectmenu.css
+%%DATADIR%%/data/launcher/style/project.css
+%%DATADIR%%/data/launcher/style/style.css
+%%DATADIR%%/documentation/User_Manual.pdf