aboutsummaryrefslogtreecommitdiff
path: root/games/linux-uplink-demo
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-09-05 19:23:42 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-09-05 19:23:42 +0000
commit82a87de90c337aae160ac254606dad78d0d78d11 (patch)
tree516db145d6cf5fd4d2666f811272aad577272ac5 /games/linux-uplink-demo
parentf22162b04be45bf28d125c67ee0a841fb1ae4b55 (diff)
downloadports-82a87de90c337aae160ac254606dad78d0d78d11.tar.gz
ports-82a87de90c337aae160ac254606dad78d0d78d11.zip
Notes
Diffstat (limited to 'games/linux-uplink-demo')
-rw-r--r--games/linux-uplink-demo/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/games/linux-uplink-demo/Makefile b/games/linux-uplink-demo/Makefile
index 94b007b58f71..2904c30deff0 100644
--- a/games/linux-uplink-demo/Makefile
+++ b/games/linux-uplink-demo/Makefile
@@ -13,8 +13,8 @@ MAINTAINER= mva@FreeBSD.org
COMMENT= High tech computer crime and industrial espionage on the Internet
ONLY_FOR_ARCHS= i386 amd64
-USE_LINUX= yes
-USE_LINUX_APPS= sdl12 jpeg sdlmixer mikmod libvorbis xorglibs
+USES= linux
+USE_LINUX= sdl12 jpeg sdlmixer mikmod libvorbis xorglibs
USE_LDCONFIG= yes
NO_CDROM= Redistribution is limited, see license
NO_BUILD= yes
@@ -32,24 +32,21 @@ NVIDIA_DESC= support for nvidia
.if ${PORT_OPTIONS:MNVIDIA}
RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-USE_LINUX_APPS+=libglu
+USE_LINUX+= libglu
.else
-USE_LINUX_APPS+=dri
+USE_LINUX+= dri
.endif
do-extract:
@cd ${WRKSRC} && ${TAIL} +376 ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} | \
${TAR} zxf -
-do-build:
- ${BRANDELF} -t Linux ${WRKSRC}/lib/uplink.bin.x86
-
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}
@cd ${WRKSRC}/lib && \
${INSTALL_PROGRAM} uplink.bin.x86 libftgl.so.0 ${STAGEDIR}${DATADIR} && \
${INSTALL_DATA} *.dat ${STAGEDIR}${DATADIR}
- ${INSTALL_PROGRAM} ${WRKDIR}/uplink \
+ ${INSTALL_SCRIPT} ${WRKDIR}/uplink \
${STAGEDIR}${PREFIX}/bin/${PKGNAMEPREFIX}uplink
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in ${DOCFILES}