aboutsummaryrefslogtreecommitdiff
path: root/games/linux-ut2003-demo
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-09-04 15:45:01 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-09-04 15:45:01 +0000
commita681a2623f96ead273162164d90cb4cb007094d6 (patch)
treeab22f8be404c640ceb361b539d233455841c96fa /games/linux-ut2003-demo
parent22696ecbedfee689a8db832c48c0f5c0589e5a05 (diff)
downloadports-a681a2623f96ead273162164d90cb4cb007094d6.tar.gz
ports-a681a2623f96ead273162164d90cb4cb007094d6.zip
Add a missing runtime dependency on libGL.
Reported by: kris Approved by: maintainer
Notes
Notes: svn path=/head/; revision=141932
Diffstat (limited to 'games/linux-ut2003-demo')
-rw-r--r--games/linux-ut2003-demo/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/games/linux-ut2003-demo/Makefile b/games/linux-ut2003-demo/Makefile
index a7c6ca36cbc7..bb1bd5777626 100644
--- a/games/linux-ut2003-demo/Makefile
+++ b/games/linux-ut2003-demo/Makefile
@@ -41,6 +41,18 @@ PORTDOCS= *
LIBDIRS= Animations Benchmark ForceFeedback KarmaData Maps Music \
Sounds StaticMeshes System Textures Web
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} != xfree86-3
+.if defined(WITH_NVIDIA_GL)
+RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
+.else
+RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+.endif
+.else
+RUN_DEPENDS+= ${LINUXBASE}/lib/libGL.so.1:${PORTSDIR}/graphics/linux_glx
+.endif
+
do-extract:
@${MKDIR} ${WRKSRC}
@cd ${WRKSRC} && ${TAIL} -c +6360 ${_DISTDIR}/${DISTFILES} | ${TAR} zxf -
@@ -82,4 +94,4 @@ do-install:
. endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>