aboutsummaryrefslogtreecommitdiff
path: root/games/linux-ut
diff options
context:
space:
mode:
authorJean Milanez Melo <jmelo@FreeBSD.org>2007-07-09 19:10:26 +0000
committerJean Milanez Melo <jmelo@FreeBSD.org>2007-07-09 19:10:26 +0000
commit6c575e22a298e54dae35edec27cd939da01fbbdd (patch)
tree219b646b83ffb39862448df2cb2f817447b38a54 /games/linux-ut
parent09e91aec257a338a28d57d9ec4d64c5add176542 (diff)
downloadports-6c575e22a298e54dae35edec27cd939da01fbbdd.tar.gz
ports-6c575e22a298e54dae35edec27cd939da01fbbdd.zip
- Fix mastersite.
- Remove /usr/local from ut-bin binary. PR: ports/113934 Submitted by: Sean Farley <sean-freebsd@farley.org> (maintainer)
Notes
Notes: svn path=/head/; revision=195321
Diffstat (limited to 'games/linux-ut')
-rw-r--r--games/linux-ut/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/games/linux-ut/Makefile b/games/linux-ut/Makefile
index 618b962b676e..c7022b036547 100644
--- a/games/linux-ut/Makefile
+++ b/games/linux-ut/Makefile
@@ -8,7 +8,7 @@
PORTNAME= linux-ut
PORTVERSION= 451
CATEGORIES= games linux
-MASTER_SITES= http://liflg.0wnitsch.de/files/native/:p436 \
+MASTER_SITES= http://liflg.0wnitsch.de/files/final/:p436 \
http://www.utpg.org/patches/:p451
DISTFILES= ${PATCH436FILES} \
${PATCH451FILES}
@@ -112,6 +112,13 @@ do-install:
${MV} -f galaxy.int Galaxy.int &&\
${MV} -f editor.int Editor.int &&\
${MV} -f windrv.int WinDrv.int
+ @${ECHO_CMD} "Removing /usr/local from ut-bin's library search path"
+ @UTBIN=${DATADIR}/System/ut-bin &&\
+ FILESIZE=`/usr/bin/stat -f "%z" $${UTBIN}` &&\
+ ${MV} $${UTBIN} $${UTBIN}.orig &&\
+ ${SED} -Ee 's|:/usr/local|:/USR-LOCAL|' $${UTBIN}.orig |\
+ ${HEAD} -c $${FILESIZE} > $${UTBIN} &&\
+ ${RM} $${UTBIN}.orig
@${ECHO_CMD} "Setting permissions"
@${FIND} ${DATADIR} -print0 |\
${XARGS} -0 ${CHOWN} ${SHAREOWN}:${SHAREGRP}