aboutsummaryrefslogtreecommitdiff
path: root/games/lolcat
diff options
context:
space:
mode:
authorLuca Pizzamiglio <pizzamig@FreeBSD.org>2020-07-11 20:26:49 +0000
committerLuca Pizzamiglio <pizzamig@FreeBSD.org>2020-07-11 20:26:49 +0000
commit8776db7698e3dc308277a2ae69800ca7269fdb98 (patch)
treea73c092046c09d83c9626cafef69ffebe2d19bab /games/lolcat
parentec55b02c40b13218bb7a52999a0d48de534bfaf2 (diff)
downloadports-8776db7698e3dc308277a2ae69800ca7269fdb98.tar.gz
ports-8776db7698e3dc308277a2ae69800ca7269fdb98.zip
games/lolcat: new port, a C implementation of the famous lolcat
High performance, energy-saving implmentation in C of lolcat NOTE: in MOVED, the previous entry lolcat -> rubygem-lolcat has been removed That is the only way to wupport this corner case. Submitted by: gbe@FreeBSD.org (maintainer) Differential Revision: https://reviews.freebsd.org/D25082
Notes
Notes: svn path=/head/; revision=542049
Diffstat (limited to 'games/lolcat')
-rw-r--r--games/lolcat/Makefile27
-rw-r--r--games/lolcat/distinfo3
-rw-r--r--games/lolcat/pkg-descr4
3 files changed, 34 insertions, 0 deletions
diff --git a/games/lolcat/Makefile b/games/lolcat/Makefile
new file mode 100644
index 000000000000..16da7283ad32
--- /dev/null
+++ b/games/lolcat/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= lolcat
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0-9
+DISTVERSIONSUFFIX= -ga83e59d
+CATEGORIES= games
+
+MAINTAINER= gbe@FreeBSD.org
+COMMENT= High performance implementation of the famous lolcat
+
+LICENSE= WTFPL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= gmake
+
+CONFLICTS_INSTALL= rubygem-lolcat
+
+USE_GITHUB= yes
+GH_ACCOUNT= jaseg
+
+PLIST_FILES= bin/censor bin/lolcat
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/censor ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/lolcat ${STAGEDIR}${PREFIX}/bin
+.include <bsd.port.mk>
diff --git a/games/lolcat/distinfo b/games/lolcat/distinfo
new file mode 100644
index 000000000000..02a1d62dba42
--- /dev/null
+++ b/games/lolcat/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1591195660
+SHA256 (jaseg-lolcat-v1.0-9-ga83e59d_GH0.tar.gz) = d618b719bea70b55f08b6c6fcb64ea25f895fd658625493986a1051de54e9b28
+SIZE (jaseg-lolcat-v1.0-9-ga83e59d_GH0.tar.gz) = 1703486
diff --git a/games/lolcat/pkg-descr b/games/lolcat/pkg-descr
new file mode 100644
index 000000000000..ccaf8c5e3f57
--- /dev/null
+++ b/games/lolcat/pkg-descr
@@ -0,0 +1,4 @@
+This is a high performance implementation of lolcat, which does
+the same as the unix "cat" programm, but in fancy rainbow colors.
+
+WWW: https://github.com/jaseg/lolcat