aboutsummaryrefslogtreecommitdiff
path: root/games/lwjgl
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-05-25 10:51:57 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-05-25 10:51:57 +0000
commita3b670146b84d1fb6e33b86a3fe1856395d31ddd (patch)
tree42fcddabe9a14d61d7fb541528da8f7c46f53728 /games/lwjgl
parentf1959fb671f4ffdaf2acf4fd600d7fac6cfc2c4d (diff)
downloadports-a3b670146b84d1fb6e33b86a3fe1856395d31ddd.tar.gz
ports-a3b670146b84d1fb6e33b86a3fe1856395d31ddd.zip
Update to version 2.9.0
PR: ports/178089 Submitted by: r4721@tormail.org
Notes
Notes: svn path=/head/; revision=319043
Diffstat (limited to 'games/lwjgl')
-rw-r--r--games/lwjgl/Makefile8
-rw-r--r--games/lwjgl/distinfo8
-rw-r--r--games/lwjgl/files/patch-build.xml20
-rw-r--r--games/lwjgl/files/patch-platform_build__bsd_ant__build.xml13
-rw-r--r--games/lwjgl/files/patch-platform_build__linux_ant__build.xml68
5 files changed, 21 insertions, 96 deletions
diff --git a/games/lwjgl/Makefile b/games/lwjgl/Makefile
index 73b1e7d58166..3d9cfa7cec27 100644
--- a/games/lwjgl/Makefile
+++ b/games/lwjgl/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= lwjgl
-DISTVERSION= 2.8.5
+DISTVERSION= 2.9.0
CATEGORIES= games java
MASTER_SITES= SF/java-game-lib/Official%20Releases/${PORTNAME:U}%20${PORTVERSION}/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
@@ -55,7 +55,7 @@ PLIST_FILES+= lib/${PORTNAME}${PORTVERSION}/lib${PORTNAME}64.so
post-patch:
@${REINPLACE_CMD} -e 's,PREFIX,${PREFIX},g' \
-e '/executable/s/gcc/${CC}/g' \
- ${WRKSRC}/platform_build/linux_ant/build.xml
+ ${WRKSRC}/platform_build/bsd_ant/build.xml
do-install:
@${ECHO_MSG} -n ">> Install JAR files in ${JAVAJARDIR}/${PORTNAME}/ ..."
@@ -66,10 +66,10 @@ do-install:
@${ECHO_MSG} " [ DONE ]"
@${MKDIR} ${PREFIX}/lib/${PORTNAME}${PORTVERSION}
.if ${ARCH} == i386
- @${INSTALL_DATA} ${WRKSRC}/libs/linux/lib${PORTNAME}.so ${PREFIX}/lib/${PORTNAME}${PORTVERSION}
+ @${INSTALL_DATA} ${WRKSRC}/libs/freebsd/lib${PORTNAME}.so ${PREFIX}/lib/${PORTNAME}${PORTVERSION}
.endif
.if ${ARCH} == amd64
- @${INSTALL_DATA} ${WRKSRC}/libs/linux/lib${PORTNAME}64.so ${PREFIX}/lib/${PORTNAME}${PORTVERSION}
+ @${INSTALL_DATA} ${WRKSRC}/libs/freebsd/lib${PORTNAME}64.so ${PREFIX}/lib/${PORTNAME}${PORTVERSION}
.endif
.include <bsd.port.post.mk>
diff --git a/games/lwjgl/distinfo b/games/lwjgl/distinfo
index 7870effa48d3..1b76dfd4b28e 100644
--- a/games/lwjgl/distinfo
+++ b/games/lwjgl/distinfo
@@ -1,4 +1,4 @@
-SHA256 (lwjgl-2.8.5.zip) = 680e4c9f84ca89fad844820019a9134c4643a00a44e3d6a02defb3d38700492c
-SIZE (lwjgl-2.8.5.zip) = 5550071
-SHA256 (lwjgl-source-2.8.5.zip) = b52f8885fb5a2cb9cd2528a9492164fccdf63031fbafb2ac96fd0f271fcbb130
-SIZE (lwjgl-source-2.8.5.zip) = 2969449
+SHA256 (lwjgl-2.9.0.zip) = b7baed854d8798048d5a96cff3b58bb050c9bf105c151ff5be461677cd5d7b7f
+SIZE (lwjgl-2.9.0.zip) = 5786081
+SHA256 (lwjgl-source-2.9.0.zip) = 8c7d978ee1c3c5d4a3f8fc8f9774cc9f1b3a371f95ed48bebd4bde8f7fe648ca
+SIZE (lwjgl-source-2.9.0.zip) = 2975604
diff --git a/games/lwjgl/files/patch-build.xml b/games/lwjgl/files/patch-build.xml
index 2260c3744546..925153835cff 100644
--- a/games/lwjgl/files/patch-build.xml
+++ b/games/lwjgl/files/patch-build.xml
@@ -8,23 +8,3 @@
<!-- ================================================================== -->
<!-- Everything below this line is targets. -->
-@@ -463,7 +462,10 @@
- <antcall target="-compile_native_win32" />
-
- <condition property="lwjgl.platform.linux">
-- <os name="Linux" />
-+ <or>
-+ <os name="Linux" />
-+ <os name="FreeBSD" />
-+ </or>
- </condition>
- <antcall target="-compile_native_linux" />
-
-@@ -604,6 +606,7 @@
- <condition property="native_path" value="libs/linux">
- <or>
- <os name="Linux" />
-+ <os name="FreeBSD" />
- <os name="SunOS" />
- </or>
- </condition>
diff --git a/games/lwjgl/files/patch-platform_build__bsd_ant__build.xml b/games/lwjgl/files/patch-platform_build__bsd_ant__build.xml
new file mode 100644
index 000000000000..f6c8403978c1
--- /dev/null
+++ b/games/lwjgl/files/patch-platform_build__bsd_ant__build.xml
@@ -0,0 +1,13 @@
+--- platform_build/bsd_ant/build.xml.orig
++++ platform_build/bsd_ant/build.xml
+@@ -4,8 +4,8 @@
+ <property name="native" location="../../src/native"/>
+ <property name="libname32" value="liblwjgl.so"/>
+ <property name="libname64" value="liblwjgl64.so"/>
+- <property name="libs32" value="-L/usr/X11R6/lib -L/usr/X11/lib -L/usr/local/lib -lm -lX11 -lXext -lXcursor -lXrandr -pthread -L${java.home}/lib/i386 -ljawt" />
+- <property name="libs64" value="-L/usr/X11R6/lib64 -L/usr/X11/lib64 -L/usr/local/lib -lm -lX11 -lXext -lXcursor -lXrandr -lXxf86vm -pthread -L${java.home}/lib/amd64 -ljawt" />
++ <property name="libs32" value="-LPREFIX/lib -lm -lX11 -lXext -lXcursor -lXrandr -pthread -L${java.home}/lib/i386 -ljawt" />
++ <property name="libs64" value="-LPREFIX/lib -lm -lX11 -lXext -lXcursor -lXrandr -lXxf86vm -pthread -L${java.home}/lib/amd64 -ljawt" />
+ <property name="cflags32" value="-O2 -Wall -c -fPIC -std=c99 -Wunused"/>
+
+ <target name="clean">
diff --git a/games/lwjgl/files/patch-platform_build__linux_ant__build.xml b/games/lwjgl/files/patch-platform_build__linux_ant__build.xml
deleted file mode 100644
index 31ae524dd408..000000000000
--- a/games/lwjgl/files/patch-platform_build__linux_ant__build.xml
+++ /dev/null
@@ -1,68 +0,0 @@
---- platform_build/linux_ant/build.xml.orig
-+++ platform_build/linux_ant/build.xml
-@@ -4,8 +4,8 @@
- <property name="native" location="../../src/native"/>
- <property name="libname32" value="liblwjgl.so"/>
- <property name="libname64" value="liblwjgl64.so"/>
-- <property name="libs32" value="-L/usr/X11R6/lib -L/usr/X11/lib -lm -lX11 -lXext -lXcursor -lXrandr -lpthread -L${java.home}/lib/i386 -ljawt" />
-- <property name="libs64" value="-L/usr/X11R6/lib64 -L/usr/X11/lib64 -lm -lX11 -lXext -lXcursor -lXrandr -lXxf86vm -lpthread -L${java.home}/lib/amd64 -ljawt" />
-+ <property name="libs32" value="-LPREFIX/lib -lm -lX11 -lXext -lXcursor -lXrandr -pthread -L${java.home}/lib/i386 -ljawt" />
-+ <property name="libs64" value="-LPREFIX/lib -lm -lX11 -lXext -lXcursor -lXrandr -lXxf86vm -pthread -L${java.home}/lib/amd64 -ljawt" />
- <property name="cflags32" value="-O2 -Wall -c -fPIC -std=c99 -Wunused"/>
-
- <target name="clean">
-@@ -46,6 +46,7 @@
- <not>
- <or>
- <equals arg1="${hwplatform}" arg2="x86_64"/>
-+ <equals arg1="${hwplatform}" arg2="amd64"/>
- <equals arg1="${hwplatform}" arg2="i86pc"/>
- </or>
- </not>
-@@ -53,10 +54,16 @@
-
- <!-- On linux, the 64 bit jre doesn't have the 32 bit libs -->
- <condition property="build.64bit.only">
-- <and>
-- <os name="Linux"/>
-- <equals arg1="${hwplatform}" arg2="x86_64"/>
-- </and>
-+ <or>
-+ <and>
-+ <os name="Linux"/>
-+ <equals arg1="${hwplatform}" arg2="x86_64"/>
-+ </and>
-+ <and>
-+ <os name="FreeBSD"/>
-+ <equals arg1="${hwplatform}" arg2="amd64"/>
-+ </and>
-+ </or>
- </condition>
-
- <antcall target="compile32"/>
-@@ -72,10 +79,12 @@
- <arg value="-I${java.home}/../include"/>
- <arg value="-I${java.home}/../include/linux"/>
- <arg value="-I${java.home}/../include/solaris"/>
-+ <arg value="-I${java.home}/../include/freebsd"/>
- <arg value="-I${native}/common"/>
- <arg value="-I${native}/common/opengl"/>
- <arg value="-I${native}/linux"/>
- <arg value="-I${native}/linux/opengl"/>
-+ <arg value="-IPREFIX/include"/>
- <mapper type="glob" from="*.c" to="*.o"/>
- <fileset dir="${native}/common" includes="*.c"/>
- <fileset dir="${native}/common/opengl" includes="*.c"/>
-@@ -104,10 +113,12 @@
- <arg value="-I${java.home}/../include"/>
- <arg value="-I${java.home}/../include/linux"/>
- <arg value="-I${java.home}/../include/solaris"/>
-+ <arg value="-I${java.home}/../include/freebsd"/>
- <arg value="-I${native}/common"/>
- <arg value="-I${native}/common/opengl"/>
- <arg value="-I${native}/linux"/>
- <arg value="-I${native}/linux/opengl"/>
-+ <arg value="-IPREFIX/include"/>
- <mapper type="glob" from="*.c" to="*.o"/>
- <fileset dir="${native}/common" includes="*.c"/>
- <fileset dir="${native}/common/opengl" includes="*.c"/>