aboutsummaryrefslogtreecommitdiff
path: root/games/maelstrom
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /games/maelstrom
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'games/maelstrom')
-rw-r--r--games/maelstrom/Makefile5
-rw-r--r--games/maelstrom/files/Makeflags4
2 files changed, 4 insertions, 5 deletions
diff --git a/games/maelstrom/Makefile b/games/maelstrom/Makefile
index 362bf8d4fb3b..43201cb6cb2c 100644
--- a/games/maelstrom/Makefile
+++ b/games/maelstrom/Makefile
@@ -7,7 +7,7 @@
PORTNAME= maelstrom
PORTVERSION= 3.0.6
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= games
MASTER_SITES= http://www.devolution.com/~slouken/projects/Maelstrom/src/
DISTNAME= Maelstrom-${PORTVERSION}
@@ -15,9 +15,8 @@ DISTNAME= Maelstrom-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Asteroids-style game for X Window System
-USE_X_PREFIX= yes
USE_SDL= sdl net
-USE_XPM= yes
+USE_XORG= xpm
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/games/maelstrom/files/Makeflags b/games/maelstrom/files/Makeflags
index de83567d2f66..f2721ebf85f1 100644
--- a/games/maelstrom/files/Makeflags
+++ b/games/maelstrom/files/Makeflags
@@ -20,12 +20,12 @@ OBJS = main.o framebuf.o v_framebuf.o x11_framebuf.o vga_framebuf.o \
Utils.o shared.o myerror.o
SOUNDOBJS = Maelstrom_sound.o Mac_Resource.o soundres.o mixer.o shared.o myerror.o
-X11INCLUDE = -I${X11BASE}/include
+X11INCLUDE = -I${LOCALBASE}/include
INCLUDES = -I$(LOGIC) $(X11INCLUDE) $(XPMINCLUDE)
CFLAGS += $(INCLUDES) $(FEATURES) \
-pedantic -DSYSTEM=\"$(SYSTEM)\" -DLIBDIR=\"$(LIBDIR)\"
EXTRALIBS =
-X11LINKDIR = -L${X11BASE}/lib
+X11LINKDIR = -L${LOCALBASE}/lib
X11LIBS = -lXpm $(XPMLINKDIR) -lX11 -lXext $(X11LINKDIR)
CSUMLIB =
LIBS = $(EXTRALIBS) $(X11LIBS) $(CSUMLIB)