aboutsummaryrefslogtreecommitdiff
path: root/games/maelstrom
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-12-28 16:11:08 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-12-28 16:11:08 +0000
commit49576030c2aac22b27e6b5d345759c56b1585e51 (patch)
tree702ff0f4296d00e5588395e8c505a7d69eb8c770 /games/maelstrom
parent176ecca3904bc920749093534fc9de031f5f176c (diff)
downloadports-49576030c2aac22b27e6b5d345759c56b1585e51.tar.gz
ports-49576030c2aac22b27e6b5d345759c56b1585e51.zip
- Change master sites
- Add DOCS Option - Support STAGEDIR, change DESTDIR - Change Desktop entry file - Disable all warnings with -w - Recreate patches with make makepatch Approved by: pawel / wg (mentors, implicit)
Notes
Notes: svn path=/head/; revision=337878
Diffstat (limited to 'games/maelstrom')
-rw-r--r--games/maelstrom/Makefile34
-rw-r--r--games/maelstrom/files/patch-buttonlist.h4
-rw-r--r--games/maelstrom/files/patch-configure4
-rw-r--r--games/maelstrom/files/patch-controls.cpp4
-rw-r--r--games/maelstrom/files/patch-dialog.h4
-rw-r--r--games/maelstrom/files/patch-load.cpp4
-rw-r--r--games/maelstrom/files/patch-maclib__Mac_FontServ.h (renamed from games/maelstrom/files/patch-maclib-Mac_FontServ.h)4
-rw-r--r--games/maelstrom/files/patch-maclib__Mac_Resource.h (renamed from games/maelstrom/files/patch-maclib-Mac_Resource.h)4
-rw-r--r--games/maelstrom/files/patch-maclib__Mac_Sound.h (renamed from games/maelstrom/files/patch-maclib-Mac_Sound.h)4
-rw-r--r--games/maelstrom/files/patch-maclib__Mac_Wave.h (renamed from games/maelstrom/files/patch-maclib-Mac_Wave.h)4
-rw-r--r--games/maelstrom/files/patch-maclib__macres.cpp (renamed from games/maelstrom/files/patch-maclib-macres.cpp)4
-rw-r--r--games/maelstrom/files/patch-maclib__snd2wav.cpp (renamed from games/maelstrom/files/patch-maclib-snd2wav.cpp)4
-rw-r--r--games/maelstrom/files/patch-main.cpp4
-rw-r--r--games/maelstrom/files/patch-myerror.cpp4
-rw-r--r--games/maelstrom/files/patch-netlogic__game.cpp (renamed from games/maelstrom/files/patch-netlogic-game.cpp)4
-rw-r--r--games/maelstrom/files/patch-netlogic__netplay.cpp (renamed from games/maelstrom/files/patch-netlogic-netplay.cpp)4
-rw-r--r--games/maelstrom/files/patch-netscore.cpp4
-rw-r--r--games/maelstrom/files/patch-screenlib__SDL_FrameBuf.cpp (renamed from games/maelstrom/files/patch-screenlib-SDL_FrameBuf.cpp)4
-rw-r--r--games/maelstrom/files/patch-screenlib__SDL_FrameBuf.h (renamed from games/maelstrom/files/patch-screenlib-SDL_FrameBuf.h)4
19 files changed, 61 insertions, 45 deletions
diff --git a/games/maelstrom/Makefile b/games/maelstrom/Makefile
index 177a1fec8a1e..c3da6d9bd723 100644
--- a/games/maelstrom/Makefile
+++ b/games/maelstrom/Makefile
@@ -6,7 +6,7 @@ PORTVERSION= 3.0.6
PORTREVISION= 9
CATEGORIES= games
MASTER_SITES= http://slouken.libsdl.org/projects/Maelstrom/src/ \
- SF/nemysisfreebsdp/:icons
+ SF/nemysisfreebsdp/${CATEGORIES}/:icons
DISTNAME= Maelstrom-${PORTVERSION}
DISTFILES= Maelstrom-${DISTVERSION}${EXTRACT_SUFX} \
${PORTNAME}.png:icons
@@ -24,23 +24,39 @@ GNU_CONFIGURE= yes
DATADIR= ${PREFIX}/share/Maelstrom
DOCSDIR= ${PREFIX}/share/doc/Maelstrom
+
PORTDOCS= *
-DESKTOP_ENTRIES="Maelstrom" "${COMMENT}" ${PORTNAME} \
- "Maelstrom" "Game;ArcadeGame;" false
+OPTIONS_DEFINE= DOCS
+
+DESKTOP_ENTRIES="Maelstrom" "" ${PORTNAME} \
+ "Maelstrom" "Game;ArcadeGame;" ""
-NO_STAGE= yes
.include <bsd.port.options.mk>
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|prefix = @prefix@|prefix = $${DESTDIR}@prefix@| ; \
+ s|$$(DESTDIR)$$(bindir)|$$(bindir)|' \
+ ${WRKSRC}/Makefile.in
+
+ @(cd ${WRKSRC} ; ${REINPLACE_CMD} \
+ -e 's|@CFLAGS@|@CFLAGS@ -w| ; \
+ s|$$(CXXFLAGS)|$$(CXXFLAGS) -w|' \
+ Makefile.in maclib/Makefile.in \
+ netlogic/Makefile.in screenlib/Makefile.in)
+
.if ${PORT_OPTIONS:MDOCS}
INSTALL_TARGET= install install_gamedocs
.endif
post-install:
- ${CHOWN} root:games ${PREFIX}/bin/Maelstrom
- ${CHMOD} 2755 ${PREFIX}/bin/Maelstrom
- ${CHMOD} 664 ${PREFIX}/share/Maelstrom/Maelstrom-Scores
- ${CHOWN} root:games ${PREFIX}/share/Maelstrom/Maelstrom-Scores
- ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png ${PREFIX}/share/pixmaps/
+ ${CHOWN} root:games ${STAGEDIR}${PREFIX}/bin/Maelstrom
+ ${CHMOD} 2755 ${STAGEDIR}${PREFIX}/bin/Maelstrom
+ ${CHMOD} 664 ${STAGEDIR}${PREFIX}/share/Maelstrom/Maelstrom-Scores
+ ${CHOWN} root:games \
+ ${STAGEDIR}${PREFIX}/share/Maelstrom/Maelstrom-Scores
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
.include <bsd.port.mk>
diff --git a/games/maelstrom/files/patch-buttonlist.h b/games/maelstrom/files/patch-buttonlist.h
index 2ed7700110ce..d5b92570d530 100644
--- a/games/maelstrom/files/patch-buttonlist.h
+++ b/games/maelstrom/files/patch-buttonlist.h
@@ -1,5 +1,5 @@
---- buttonlist.h.orig 2000-01-25 17:41:32.000000000 +0100
-+++ buttonlist.h 2013-03-16 11:40:09.000000000 +0100
+--- ./buttonlist.h.orig 2000-01-25 17:41:32.000000000 +0100
++++ ./buttonlist.h 2013-12-28 11:39:15.000000000 +0100
@@ -16,7 +16,7 @@
void Add_Button(Uint16 x, Uint16 y, Uint16 width, Uint16 height,
diff --git a/games/maelstrom/files/patch-configure b/games/maelstrom/files/patch-configure
index 98258a5f40fe..3133aaad2f7b 100644
--- a/games/maelstrom/files/patch-configure
+++ b/games/maelstrom/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig 2002-10-20 05:43:07.000000000 +0200
-+++ configure 2013-03-16 13:28:11.000000000 +0100
+--- ./configure.orig 2002-10-20 05:43:07.000000000 +0200
++++ ./configure 2013-12-28 11:39:15.000000000 +0100
@@ -3231,6 +3231,9 @@
ac_default_prefix=/boot/beos
GAME_INSTALLDIR="\$(prefix)/games/$PACKAGE"
diff --git a/games/maelstrom/files/patch-controls.cpp b/games/maelstrom/files/patch-controls.cpp
index 7532d3f22ac5..71aac53a74d4 100644
--- a/games/maelstrom/files/patch-controls.cpp
+++ b/games/maelstrom/files/patch-controls.cpp
@@ -1,5 +1,5 @@
---- controls.cpp.orig 2001-03-24 19:04:28.000000000 +0100
-+++ controls.cpp 2013-03-16 13:30:14.000000000 +0100
+--- ./controls.cpp.orig 2001-03-24 19:04:28.000000000 +0100
++++ ./controls.cpp 2013-12-28 11:39:15.000000000 +0100
@@ -83,7 +83,7 @@
if ( fname ) {
*fname = datafile;
diff --git a/games/maelstrom/files/patch-dialog.h b/games/maelstrom/files/patch-dialog.h
index 070ff6b52faf..a46d39db590b 100644
--- a/games/maelstrom/files/patch-dialog.h
+++ b/games/maelstrom/files/patch-dialog.h
@@ -1,5 +1,5 @@
---- dialog.h.orig 2001-07-20 17:08:10.000000000 +0200
-+++ dialog.h 2013-03-16 10:15:10.000000000 +0100
+--- ./dialog.h.orig 2001-07-20 17:08:10.000000000 +0200
++++ ./dialog.h 2013-12-28 11:39:16.000000000 +0100
@@ -92,7 +92,7 @@
va_list ap;
diff --git a/games/maelstrom/files/patch-load.cpp b/games/maelstrom/files/patch-load.cpp
index 36c3120fe57f..926e8376d846 100644
--- a/games/maelstrom/files/patch-load.cpp
+++ b/games/maelstrom/files/patch-load.cpp
@@ -1,5 +1,5 @@
---- load.cpp.orig 2000-02-15 03:47:39.000000000 +0100
-+++ load.cpp 2013-03-16 10:17:30.000000000 +0100
+--- ./load.cpp.orig 2000-02-15 03:47:39.000000000 +0100
++++ ./load.cpp 2013-12-28 11:39:16.000000000 +0100
@@ -81,7 +81,7 @@
SDL_Surface *bmp, *title;
diff --git a/games/maelstrom/files/patch-maclib-Mac_FontServ.h b/games/maelstrom/files/patch-maclib__Mac_FontServ.h
index 5c730c143fc5..4c8c18a3d4a6 100644
--- a/games/maelstrom/files/patch-maclib-Mac_FontServ.h
+++ b/games/maelstrom/files/patch-maclib__Mac_FontServ.h
@@ -1,5 +1,5 @@
---- maclib/Mac_FontServ.h.orig 1999-12-02 18:15:33.000000000 +0100
-+++ maclib/Mac_FontServ.h 2013-03-16 10:18:56.000000000 +0100
+--- ./maclib/Mac_FontServ.h.orig 1999-12-02 18:15:33.000000000 +0100
++++ ./maclib/Mac_FontServ.h 2013-12-28 11:39:16.000000000 +0100
@@ -135,7 +135,7 @@
va_list ap;
diff --git a/games/maelstrom/files/patch-maclib-Mac_Resource.h b/games/maelstrom/files/patch-maclib__Mac_Resource.h
index 79f4380a82fd..eee771bbbdf3 100644
--- a/games/maelstrom/files/patch-maclib-Mac_Resource.h
+++ b/games/maelstrom/files/patch-maclib__Mac_Resource.h
@@ -1,5 +1,5 @@
---- maclib/Mac_Resource.h.orig 1999-12-03 19:01:47.000000000 +0100
-+++ maclib/Mac_Resource.h 2013-03-16 10:47:19.000000000 +0100
+--- ./maclib/Mac_Resource.h.orig 1999-12-03 19:01:47.000000000 +0100
++++ ./maclib/Mac_Resource.h 2013-12-28 11:39:16.000000000 +0100
@@ -96,7 +96,7 @@
va_list ap;
diff --git a/games/maelstrom/files/patch-maclib-Mac_Sound.h b/games/maelstrom/files/patch-maclib__Mac_Sound.h
index 221236b99cdc..dc6c4a64a96a 100644
--- a/games/maelstrom/files/patch-maclib-Mac_Sound.h
+++ b/games/maelstrom/files/patch-maclib__Mac_Sound.h
@@ -1,5 +1,5 @@
---- maclib/Mac_Sound.h.orig 2002-10-20 04:53:34.000000000 +0200
-+++ maclib/Mac_Sound.h 2013-03-16 10:48:58.000000000 +0100
+--- ./maclib/Mac_Sound.h.orig 2002-10-20 04:53:34.000000000 +0200
++++ ./maclib/Mac_Sound.h 2013-12-28 11:39:16.000000000 +0100
@@ -199,7 +199,7 @@
va_list ap;
diff --git a/games/maelstrom/files/patch-maclib-Mac_Wave.h b/games/maelstrom/files/patch-maclib__Mac_Wave.h
index dbed827a3776..be9e047ea189 100644
--- a/games/maelstrom/files/patch-maclib-Mac_Wave.h
+++ b/games/maelstrom/files/patch-maclib__Mac_Wave.h
@@ -1,5 +1,5 @@
---- maclib/Mac_Wave.h.orig 2000-01-25 17:44:10.000000000 +0100
-+++ maclib/Mac_Wave.h 2013-03-16 10:50:39.000000000 +0100
+--- ./maclib/Mac_Wave.h.orig 2000-01-25 17:44:10.000000000 +0100
++++ ./maclib/Mac_Wave.h 2013-12-28 11:39:16.000000000 +0100
@@ -108,7 +108,7 @@
va_list ap;
diff --git a/games/maelstrom/files/patch-maclib-macres.cpp b/games/maelstrom/files/patch-maclib__macres.cpp
index 09529db1d602..f0fff570d4cd 100644
--- a/games/maelstrom/files/patch-maclib-macres.cpp
+++ b/games/maelstrom/files/patch-maclib__macres.cpp
@@ -1,5 +1,5 @@
---- maclib/macres.cpp.orig 2000-01-25 17:44:20.000000000 +0100
-+++ maclib/macres.cpp 2013-03-16 10:55:45.000000000 +0100
+--- ./maclib/macres.cpp.orig 2000-01-25 17:44:20.000000000 +0100
++++ ./maclib/macres.cpp 2013-12-28 11:39:16.000000000 +0100
@@ -58,8 +58,8 @@
ids[j], res->ResourceName(types[i], ids[j]));
if ( argv[2] ) {
diff --git a/games/maelstrom/files/patch-maclib-snd2wav.cpp b/games/maelstrom/files/patch-maclib__snd2wav.cpp
index 8a1a5e0a549f..b1e5e7fb5b5c 100644
--- a/games/maelstrom/files/patch-maclib-snd2wav.cpp
+++ b/games/maelstrom/files/patch-maclib__snd2wav.cpp
@@ -1,5 +1,5 @@
---- maclib/snd2wav.cpp.orig 2001-03-28 05:54:50.000000000 +0200
-+++ maclib/snd2wav.cpp 2013-03-16 10:58:23.000000000 +0100
+--- ./maclib/snd2wav.cpp.orig 2001-03-28 05:54:50.000000000 +0200
++++ ./maclib/snd2wav.cpp 2013-12-28 11:39:16.000000000 +0100
@@ -82,7 +82,7 @@
continue;
}
diff --git a/games/maelstrom/files/patch-main.cpp b/games/maelstrom/files/patch-main.cpp
index b5951b74b9e1..62fbe5f31fb1 100644
--- a/games/maelstrom/files/patch-main.cpp
+++ b/games/maelstrom/files/patch-main.cpp
@@ -1,5 +1,5 @@
---- main.cpp.orig 2002-10-20 04:53:32.000000000 +0200
-+++ main.cpp 2013-03-16 11:03:28.000000000 +0100
+--- ./main.cpp.orig 2002-10-20 04:53:32.000000000 +0200
++++ ./main.cpp 2013-12-28 11:39:16.000000000 +0100
@@ -445,7 +445,7 @@
DrawText(xOff+309-7, yOff+240-6, text, geneva, STYLE_BOLD,
0x00, 0x00, 0x00);
diff --git a/games/maelstrom/files/patch-myerror.cpp b/games/maelstrom/files/patch-myerror.cpp
index 07cc6d8ce094..84937717a40a 100644
--- a/games/maelstrom/files/patch-myerror.cpp
+++ b/games/maelstrom/files/patch-myerror.cpp
@@ -1,5 +1,5 @@
---- myerror.cpp.orig 1998-07-14 03:50:17.000000000 +0200
-+++ myerror.cpp 2013-03-16 12:24:50.000000000 +0100
+--- ./myerror.cpp.orig 1998-07-14 03:50:17.000000000 +0200
++++ ./myerror.cpp 2013-12-28 11:39:16.000000000 +0100
@@ -16,7 +16,7 @@
va_list ap;
diff --git a/games/maelstrom/files/patch-netlogic-game.cpp b/games/maelstrom/files/patch-netlogic__game.cpp
index bc7583bfdd18..df2e7b66b12b 100644
--- a/games/maelstrom/files/patch-netlogic-game.cpp
+++ b/games/maelstrom/files/patch-netlogic__game.cpp
@@ -1,5 +1,5 @@
---- netlogic/game.cpp.orig 2001-07-23 04:24:03.000000000 +0200
-+++ netlogic/game.cpp 2013-03-16 13:13:14.000000000 +0100
+--- ./netlogic/game.cpp.orig 2001-07-23 04:24:03.000000000 +0200
++++ ./netlogic/game.cpp 2013-12-28 11:39:16.000000000 +0100
@@ -232,7 +232,7 @@
lastDisplayed = gDisplayed;
diff --git a/games/maelstrom/files/patch-netlogic-netplay.cpp b/games/maelstrom/files/patch-netlogic__netplay.cpp
index a39e826300c3..a7afdfc7b539 100644
--- a/games/maelstrom/files/patch-netlogic-netplay.cpp
+++ b/games/maelstrom/files/patch-netlogic__netplay.cpp
@@ -1,5 +1,5 @@
---- netlogic/netplay.cpp.orig 2002-10-20 06:11:52.000000000 +0200
-+++ netlogic/netplay.cpp 2013-03-16 13:16:57.000000000 +0100
+--- ./netlogic/netplay.cpp.orig 2002-10-20 06:11:52.000000000 +0200
++++ ./netlogic/netplay.cpp 2013-12-28 11:39:16.000000000 +0100
@@ -670,7 +670,9 @@
strcpy(message, "Waiting for players:");
for ( i=0; i<gNumPlayers; ++i ) {
diff --git a/games/maelstrom/files/patch-netscore.cpp b/games/maelstrom/files/patch-netscore.cpp
index f82e4523706d..ddda80f6a676 100644
--- a/games/maelstrom/files/patch-netscore.cpp
+++ b/games/maelstrom/files/patch-netscore.cpp
@@ -1,5 +1,5 @@
---- netscore.cpp.orig 2001-07-23 05:25:17.000000000 +0200
-+++ netscore.cpp 2013-03-16 11:30:57.000000000 +0100
+--- ./netscore.cpp.orig 2001-07-23 05:25:17.000000000 +0200
++++ ./netscore.cpp 2013-12-28 11:39:16.000000000 +0100
@@ -59,7 +59,7 @@
/* Send the scores */
diff --git a/games/maelstrom/files/patch-screenlib-SDL_FrameBuf.cpp b/games/maelstrom/files/patch-screenlib__SDL_FrameBuf.cpp
index 550390b2a3d8..3497e48da0a2 100644
--- a/games/maelstrom/files/patch-screenlib-SDL_FrameBuf.cpp
+++ b/games/maelstrom/files/patch-screenlib__SDL_FrameBuf.cpp
@@ -1,5 +1,5 @@
---- screenlib/SDL_FrameBuf.cpp.orig 2001-07-22 23:03:13.000000000 +0200
-+++ screenlib/SDL_FrameBuf.cpp 2013-03-16 11:45:02.000000000 +0100
+--- ./screenlib/SDL_FrameBuf.cpp.orig 2001-07-22 23:03:13.000000000 +0200
++++ ./screenlib/SDL_FrameBuf.cpp 2013-12-28 11:39:16.000000000 +0100
@@ -628,7 +628,7 @@
found = 0;
diff --git a/games/maelstrom/files/patch-screenlib-SDL_FrameBuf.h b/games/maelstrom/files/patch-screenlib__SDL_FrameBuf.h
index d58bf4388de8..8260b529cdb9 100644
--- a/games/maelstrom/files/patch-screenlib-SDL_FrameBuf.h
+++ b/games/maelstrom/files/patch-screenlib__SDL_FrameBuf.h
@@ -1,5 +1,5 @@
---- screenlib/SDL_FrameBuf.h.orig 2000-09-24 19:55:39.000000000 +0200
-+++ screenlib/SDL_FrameBuf.h 2013-03-16 11:33:01.000000000 +0100
+--- ./screenlib/SDL_FrameBuf.h.orig 2000-09-24 19:55:39.000000000 +0200
++++ ./screenlib/SDL_FrameBuf.h 2013-12-28 11:39:16.000000000 +0100
@@ -165,7 +165,7 @@
va_list ap;