aboutsummaryrefslogtreecommitdiff
path: root/games/mangband
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2000-03-11 01:23:11 +0000
committerKris Kennaway <kris@FreeBSD.org>2000-03-11 01:23:11 +0000
commit21f0fd7c1c2af6f731eda6375f2e9ff9f69a9306 (patch)
tree3a455e895ef91c2750f1cecd628db1c3925ee837 /games/mangband
parent3a7c9e3d9132a6304d904127615e0a0e5242a375 (diff)
downloadports-21f0fd7c1c2af6f731eda6375f2e9ff9f69a9306.tar.gz
ports-21f0fd7c1c2af6f731eda6375f2e9ff9f69a9306.zip
Install setgid games, not setuid games.
Reviewed by: ache (maintainer)
Notes
Notes: svn path=/head/; revision=26731
Diffstat (limited to 'games/mangband')
-rw-r--r--games/mangband/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/games/mangband/Makefile b/games/mangband/Makefile
index 4056086e6f22..3ba222816535 100644
--- a/games/mangband/Makefile
+++ b/games/mangband/Makefile
@@ -25,12 +25,12 @@ do-install:
cd ${WRKSRC}/../lib; ${CP} -R -p * ${MALIB}; \
cd ${MALIB}; \
touch file/wizards.txt; \
- ${CHMOD} 750 *; ${CHOWN} -R games.games *; \
+ ${CHMOD} 750 *; ${CHOWN} -R root.games *; \
${CHMOD} 755 user;
cd ${WRKSRC}; \
- ${INSTALL_PROGRAM} -o games -g games -m 4550 \
+ ${INSTALL_PROGRAM} -o root -g games -m 2550 \
mangband ${PREFIX}/bin; \
- ${INSTALL_PROGRAM} -o games -g games -m 550 \
+ ${INSTALL_PROGRAM} -o root -g games -m 550 \
mangconsole ${PREFIX}/bin; \
${INSTALL_PROGRAM} mangclient ${PREFIX}/bin