aboutsummaryrefslogtreecommitdiff
path: root/games/meandmyshadow
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-10-28 17:29:13 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-10-28 17:29:13 +0000
commit1d90df1583706f37969151c84f23c118e364ef4c (patch)
tree9f0b6a53074ffcf298dd212ecdc0880cca58cfe4 /games/meandmyshadow
parent0a1c16aa6adcaaafacd04b502f653e730d372fab (diff)
downloadports-1d90df1583706f37969151c84f23c118e364ef4c.tar.gz
ports-1d90df1583706f37969151c84f23c118e364ef4c.zip
- Update to 0.5
Notes
Notes: svn path=/head/; revision=483319
Diffstat (limited to 'games/meandmyshadow')
-rw-r--r--games/meandmyshadow/Makefile9
-rw-r--r--games/meandmyshadow/distinfo5
-rw-r--r--games/meandmyshadow/files/patch-CMakeLists.txt29
-rw-r--r--games/meandmyshadow/files/patch-src_Functions.cpp11
-rw-r--r--games/meandmyshadow/pkg-descr2
5 files changed, 48 insertions, 8 deletions
diff --git a/games/meandmyshadow/Makefile b/games/meandmyshadow/Makefile
index 88a34d9de351..d7c7a667593f 100644
--- a/games/meandmyshadow/Makefile
+++ b/games/meandmyshadow/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= meandmyshadow
-PORTVERSION= 0.4.1
-PORTREVISION= 4
+PORTVERSION= 0.5
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
@@ -16,9 +15,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libcurl.so:ftp/curl
-USES= cmake libarchive ssl
-USE_SDL= sdl ttf image mixer image gfx
-USE_GL= gl glu
+USES= cmake dos2unix libarchive lua:53
+DOS2UNIX_FILES= CMakeLists.txt src/Functions.cpp
+USE_SDL= sdl2 image2 ttf2 mixer2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/games/meandmyshadow/distinfo b/games/meandmyshadow/distinfo
index 2fe2f3e577e6..b977d938de51 100644
--- a/games/meandmyshadow/distinfo
+++ b/games/meandmyshadow/distinfo
@@ -1,2 +1,3 @@
-SHA256 (meandmyshadow-0.4.1-src.tar.gz) = 25dd24f1f34e274a23b7b85116b6c3c2172af2069d0d028c0e00785c0e6b8572
-SIZE (meandmyshadow-0.4.1-src.tar.gz) = 17017718
+TIMESTAMP = 1539012144
+SHA256 (meandmyshadow-0.5-src.tar.gz) = 75d4914ae7275402bce3f544125271c262a15ae53e61292c9768bbb60772d8ac
+SIZE (meandmyshadow-0.5-src.tar.gz) = 17526981
diff --git a/games/meandmyshadow/files/patch-CMakeLists.txt b/games/meandmyshadow/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..93815413ffe2
--- /dev/null
+++ b/games/meandmyshadow/files/patch-CMakeLists.txt
@@ -0,0 +1,29 @@
+--- CMakeLists.txt.orig 2018-10-07 15:06:26 UTC
++++ CMakeLists.txt
+@@ -2,6 +2,13 @@ Project (meandmyshadow)
+ CMake_Minimum_Required (VERSION 3.1)
+ Set (CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/Modules/")
+
++#Path options
++Set (BINDIR "bin" CACHE STRING "Where to install binaries")
++Set (DATAROOTDIR "${CMAKE_INSTALL_PREFIX}/share" CACHE STRING "Sets the root of data directories to a non-default location")
++Set (ICONDIR "${DATAROOTDIR}/icons" CACHE STRING "Sets the icon directory for desktop entry to a non-default location.")
++Set (DESKTOPDIR "${DATAROOTDIR}/applications" CACHE STRING "Sets the desktop file directory for desktop entry to a non-default location.")
++
++#Options
+ Option (DEBUG_MODE "Compile the game with debug mode enabled" OFF)
+ Option (DISABLED_DEBUG_STUFF "Enable this you'll see a lot of annoying script debug messages which will lag the game." OFF)
+
+@@ -164,12 +171,6 @@ Target_Link_Libraries (
+ ${LUA_LIBRARIES}
+ )
+
+-#Path options
+-Set (BINDIR "bin" CACHE STRING "Where to install binaries")
+-Set (DATAROOTDIR "${CMAKE_INSTALL_PREFIX}/share" CACHE STRING "Sets the root of data directories to a non-default location")
+-Set (ICONDIR "${DATAROOTDIR}/icons" CACHE STRING "Sets the icon directory for desktop entry to a non-default location.")
+-Set (DESKTOPDIR "${DATAROOTDIR}/applications" CACHE STRING "Sets the desktop file directory for desktop entry to a non-default location.")
+-
+ #Install locations
+ Install (DIRECTORY ${PROJECT_SOURCE_DIR}/data DESTINATION ${DATAROOTDIR}/meandmyshadow/)
+ Install (FILES AUTHORS DESTINATION ${DATAROOTDIR}/meandmyshadow/)
diff --git a/games/meandmyshadow/files/patch-src_Functions.cpp b/games/meandmyshadow/files/patch-src_Functions.cpp
new file mode 100644
index 000000000000..d89263c48367
--- /dev/null
+++ b/games/meandmyshadow/files/patch-src_Functions.cpp
@@ -0,0 +1,11 @@
+--- src/Functions.cpp.orig 2018-10-07 15:06:26 UTC
++++ src/Functions.cpp
+@@ -416,7 +416,7 @@ void onVideoResize(ImageManager& imageMa
+
+ ScreenData init(){
+ //Initialze SDL.
+- if(SDL_Init(SDL_INIT_EVERYTHING)==-1) {
++ if(SDL_Init(SDL_INIT_VIDEO|SDL_INIT_AUDIO|SDL_INIT_JOYSTICK|SDL_INIT_TIMER)==-1) {
+ std::cerr << "FATAL ERROR: SDL_Init failed\nError: " << SDL_GetError() << std::endl;
+ return creationFailed();
+ }
diff --git a/games/meandmyshadow/pkg-descr b/games/meandmyshadow/pkg-descr
index 246fdda90f42..7d7c518b7c3c 100644
--- a/games/meandmyshadow/pkg-descr
+++ b/games/meandmyshadow/pkg-descr
@@ -2,4 +2,4 @@ Me and My Shadow is a puzzle/platform game written by Luka Horvat.
The author has given us permission to gpl the game, and develop it
further. It has an interesting concept and rather unique gameplay.
-WWW: http://meandmyshadow.sourceforge.net/
+WWW: https://acmepjz.github.io/meandmyshadow/