aboutsummaryrefslogtreecommitdiff
path: root/games/megaglest
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-04-12 08:32:01 +0000
committerJohn Marino <marino@FreeBSD.org>2015-04-12 08:32:01 +0000
commit33e3be5231074adca69fd58e79fe486031edb74a (patch)
tree10a016b43fbc2111bd894ce082a39f42b3f54d90 /games/megaglest
parentbb1b699cc3666521826ca6e9308a98512f5b2462 (diff)
downloadports-33e3be5231074adca69fd58e79fe486031edb74a.tar.gz
ports-33e3be5231074adca69fd58e79fe486031edb74a.zip
Notes
Diffstat (limited to 'games/megaglest')
-rw-r--r--games/megaglest/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/games/megaglest/Makefile b/games/megaglest/Makefile
index 8b3a654d65f8..065867b00f63 100644
--- a/games/megaglest/Makefile
+++ b/games/megaglest/Makefile
@@ -3,7 +3,7 @@
PORTNAME= megaglest
PORTVERSION= 3.9.0.4
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}_3.9.0/
DISTNAME= ${PORTNAME}-source-${PORTVERSION}
@@ -23,7 +23,11 @@ RUN_DEPENDS= ${DATADIR}/tutorials/2_basic_tutorial/2_basic_tutorial.xml:${PORTSD
SUB_FILES= pkg-message
-USES= cmake compiler:c++11-lib display:build dos2unix lua openal:al,alut pkgconfig tar:xz
+# Clang catches a c++11 violation that older GCC misses, so until the
+# code is fixed, remove USES+=compiler:c++11-lib and set USE_GCC=yes
+USES= cmake display:build dos2unix lua openal:al,alut pkgconfig \
+ tar:xz
+USE_GCC= yes
USE_GL= glew gl glu
USE_SDL= yes
USE_WX= 3.0