aboutsummaryrefslogtreecommitdiff
path: root/games/megaglest
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-03-27 01:10:18 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-03-27 01:10:18 +0000
commit588e4661a992273a75c704edffe68ed71431c230 (patch)
tree3cd6d42c67b6f7a415095d3e340109be4d53c32e /games/megaglest
parent7be8d8f94ca50992cfa6a160918b47c9441fc8ef (diff)
downloadports-588e4661a992273a75c704edffe68ed71431c230.tar.gz
ports-588e4661a992273a75c704edffe68ed71431c230.zip
- Update to 3.11.1
- Cleanup the port - Pass maintainership to submitter PR: 205485 Submitted by: monwarez@mailoo.org
Notes
Notes: svn path=/head/; revision=411969
Diffstat (limited to 'games/megaglest')
-rw-r--r--games/megaglest/Makefile22
-rw-r--r--games/megaglest/distinfo4
-rw-r--r--games/megaglest/files/patch-source_shared__lib_sources_miniz_miniz.c19
-rw-r--r--games/megaglest/pkg-plist2
4 files changed, 18 insertions, 29 deletions
diff --git a/games/megaglest/Makefile b/games/megaglest/Makefile
index 4e093d274411..b99f8f9e95d0 100644
--- a/games/megaglest/Makefile
+++ b/games/megaglest/Makefile
@@ -2,15 +2,16 @@
# $FreeBSD$
PORTNAME= megaglest
-PORTVERSION= 3.9.0.4
-PORTREVISION= 8
+PORTVERSION= 3.11.1
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/archived/${PORTNAME}_3.9.0/
DISTNAME= ${PORTNAME}-source-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= monwarez@mailoo.org
COMMENT= Open source 3D real-time strategy game
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/docs/gnu_gpl_3.0.txt
+
LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
libpng.so:${PORTSDIR}/graphics/png \
libxerces-c.so:${PORTSDIR}/textproc/xerces-c3 \
@@ -20,6 +21,10 @@ BUILD_DEPENDS= ${LOCALBASE}/include/libircclient.h:${PORTSDIR}/irc/libircclient
${LOCALBASE}/include/miniupnpc/miniupnpc.h:${PORTSDIR}/net/miniupnpc
RUN_DEPENDS= ${DATADIR}/tutorials/2_basic_tutorial/2_basic_tutorial.xml:${PORTSDIR}/games/megaglest-data
+USE_GITHUB= yes
+GH_ACCOUNT= MegaGlest
+GH_PROJECT= megaglest-source
+
SUB_FILES= pkg-message
USES= cmake compiler:c++11-lib display:build dos2unix jpeg lua \
@@ -28,11 +33,9 @@ USE_GL= glew gl glu
USE_SDL= yes
USE_WX= 3.0
USE_CXXSTD= c++11
-WX_UNICODE= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lssl -lcrypto
-WRKSRC= ${WRKDIR}/${PORTNAME}-3.9.0
OPTIONS_DEFINE= EDITOR DOCS
OPTIONS_SUB= yes
@@ -49,13 +52,16 @@ post-patch:
do-install:
${STRIP_CMD} ${WRKSRC}/source/glest_game/megaglest
@${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/mk/linux/megaglest.desktop ${STAGEDIR}${PREFIX}/share/applications/
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons
+ ${INSTALL_DATA} ${WRKSRC}/mk/linux/megaglest.png ${STAGEDIR}${PREFIX}/share/icons/
${INSTALL_PROGRAM} ${WRKSRC}/source/glest_game/megaglest ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
-.for f in glest.ini glestkeys.ini servers.ini
+.for f in mk/linux/glest.ini mk/shared/glestkeys.ini mk/shared/servers.ini
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DATADIR}
.endfor
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
-. for f in AUTHORS.source_code.txt CHANGELOG.txt README.txt COPYRIGHT.source_code.txt
+. for f in docs/AUTHORS.source_code.txt docs/CHANGELOG.txt docs/README.txt docs/COPYRIGHT.source_code.txt
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
. endfor
.endif
diff --git a/games/megaglest/distinfo b/games/megaglest/distinfo
index 261eaa0ea5ea..3d371f3bf3c5 100644
--- a/games/megaglest/distinfo
+++ b/games/megaglest/distinfo
@@ -1,2 +1,2 @@
-SHA256 (megaglest-source-3.9.0.4.tar.xz) = 3362ade61af3c01c2d8976d2d481769698dc0c800f35251b8c5489f8e41d9bc3
-SIZE (megaglest-source-3.9.0.4.tar.xz) = 1596692
+SHA256 (megaglest-source-3.11.1_GH0.tar.xz) = 6bbbbb69d01bc765f439a60c74178b75dc47753cc126e6758e3bc740d8b42a21
+SIZE (megaglest-source-3.11.1_GH0.tar.xz) = 4807372
diff --git a/games/megaglest/files/patch-source_shared__lib_sources_miniz_miniz.c b/games/megaglest/files/patch-source_shared__lib_sources_miniz_miniz.c
deleted file mode 100644
index 4f91feb21783..000000000000
--- a/games/megaglest/files/patch-source_shared__lib_sources_miniz_miniz.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- source/shared_lib/sources/miniz/miniz.c.orig 2015-04-13 04:50:02 UTC
-+++ source/shared_lib/sources/miniz/miniz.c
-@@ -2765,6 +2765,7 @@ mz_uint tdefl_create_comp_flags_from_zip
- // http://altdevblogaday.org/2011/04/06/a-smaller-jpg-encoder/.
- void *tdefl_write_image_to_png_file_in_memory(const void *pImage, int w, int h, int num_chans, size_t *pLen_out)
- {
-+ static const mz_uint8 chans[] = {0x00, 0x00, 0x04, 0x02, 0x06};
- tdefl_compressor *pComp = (tdefl_compressor *)MZ_MALLOC(sizeof(tdefl_compressor)); tdefl_output_buffer out_buf; int i, bpl = w * num_chans, y, z; mz_uint32 c; *pLen_out = 0;
- if (!pComp) return NULL;
- MZ_CLEAR_OBJ(out_buf); out_buf.m_expandable = MZ_TRUE; out_buf.m_capacity = 57+MZ_MAX(64, (1+bpl)*h); if (NULL == (out_buf.m_pBuf = (mz_uint8*)MZ_MALLOC(out_buf.m_capacity))) { MZ_FREE(pComp); return NULL; }
-@@ -2778,7 +2779,7 @@ void *tdefl_write_image_to_png_file_in_m
- *pLen_out = out_buf.m_size-41;
- {
- mz_uint8 pnghdr[41]={0x89,0x50,0x4e,0x47,0x0d,0x0a,0x1a,0x0a,0x00,0x00,0x00,0x0d,0x49,0x48,0x44,0x52,
-- 0,0,(mz_uint8)(w>>8),(mz_uint8)w,0,0,(mz_uint8)(h>>8),(mz_uint8)h,8,"\0\0\04\02\06"[num_chans],0,0,0,0,0,0,0,
-+ 0,0,(mz_uint8)(w>>8),(mz_uint8)w,0,0,(mz_uint8)(h>>8),(mz_uint8)h,8,chans[num_chans],0,0,0,0,0,0,0,
- (mz_uint8)(*pLen_out>>24),(mz_uint8)(*pLen_out>>16),(mz_uint8)(*pLen_out>>8),(mz_uint8)*pLen_out,0x49,0x44,0x41,0x54};
- c=(mz_uint32)mz_crc32(MZ_CRC32_INIT,pnghdr+12,17); for (i=0; i<4; ++i, c<<=8) ((mz_uint8*)(pnghdr+29))[i]=(mz_uint8)(c>>24);
- memcpy(out_buf.m_pBuf, pnghdr, 41);
diff --git a/games/megaglest/pkg-plist b/games/megaglest/pkg-plist
index 7ad81313fea8..e509ebe2c3f0 100644
--- a/games/megaglest/pkg-plist
+++ b/games/megaglest/pkg-plist
@@ -7,3 +7,5 @@ bin/megaglest
%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT.source_code.txt
%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG.txt
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS.source_code.txt
+share/applications/megaglest.desktop
+share/icons/megaglest.png