aboutsummaryrefslogtreecommitdiff
path: root/games/megaglest
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2016-12-25 23:11:36 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2016-12-25 23:11:36 +0000
commit7a97406f0386fdd2f636de137599f8fa3c72e8a3 (patch)
tree20139c0ee8c6f9fd40bcb19a41a070f0a937b265 /games/megaglest
parent8d1478ada84dc7d298afd8455b2c9e8741cdf71e (diff)
downloadports-7a97406f0386fdd2f636de137599f8fa3c72e8a3.tar.gz
ports-7a97406f0386fdd2f636de137599f8fa3c72e8a3.zip
Notes
Diffstat (limited to 'games/megaglest')
-rw-r--r--games/megaglest/Makefile1
-rw-r--r--games/megaglest/files/patch-source-shared_lib-sources-platform-posix-socket.cpp11
2 files changed, 12 insertions, 0 deletions
diff --git a/games/megaglest/Makefile b/games/megaglest/Makefile
index 3aea5f93c8ee..0a0e8353e843 100644
--- a/games/megaglest/Makefile
+++ b/games/megaglest/Makefile
@@ -3,6 +3,7 @@
PORTNAME= megaglest
PORTVERSION= 3.12.0
+PORTREVISION= 1
CATEGORIES= games
MAINTAINER= monwarez@mailoo.org
diff --git a/games/megaglest/files/patch-source-shared_lib-sources-platform-posix-socket.cpp b/games/megaglest/files/patch-source-shared_lib-sources-platform-posix-socket.cpp
new file mode 100644
index 000000000000..d50e6ae4cfe4
--- /dev/null
+++ b/games/megaglest/files/patch-source-shared_lib-sources-platform-posix-socket.cpp
@@ -0,0 +1,11 @@
+--- source/shared_lib/sources/platform/posix/socket.cpp.orig 2016-12-26 00:02:43.325573000 +0100
++++ source/shared_lib/sources/platform/posix/socket.cpp 2016-12-26 00:04:06.681172000 +0100
+@@ -2632,7 +2632,7 @@
+
+ //printf("UPnP device found: [%s] [%s] lanaddr [%s]\n", dev->descURL, dev->st,lanaddr);
+ #if (defined(MINIUPNPC_API_VERSION) && MINIUPNPC_API_VERSION >= 9) || (!defined(MINIUPNPC_VERSION_PRE1_7) && !defined(MINIUPNPC_VERSION_PRE1_6))
+- char *descXML = (char *)miniwget_getaddr(dev->descURL, &descXMLsize, lanaddr, (sizeof(lanaddr) / sizeof(lanaddr[0])),0);
++ char *descXML = (char *)miniwget_getaddr(dev->descURL, &descXMLsize, lanaddr, (sizeof(lanaddr) / sizeof(lanaddr[0])),0,0);
+ #else
+ char *descXML = (char *)miniwget_getaddr(dev->descURL, &descXMLsize, lanaddr, (sizeof(lanaddr) / sizeof(lanaddr[0])));
+ #endif