aboutsummaryrefslogtreecommitdiff
path: root/games/meqcc
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2005-01-16 12:19:15 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2005-01-16 12:19:15 +0000
commit458f7331dbf761eb9ff4fe05dc962d89f0b7774d (patch)
tree9a0fc768f9f940a4ef45e7f5b6bd71e1b757217d /games/meqcc
parentf7ab4556e7e04b94f9edef2f3a2db65afe1e5410 (diff)
downloadports-458f7331dbf761eb9ff4fe05dc962d89f0b7774d.tar.gz
ports-458f7331dbf761eb9ff4fe05dc962d89f0b7774d.zip
Add meqcc 1.4, MrElusive's QuakeC compiler.
Notes
Notes: svn path=/head/; revision=126577
Diffstat (limited to 'games/meqcc')
-rw-r--r--games/meqcc/Makefile39
-rw-r--r--games/meqcc/distinfo2
-rw-r--r--games/meqcc/files/patch-cmdlib.c11
-rw-r--r--games/meqcc/files/patch-l_memory.c24
-rw-r--r--games/meqcc/files/patch-linux.mak20
-rw-r--r--games/meqcc/pkg-descr7
-rw-r--r--games/meqcc/pkg-plist5
7 files changed, 108 insertions, 0 deletions
diff --git a/games/meqcc/Makefile b/games/meqcc/Makefile
new file mode 100644
index 000000000000..c0302129a242
--- /dev/null
+++ b/games/meqcc/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: meQCC
+# Date created: 16 Jan 2005
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= meqcc
+PORTVERSION= 1.4
+CATEGORIES= games devel
+MASTER_SITES= http://wiki.quakesrc.org/files/ \
+ http://freebsd.nsu.ru/distfiles/
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}src
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= MrElusive's QuakeC compiler
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_ZIP= yes
+
+MAKEFILE= ${WRKSRC}/linux.mak
+
+post-extract:
+ @${FIND} -E ${WRKDIR} -type f -iregex ".*\.(c|h|mak|txt)" -print0 | \
+ ${XARGS} -0 ${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//'
+ @${REINPLACE_CMD} -e 's/<io\.h>/<unistd\.h>/' ${WRKSRC}/cmdlib.c \
+ ${WRKSRC}/qcc.c ${WRKSRC}/l_log.c
+ @${REINPLACE_CMD} -e '/<conio\.h>/d' ${WRKSRC}/l_log.c
+ @${REINPLACE_CMD} -e 's/unsigned long t/time_t t/' ${WRKSRC}/l_precomp.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/qcc ${PREFIX}/bin/${PORTNAME}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/[^g]*.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/meqcc/distinfo b/games/meqcc/distinfo
new file mode 100644
index 000000000000..68fbaf9f5862
--- /dev/null
+++ b/games/meqcc/distinfo
@@ -0,0 +1,2 @@
+MD5 (meqcc14src.zip) = e0189332470ca4d53d34964b03faec62
+SIZE (meqcc14src.zip) = 100418
diff --git a/games/meqcc/files/patch-cmdlib.c b/games/meqcc/files/patch-cmdlib.c
new file mode 100644
index 000000000000..bc0d24a72e9a
--- /dev/null
+++ b/games/meqcc/files/patch-cmdlib.c
@@ -0,0 +1,11 @@
+--- cmdlib.c.orig Sat Jan 15 20:08:10 2005
++++ cmdlib.c Sat Jan 15 20:03:02 2005
+@@ -141,6 +141,8 @@
+ ================
+ */
+ // MrE:
++long int tell (int);
++
+ long int filelength (int handle)
+ {
+ /*
diff --git a/games/meqcc/files/patch-l_memory.c b/games/meqcc/files/patch-l_memory.c
new file mode 100644
index 000000000000..50fc1cd362cf
--- /dev/null
+++ b/games/meqcc/files/patch-l_memory.c
@@ -0,0 +1,24 @@
+--- l_memory.c.orig Sat Jan 15 20:19:09 2005
++++ l_memory.c Sat Jan 15 20:19:04 2005
+@@ -10,11 +10,12 @@
+ // Tab Size: 3
+ //===========================================================================
+
+-#include <malloc.h>
++#include <stdlib.h>
+ #include "qcc.h"
+ #include "l_log.h"
+
+
++#if 0
+ /*
+ =================
+ MemorySize
+@@ -31,6 +32,7 @@
+ #endif
+ #endif
+ } //end of the function MemorySize
++#endif
+
+ /*
+ =================
diff --git a/games/meqcc/files/patch-linux.mak b/games/meqcc/files/patch-linux.mak
new file mode 100644
index 000000000000..fd375b65e508
--- /dev/null
+++ b/games/meqcc/files/patch-linux.mak
@@ -0,0 +1,20 @@
+--- linux.mak.orig Sat Jan 15 19:59:27 2005
++++ linux.mak Sat Jan 15 19:59:20 2005
+@@ -1,5 +1,4 @@
+-# for Linux/DJGPP
+-CFLAGS = -g -O2 -Wall
++CFLAGS += -Dstricmp=strcasecmp -Dstrcmpi=strcasecmp
+
+ EXES = qcc
+
+@@ -21,8 +20,8 @@
+ clean:
+ rm -f *.o *~ $(EXES)
+
+-.c.o: ; gcc -c $(CFLAGS) -o $@ $*.c
++.c.o: ; $(CC) -c $(CFLAGS) -o $@ $*.c
+
+ QCCFILES = qcc.o pr_lex.o pr_comp.o cmdlib.o l_log.o l_memory.o l_script.o l_precomp.o
+ qcc : $(QCCFILES)
+- gcc -o qcc $(QCCFILES)
++ $(CC) -o qcc $(QCCFILES)
diff --git a/games/meqcc/pkg-descr b/games/meqcc/pkg-descr
new file mode 100644
index 000000000000..ac82fb177032
--- /dev/null
+++ b/games/meqcc/pkg-descr
@@ -0,0 +1,7 @@
+This is a modification to the Quake-C compiler from id Software. It allows
+for creating a `progs.dat' which cannot be decompiled to Quake-C source code.
+As an added bonus a `progs.dat' which cannot be decompiled is a lot smaller.
+The compiler also has a C compatible precompiler. A description of the
+precompiler directives can be found in a regular C manual.
+
+WWW: http://wiki.quakesrc.org/index.php/meQCC
diff --git a/games/meqcc/pkg-plist b/games/meqcc/pkg-plist
new file mode 100644
index 000000000000..a0cb9a2c8a68
--- /dev/null
+++ b/games/meqcc/pkg-plist
@@ -0,0 +1,5 @@
+bin/meqcc
+%%PORTDOCS%%%%DOCSDIR%%/meqcc.txt
+%%PORTDOCS%%%%DOCSDIR%%/qcc.txt
+%%PORTDOCS%%%%DOCSDIR%%/readme.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%