aboutsummaryrefslogtreecommitdiff
path: root/games/minetest
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-02-13 20:45:24 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-02-13 20:45:24 +0000
commita12693b82c93ffd987181b35ced6b8e81ba71490 (patch)
tree5f8910c98d69fba7811a40e618f39e1fb5f49a9f /games/minetest
parent93bddf9c81747b20f8933ad4df53fa3f09cde708 (diff)
downloadports-a12693b82c93ffd987181b35ced6b8e81ba71490.tar.gz
ports-a12693b82c93ffd987181b35ced6b8e81ba71490.zip
- Make server-only installation not bring in X11 depends
Notes
Notes: svn path=/head/; revision=344142
Diffstat (limited to 'games/minetest')
-rw-r--r--games/minetest/Makefile14
-rw-r--r--games/minetest/files/extra-patch-irrlichtdepend11
2 files changed, 22 insertions, 3 deletions
diff --git a/games/minetest/Makefile b/games/minetest/Makefile
index 4358b157cbf0..590cdd1da69b 100644
--- a/games/minetest/Makefile
+++ b/games/minetest/Makefile
@@ -10,8 +10,7 @@ COMMENT= Infiniminer/Minecraft inspired game
LICENSE= LGPL21
-LIB_DEPENDS= libIrrlicht.so:${PORTSDIR}/x11-toolkits/irrlicht \
- sqlite3:${PORTSDIR}/databases/sqlite3
+LIB_DEPENDS= libsqlite3.so:${PORTSDIR}/databases/sqlite3
USE_GITHUB= yes
GH_ACCOUNT= minetest
@@ -39,7 +38,8 @@ LUAJIT_DESC= LuaJIT support
CLIENT_CMAKE_ON= -DBUILD_CLIENT=1
CLIENT_CMAKE_OFF= -DBUILD_CLIENT=0
CLIENT_LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng.so:${PORTSDIR}/graphics/png
+ libpng.so:${PORTSDIR}/graphics/png \
+ libIrrlicht.so:${PORTSDIR}/x11-toolkits/irrlicht
CLIENT_USE= GL=gl XORG=x11
SERVER_CMAKE_ON= -DBUILD_SERVER=1
SERVER_CMAKE_OFF= -DBUILD_SERVER=0
@@ -73,6 +73,14 @@ USERS= ${PORTNAME}
GROUPS= ${PORTNAME}
.endif
+# hacky way to not bring irrlicht and X11 depends for server only
+.if ! ${PORT_OPTIONS:MCLIENT} && ${PORT_OPTIONS:MSERVER}
+BUILD_DEPENDS+= ${NONEXISTENT}:${PORTSDIR}/x11-toolkits/irrlicht:patch
+IRRLICHT_INCLUDE_DIR= `${MAKE} -C ${PORTSDIR}/x11-toolkits/irrlicht -V WRKSRC`/include
+CMAKE_ARGS+= -DIRRLICHT_INCLUDE_DIR:STRING="${IRRLICHT_INCLUDE_DIR}"
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-irrlichtdepend
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
${WRKSRC}/cmake/Modules/*.cmake
diff --git a/games/minetest/files/extra-patch-irrlichtdepend b/games/minetest/files/extra-patch-irrlichtdepend
new file mode 100644
index 000000000000..7508ae5abe80
--- /dev/null
+++ b/games/minetest/files/extra-patch-irrlichtdepend
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2014-01-02 01:54:28.000000000 +0400
++++ CMakeLists.txt 2014-02-07 05:16:36.652533717 +0400
+@@ -57,7 +57,7 @@
+ include(${CMAKE_SOURCE_DIR}/cmake/Modules/misc.cmake)
+
+ # This is done here so that relative search paths are more reasnable
+-find_package(Irrlicht)
++set(IRRLICHT_LIBRARY "")
+
+ #
+ # Installation