aboutsummaryrefslogtreecommitdiff
path: root/games/monster-masher
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-01-05 20:36:33 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-01-05 20:36:33 +0000
commit41d8c3385c21ae51629c8997035eae8a9423ff6c (patch)
tree246d960cb714ce0095c452017819f6b1c64a7dfb /games/monster-masher
parent5e3b0872db18497aacc353b3ef94ad8dac11183f (diff)
downloadports-41d8c3385c21ae51629c8997035eae8a9423ff6c.tar.gz
ports-41d8c3385c21ae51629c8997035eae8a9423ff6c.zip
- Remove conditional checks for FreeBSD 5.x and older
Notes
Notes: svn path=/head/; revision=225297
Diffstat (limited to 'games/monster-masher')
-rw-r--r--games/monster-masher/Makefile9
-rw-r--r--games/monster-masher/files/extra-patch-src-vector.hpp30
2 files changed, 1 insertions, 38 deletions
diff --git a/games/monster-masher/Makefile b/games/monster-masher/Makefile
index 2348d2981f9e..633988664911 100644
--- a/games/monster-masher/Makefile
+++ b/games/monster-masher/Makefile
@@ -27,11 +27,4 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GCONF_SCHEMAS= monster-masher.schemas
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500010
-IGNORE= Freezes when starting a new game
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-src-vector.hpp
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/monster-masher/files/extra-patch-src-vector.hpp b/games/monster-masher/files/extra-patch-src-vector.hpp
deleted file mode 100644
index 1ba2faf2887e..000000000000
--- a/games/monster-masher/files/extra-patch-src-vector.hpp
+++ /dev/null
@@ -1,30 +0,0 @@
---- src/vector.hpp.orig Fri Aug 15 19:07:16 2003
-+++ src/vector.hpp Wed Nov 5 20:34:27 2003
-@@ -107,25 +107,17 @@
- }
-
- template <typename T>
--inline bool operator !=(Vector<T> lhs, Vector<T> rhs)
--{
-- return !(lhs == rhs);
--}
--
--template <typename T>
- inline bool operator ==(Vector<T> lhs, Vector<T> rhs)
- {
- return lhs.x == rhs.x && lhs.y == rhs.y;
- }
-
--template <>
--inline bool operator ==<double>(Vector<double> lhs, Vector<double> rhs)
-+inline bool operator ==(Vector<double> lhs, Vector<double> rhs)
- {
- return std::abs(lhs.x - rhs.x) < 0.001 && std::abs(lhs.y - rhs.y) < 0.001;
- }
-
--template <>
--inline bool operator ==<float>(Vector<float> lhs, Vector<float> rhs)
-+inline bool operator ==(Vector<float> lhs, Vector<float> rhs)
- {
- return std::abs(lhs.x - rhs.x) < 0.001 && std::abs(lhs.y - rhs.y) < 0.001;
- }