aboutsummaryrefslogtreecommitdiff
path: root/games/monsterz
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-08-19 16:37:37 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-08-19 16:37:37 +0000
commit20e736bcd5bec5ea2b10a5a375faec35674d9dcc (patch)
treea1e5d4036aaa9a234e14938f1bbed896b4f7f93f /games/monsterz
parentd521cad8342a97c81c4068eca9749979809f9256 (diff)
downloadports-20e736bcd5bec5ea2b10a5a375faec35674d9dcc.tar.gz
ports-20e736bcd5bec5ea2b10a5a375faec35674d9dcc.zip
- Bump portrevision
- Trim master sites, add icon - Trim to use default permissions for licenses, if not defined - Trim dependency for ${PYGAME} - Trim docs, not install COPYING INSTALL into DOCSDIR and mute dir install - Add Desktop entry file - Trim files/patch-Makefile for right installation - Trim pkg-plist, share/games/monsterz --> DATADIR Approved by: wxs (mentor)
Notes
Notes: svn path=/head/; revision=325004
Diffstat (limited to 'games/monsterz')
-rw-r--r--games/monsterz/Makefile36
-rw-r--r--games/monsterz/distinfo2
-rw-r--r--games/monsterz/files/patch-Makefile18
-rw-r--r--games/monsterz/pkg-plist54
4 files changed, 65 insertions, 45 deletions
diff --git a/games/monsterz/Makefile b/games/monsterz/Makefile
index 4e7239c5e642..e9ec2f61c01e 100644
--- a/games/monsterz/Makefile
+++ b/games/monsterz/Makefile
@@ -3,9 +3,13 @@
PORTNAME= monsterz
PORTVERSION= 0.7.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= games
-MASTER_SITES= http://sam.zoy.org/monsterz/
+MASTER_SITES= http://sam.zoy.org/monsterz/ \
+ SF/nemysisfreebsdp/:icons
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}.png:icons
+EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
MAINTAINER= thierry@FreeBSD.org
COMMENT= Monsterz - arcade puzzle game
@@ -13,26 +17,34 @@ COMMENT= Monsterz - arcade puzzle game
LICENSE= WTFPL
LICENSE_NAME= Do What The [expletive] You Want To Public License, Version 2
LICENSE_FILE= ${WRKSRC}/COPYING
-LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+LICENSE_PERMS= ${_LICENSE_PERMS_DEFAULT}
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/pygame/__init__.py:${PORTSDIR}/devel/py-game
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${PYGAME}
USE_PYTHON= yes
MAKE_ENV= prefix=${PREFIX}
+PORTDOCS= AUTHORS README TODO
+
SCOREDIR= /var/games
PLIST_SUB= SCOREDIR=${SCOREDIR}
-PORTDOCS= AUTHORS COPYING INSTALL README TODO
+DESKTOP_ENTRIES="Monsterz" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" false
+
+.include <bsd.port.options.mk>
post-install:
- ${STRIP_CMD} ${PREFIX}/games/monsterz
- ${LN} -sf ${PREFIX}/games/monsterz ${PREFIX}/bin
- @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/share/games/monsterz
- @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/share/games/monsterz
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+.for d in graphics sound
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${DATADIR})
+.endfor
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.py ${DATADIR}
+ @${PYTHON_CMD} -m compileall ${DATADIR}
+ @${PYTHON_CMD} -O -m compileall ${DATADIR}
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png ${PREFIX}/share/pixmaps/
+
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
diff --git a/games/monsterz/distinfo b/games/monsterz/distinfo
index 2b21fc80e7e4..5eea709f47c5 100644
--- a/games/monsterz/distinfo
+++ b/games/monsterz/distinfo
@@ -1,2 +1,4 @@
SHA256 (monsterz-0.7.1.tar.gz) = 50828b8fa26d107bcc2bd134328f83c905b9f5e124846bdf239daf0eed34973d
SIZE (monsterz-0.7.1.tar.gz) = 1879537
+SHA256 (monsterz.png) = 64f9533f252db001bdaec34e1c4432a6d236a8084899d0adc22ad90d01eedae1
+SIZE (monsterz.png) = 4849
diff --git a/games/monsterz/files/patch-Makefile b/games/monsterz/files/patch-Makefile
index 18c01a0313b9..d85652c63fcf 100644
--- a/games/monsterz/files/patch-Makefile
+++ b/games/monsterz/files/patch-Makefile
@@ -1,12 +1,18 @@
--- Makefile.orig 2007-12-17 23:05:00.000000000 +0100
-+++ Makefile 2013-05-25 16:56:29.000000000 +0200
-@@ -1,5 +1,5 @@
++++ Makefile 2013-08-19 08:57:30.000000000 +0200
+@@ -1,8 +1,8 @@
-prefix = /usr/local
-+prefix?= /usr/local
- gamesdir = ${prefix}/games
- datadir = ${prefix}/share
- pkgdatadir = $(datadir)/games/monsterz
+-gamesdir = ${prefix}/games
+-datadir = ${prefix}/share
+-pkgdatadir = $(datadir)/games/monsterz
++prefix? = /usr/local
++gamesdir = ${prefix}/bin
++datadir = ${prefix}/share/monsterz
++pkgdatadir = $(datadir)
+ scoredir = /var/games
+ scorefile = $(scoredir)/monsterz
+
@@ -22,7 +22,7 @@
all: monsterz
diff --git a/games/monsterz/pkg-plist b/games/monsterz/pkg-plist
index 6a9338776e11..9d2e7f26b36a 100644
--- a/games/monsterz/pkg-plist
+++ b/games/monsterz/pkg-plist
@@ -1,30 +1,30 @@
bin/monsterz
-games/monsterz
-share/games/monsterz/graphics/background.png
-share/games/monsterz/graphics/bigtiles.png
-share/games/monsterz/graphics/board.png
-share/games/monsterz/graphics/icon.png
-share/games/monsterz/graphics/logo.png
-share/games/monsterz/graphics/tiles.png
-share/games/monsterz/monsterz.py
-share/games/monsterz/monsterz.pyc
-share/games/monsterz/monsterz.pyo
-share/games/monsterz/sound/applause.wav
-share/games/monsterz/sound/boing.wav
-share/games/monsterz/sound/click.wav
-share/games/monsterz/sound/ding.wav
-share/games/monsterz/sound/duh.wav
-share/games/monsterz/sound/grunt.wav
-share/games/monsterz/sound/laugh.wav
-share/games/monsterz/sound/music.s3m
-share/games/monsterz/sound/pop.wav
-share/games/monsterz/sound/warning.wav
-share/games/monsterz/sound/whip.wav
-@dirrm share/games/monsterz/sound
-@dirrm share/games/monsterz/graphics
-@dirrm share/games/monsterz
-@dirrmtry share/games
-@dirrmtry games
+%%DATADIR%%/graphics/background.png
+%%DATADIR%%/graphics/bigtiles.png
+%%DATADIR%%/graphics/board.png
+%%DATADIR%%/graphics/graphics.svg
+%%DATADIR%%/graphics/icon.png
+%%DATADIR%%/graphics/logo.png
+%%DATADIR%%/graphics/pattern.png
+%%DATADIR%%/graphics/tiles.png
+%%DATADIR%%/monsterz.py
+%%DATADIR%%/monsterz.pyc
+%%DATADIR%%/monsterz.pyo
+%%DATADIR%%/sound/applause.wav
+%%DATADIR%%/sound/boing.wav
+%%DATADIR%%/sound/click.wav
+%%DATADIR%%/sound/ding.wav
+%%DATADIR%%/sound/duh.wav
+%%DATADIR%%/sound/grunt.wav
+%%DATADIR%%/sound/laugh.wav
+%%DATADIR%%/sound/music.s3m
+%%DATADIR%%/sound/pop.wav
+%%DATADIR%%/sound/warning.wav
+%%DATADIR%%/sound/whip.wav
+share/pixmaps/monsterz.png
+@dirrm %%DATADIR%%/sound
+@dirrm %%DATADIR%%/graphics
+@dirrm %%DATADIR%%
@exec if [ ! -e %%SCOREDIR%% ] ; then mkdir -p -m 775 %%SCOREDIR%% ; fi
-@exec [ -e %%SCOREDIR%%/monsterz ] || touch %%SCOREDIR%%/monsterz && chmod g+w %%SCOREDIR%%/monsterz && chown root:games %%SCOREDIR%%/monsterz
+@exec [ -e %%SCOREDIR%%/monsterz ] || touch %%SCOREDIR%%/monsterz && chmod 664 %%SCOREDIR%%/monsterz && chgrp games %%SCOREDIR%%/monsterz
@unexec if [ ! -s %%SCOREDIR%%/monsterz ] ; then rm -f %%SCOREDIR%%/monsterz && rm -r %%SCOREDIR%% || true ; fi