aboutsummaryrefslogtreecommitdiff
path: root/games/monsterz
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2016-02-11 21:17:39 +0000
committerThierry Thomas <thierry@FreeBSD.org>2016-02-11 21:17:39 +0000
commite62c25dd60f458a7990766a5287fc58fb93a39dc (patch)
tree7ea91856c019f4ec6dd5b16824bc240c76ddb7cf /games/monsterz
parent9349bac673f1c5f35c4c6fc4cb166e9a1953f1e3 (diff)
downloadports-e62c25dd60f458a7990766a5287fc58fb93a39dc.tar.gz
ports-e62c25dd60f458a7990766a5287fc58fb93a39dc.zip
Modernize pkg-plist.
PR: ports/206743 Submitted by: pawel
Notes
Notes: svn path=/head/; revision=408699
Diffstat (limited to 'games/monsterz')
-rw-r--r--games/monsterz/Makefile10
-rw-r--r--games/monsterz/pkg-plist14
2 files changed, 9 insertions, 15 deletions
diff --git a/games/monsterz/Makefile b/games/monsterz/Makefile
index 53dc50258970..6b9f040fc722 100644
--- a/games/monsterz/Makefile
+++ b/games/monsterz/Makefile
@@ -3,7 +3,7 @@
PORTNAME= monsterz
PORTVERSION= 0.7.1
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= games
MASTER_SITES= http://sam.zoy.org/monsterz/ \
SF/nemysisfreebsdp/:icons
@@ -34,7 +34,9 @@ DESKTOP_ENTRIES="Monsterz" "${COMMENT}" "${PORTNAME}" \
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
+pre-configure:
+ ${REINPLACE_CMD} '/test -f/ s|scorefile)|&.sample|g' \
+ ${WRKSRC}/Makefile
post-install:
.for d in graphics sound
@@ -48,9 +50,9 @@ post-install:
-f ${DATADIR:S;${PREFIX}/;;})
${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png ${STAGEDIR}${PREFIX}/share/pixmaps/
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/monsterz
-.if ${PORT_OPTIONS:MDOCS}
+
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/games/monsterz/pkg-plist b/games/monsterz/pkg-plist
index 68cb2f9a6168..9d10776ef7d8 100644
--- a/games/monsterz/pkg-plist
+++ b/games/monsterz/pkg-plist
@@ -1,8 +1,4 @@
-@group games
-@mode 2555
-bin/monsterz
-@mode
-@group
+@(,games,2555) bin/monsterz
%%DATADIR%%/graphics/background.png
%%DATADIR%%/graphics/bigtiles.png
%%DATADIR%%/graphics/board.png
@@ -26,9 +22,5 @@ bin/monsterz
%%DATADIR%%/sound/warning.wav
%%DATADIR%%/sound/whip.wav
share/pixmaps/monsterz.png
-@dirrm %%DATADIR%%/sound
-@dirrm %%DATADIR%%/graphics
-@dirrm %%DATADIR%%
-@exec if [ ! -e %%SCOREDIR%% ] ; then mkdir -p -m 775 %%SCOREDIR%% ; fi
-@unexec if [ ! -s %%SCOREDIR%%/monsterz ] ; then rm -f %%SCOREDIR%%/monsterz && rm -r %%SCOREDIR%% || true ; fi
-@exec [ -e %%SCOREDIR%%/monsterz ] || touch %%SCOREDIR%%/monsterz && chmod 664 %%SCOREDIR%%/monsterz && chgrp games %%SCOREDIR%%/monsterz
+@sample(,games,664) %%SCOREDIR%%/monsterz.sample
+@dir(,,775) %%SCOREDIR%%