aboutsummaryrefslogtreecommitdiff
path: root/games/moonlander
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-08-20 20:22:42 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-08-20 20:22:42 +0000
commitaade76271be960bd63c1e331d6d3098072862998 (patch)
tree996c3fc9ac89ee5fd85dcf86c721dd8597d49bf0 /games/moonlander
parent08f2714782a6a3f8b51c7362c489f75f8d414ae0 (diff)
downloadports-aade76271be960bd63c1e331d6d3098072862998.tar.gz
ports-aade76271be960bd63c1e331d6d3098072862998.zip
- Switch to options helpers
Notes
Notes: svn path=/head/; revision=394909
Diffstat (limited to 'games/moonlander')
-rw-r--r--games/moonlander/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/games/moonlander/Makefile b/games/moonlander/Makefile
index 7dfe417264e7..dbdc4649364d 100644
--- a/games/moonlander/Makefile
+++ b/games/moonlander/Makefile
@@ -17,26 +17,22 @@ USE_SDL= mixer image sdl
WRKSRC= ${WRKDIR}/moon-lander
-SOUNDS= sounds
-
PLIST_FILES= bin/${PORTNAME}
PORTDATA= *
OPTIONS_DEFINE= SOUND
OPTIONS_DEFAULT=SOUND
-.include <bsd.port.options.mk>
-
-.if ! ${PORT_OPTIONS:MSOUND}
-SOUNDS= # empty
-CFLAGS+= -DNOSOUND
-.endif
+SOUND_CFLAGS_OFF= -DNOSOUND
do-configure:
@${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' ${WRKSRC}/moon_lander.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/moonlander ${STAGEDIR}${PREFIX}/bin/
- cd ${WRKSRC} && ${COPYTREE_SHARE} "fonts images ${SOUNDS}" ${STAGEDIR}${DATADIR}/
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "fonts images" ${STAGEDIR}${DATADIR}/
+
+post-install-SOUND-on:
+ cd ${WRKSRC} && ${COPYTREE_SHARE} sounds ${STAGEDIR}${DATADIR}/
.include <bsd.port.mk>