aboutsummaryrefslogtreecommitdiff
path: root/games/moonlight-embedded
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-01-29 15:53:31 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-01-29 15:53:31 +0000
commit1af77b3bacf05bcf1259561dbc10508f23aeb9f5 (patch)
tree3d82c565d062938229bb5ae4ff2a2601f0b2d9c8 /games/moonlight-embedded
parent49c9f0085049a475f481a89ddbc3f203afecc64b (diff)
downloadports-1af77b3bacf05bcf1259561dbc10508f23aeb9f5.tar.gz
ports-1af77b3bacf05bcf1259561dbc10508f23aeb9f5.zip
games/moonlight-embedded: Add patch to fix runtime with GFE 3.16
Submitted by: Brian Bostwick
Notes
Notes: svn path=/head/; revision=491573
Diffstat (limited to 'games/moonlight-embedded')
-rw-r--r--games/moonlight-embedded/Makefile2
-rw-r--r--games/moonlight-embedded/files/patch-third__party_moonlight-common-c_src_ControlStream.c46
2 files changed, 47 insertions, 1 deletions
diff --git a/games/moonlight-embedded/Makefile b/games/moonlight-embedded/Makefile
index 2893fd67047b..ff4fba003ef4 100644
--- a/games/moonlight-embedded/Makefile
+++ b/games/moonlight-embedded/Makefile
@@ -2,7 +2,7 @@
PORTNAME= moonlight-embedded
DISTVERSION= 2.4.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= https://github.com/irtimmer/moonlight-embedded/releases/download/v${DISTVERSION}/
diff --git a/games/moonlight-embedded/files/patch-third__party_moonlight-common-c_src_ControlStream.c b/games/moonlight-embedded/files/patch-third__party_moonlight-common-c_src_ControlStream.c
new file mode 100644
index 000000000000..7d7851d80d50
--- /dev/null
+++ b/games/moonlight-embedded/files/patch-third__party_moonlight-common-c_src_ControlStream.c
@@ -0,0 +1,46 @@
+From 8665d806978d2cba9c9040183a3686f4d87d402c Mon Sep 17 00:00:00 2001
+From: Cameron Gutman <aicommander@gmail.com>
+Date: Thu, 15 Nov 2018 12:55:22 -0800
+Subject: [PATCH] Don't expect responses for ENet control messages to fix GFE
+ 3.16
+
+---
+ src/ControlStream.c | 12 +-----------
+ 1 file changed, 1 insertion(+), 11 deletions(-)
+
+--- third_party/moonlight-common-c/src/ControlStream.c.orig 2018-08-11 15:28:10 UTC
++++ third_party/moonlight-common-c/src/ControlStream.c
+@@ -378,10 +378,7 @@ static int sendMessageAndForget(short ptype, short pay
+ }
+
+ static int sendMessageAndDiscardReply(short ptype, short paylen, const void* payload) {
+- // Discard the response
+ if (AppVersionQuad[0] >= 5) {
+- ENetEvent event;
+-
+ PltLockMutex(&enetMutex);
+
+ if (!sendMessageEnet(ptype, paylen, payload)) {
+@@ -389,14 +386,6 @@ static int sendMessageAndDiscardReply(short ptype, sho
+ return 0;
+ }
+
+- if (serviceEnetHost(client, &event, CONTROL_STREAM_TIMEOUT_SEC * 1000) <= 0 ||
+- event.type != ENET_EVENT_TYPE_RECEIVE) {
+- PltUnlockMutex(&enetMutex);
+- return 0;
+- }
+-
+- enet_packet_destroy(event.packet);
+-
+ PltUnlockMutex(&enetMutex);
+ }
+ else {
+@@ -406,6 +395,7 @@ static int sendMessageAndDiscardReply(short ptype, sho
+ return 0;
+ }
+
++ // Discard the response
+ reply = readNvctlPacketTcp();
+ if (reply == NULL) {
+ return 0;