aboutsummaryrefslogtreecommitdiff
path: root/games/mopesnake/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2013-03-14 23:31:14 +0000
committerBeech Rintoul <beech@FreeBSD.org>2013-03-14 23:31:14 +0000
commit798557fe63a4f7b1554e6914403e0a1f576d2944 (patch)
tree3ded923218cd744ec3a22788550c7240ebe724ec /games/mopesnake/Makefile
parent964f1cee537e429ccf2c9cd2a002683f9e324c1b (diff)
downloadports-798557fe63a4f7b1554e6914403e0a1f576d2944.tar.gz
ports-798557fe63a4f7b1554e6914403e0a1f576d2944.zip
Notes
Diffstat (limited to 'games/mopesnake/Makefile')
-rw-r--r--games/mopesnake/Makefile34
1 files changed, 12 insertions, 22 deletions
diff --git a/games/mopesnake/Makefile b/games/mopesnake/Makefile
index e216a26a9233..f7d3ed593910 100644
--- a/games/mopesnake/Makefile
+++ b/games/mopesnake/Makefile
@@ -1,9 +1,10 @@
+# Created by: nemysis <nemysis@gmx.ch>
# $FreeBSD$
PORTNAME= mopesnake
PORTVERSION= 0.5
-PORTREVISION= 1
-CATEGORIES= games
+PORTREVISION= 2
+CATEGORIES= games python
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
DISTNAME= ${PORTNAME}-pc-${DISTVERSION}
@@ -18,43 +19,32 @@ USE_ZIP= yes
USE_PYTHON= yes
NO_BUILD= yes
-PLIST_FILES= bin/${PORTNAME} \
- share/pixmaps/${PORTNAME}.png
-
-PORTDATA= *
PORTDOCS= TODO.txt index.html
SUB_FILES= ${PORTNAME}
+DESKTOP_ENTRIES="Master Of Pain (Eating) - Snake" "${COMMENT}" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" false
+
+.include <bsd.port.options.mk>
+
post-patch:
-# Fix path to python interpreter
@${REINPLACE_CMD} -e 's,/usr/bin/python,${PYTHON_CMD},' \
${WRKSRC}/*.py ${WRKSRC}/mopelib/*.py
- @(cd ${WRKSRC} && ${RM} *.py.bak mopelib/*py.bak)
-
-.include <bsd.port.options.mk>
+ @${FIND} ${WRKSRC} -name "*.bak" -delete
do-install:
-# Scripts
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
-
-# Executable
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/
${MKDIR} ${DATADIR}
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.py ${DATADIR}
-
-# Data
@(cd ${WRKSRC} && ${COPYTREE_SHARE} "images mopelib music sounds" ${DATADIR})
-
-# Pixmaps and version
${INSTALL_DATA} ${WRKSRC}/doc/screenshot1.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
${INSTALL_DATA} ${WRKSRC}/version ${DATADIR}
-# Documentation
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
-. for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DOCSDIR}
-. endfor
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/|} ${DOCSDIR}
.endif
.include <bsd.port.mk>