aboutsummaryrefslogtreecommitdiff
path: root/games/mvdsv/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-03-17 09:57:16 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-03-17 09:57:16 +0000
commit8bcdc2f8e0a40596ada54061743d56198ff6e8fc (patch)
tree0cc85e77e55e7634c4e8f2fa075a58aaf7b37541 /games/mvdsv/Makefile
parent4ccab87c554ac4a0f227a797ebe31ba96e5f4e3c (diff)
Notes
Diffstat (limited to 'games/mvdsv/Makefile')
-rw-r--r--games/mvdsv/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/games/mvdsv/Makefile b/games/mvdsv/Makefile
index a53f33619d9d..96630987631d 100644
--- a/games/mvdsv/Makefile
+++ b/games/mvdsv/Makefile
@@ -13,7 +13,7 @@ COMMENT?= Enhanced QuakeWorld server with multi-view demos capability
LICENSE= GPLv2
-USES= zip
+USES= zip
HAS_CONFIGURE= yes
CONFIGURE_ARGS= ${OPSYS} ${ARCH:C/.*(64)/\1/}
@@ -27,22 +27,15 @@ OPTIONS_DEFINE_amd64= ASM
OPTIONS_DEFAULT_i386= ASM
OPTIONS_DEFAULT_amd64= ASM
-.if ${PORTNAME} == "mvdsv"
+.if ${PORTNAME} == mvdsv
OPTIONS_DEFINE+= KQUEUE
OPTIONS_DEFAULT+= KQUEUE
.endif
KQUEUE_DESC= Kqueue support
-.include <bsd.port.options.mk>
-
-.if ! ${PORT_OPTIONS:MKQUEUE}
-MAKE_ARGS+= -DNOKQUEUE
-.endif
-
-.if ! ${PORT_OPTIONS:MASM}
-MAKE_ARGS+= -DWITHOUT_X86_ASM
-.endif
+KQUEUE_MAKE_ARGS_OFF= -DNOKQUEUE
+ASM_MAKE_ARGS_OFF= -DWITHOUT_X86_ASM
post-patch:
@${REINPLACE_CMD} -e 's,gcc,${CC},' ${WRKSRC}/configure