aboutsummaryrefslogtreecommitdiff
path: root/games/mvdsv
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-09-12 13:53:53 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-09-12 13:53:53 +0000
commit3cc71f11dc67f7e8cc069ea8aa8b96f38b782bad (patch)
tree7fd0befa6ee46002b0fe2f46f145500c307ecb9e /games/mvdsv
parent2bb572d4526cb2f91271e60a1da772eac26e51f7 (diff)
downloadports-3cc71f11dc67f7e8cc069ea8aa8b96f38b782bad.tar.gz
ports-3cc71f11dc67f7e8cc069ea8aa8b96f38b782bad.zip
- Unbreak the build in GCC-less environments: respect CC, pacify Clang
- Fix the inner Makefile.BSD to allow -jX builds, remove MAKE_JOBS_UNSAFE Reported by: pkg-fallout
Notes
Notes: svn path=/head/; revision=327066
Diffstat (limited to 'games/mvdsv')
-rw-r--r--games/mvdsv/Makefile5
-rw-r--r--games/mvdsv/files/patch-Makefile.BSD13
2 files changed, 17 insertions, 1 deletions
diff --git a/games/mvdsv/Makefile b/games/mvdsv/Makefile
index 31989c80881c..56ee6ad49e78 100644
--- a/games/mvdsv/Makefile
+++ b/games/mvdsv/Makefile
@@ -17,9 +17,9 @@ USE_ZIP= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= ${OPSYS} ${ARCH:C/.*(64)/\1/}
+MAKE_ARGS= CC="${CC}"
ALL_TARGET= ${PORTNAME}
WRKSRC= ${WRKDIR}/mvdsv
-MAKE_JOBS_UNSAFE= yes
PLIST_FILES= bin/${PORTNAME}
@@ -45,6 +45,9 @@ MAKE_ARGS+= -DNOKQUEUE
MAKE_ARGS+= -DWITHOUT_X86_ASM
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's,^inline ,,' ${WRKSRC}/source/sv_sys_unix.c
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
diff --git a/games/mvdsv/files/patch-Makefile.BSD b/games/mvdsv/files/patch-Makefile.BSD
index 79e0ae17189f..78a3039b17ff 100644
--- a/games/mvdsv/files/patch-Makefile.BSD
+++ b/games/mvdsv/files/patch-Makefile.BSD
@@ -18,3 +18,16 @@
QWDTOOLS_ASM_OBJS = \
${SV_DIR}/bothtoolsa.o
.endif
+@@ -129,10 +129,10 @@
+ #############################################################################
+
+ .c.o:
+- ${CC} ${DO_CFLAGS} -c $< -o $*.o
++ ${CC} ${DO_CFLAGS} -c $< -o $@
+
+ .s.o:
+- ${CC} ${DO_CFLAGS} -DELF -x assembler-with-cpp -c $< -o $*.o
++ ${CC} ${DO_CFLAGS} -DELF -x assembler-with-cpp -c $< -o $@
+
+ all: mvdsv qwdtools
+ ${STRIP} ${STRIP_FLAGS} mvdsv qwdtools