aboutsummaryrefslogtreecommitdiff
path: root/games/nethack33-gnome/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-12 04:24:01 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-12 04:24:01 +0000
commit688aa71c6f580fb638aa286dbbbc162853e13157 (patch)
tree12ed4155b816282eb7fba59bdc39e539b90a377d /games/nethack33-gnome/Makefile
parent5be65dc29d042e971f309582068671031aa18946 (diff)
downloadports-688aa71c6f580fb638aa286dbbbc162853e13157.tar.gz
ports-688aa71c6f580fb638aa286dbbbc162853e13157.zip
Notes
Diffstat (limited to 'games/nethack33-gnome/Makefile')
-rw-r--r--games/nethack33-gnome/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/games/nethack33-gnome/Makefile b/games/nethack33-gnome/Makefile
new file mode 100644
index 000000000000..c7ac2b699509
--- /dev/null
+++ b/games/nethack33-gnome/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: nethack
+# Date created: 09 December 2000
+# Whom: Jan Stocker <Jan.Stocker@t-online.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nethack
+PORTVERSION= 3.3.1
+CATEGORIES= games gnome
+MASTER_SITES= ftp://ftp.nethack.org/pub/nethack/nh331/src/ \
+ ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMESUFFIX= -gnome
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= Jan.Stocker@t-online.de
+
+USE_GNOME= yes
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+MAN6= dgn_comp.6 dlb.6 lev_comp.6 nethack.6 recover.6
+
+pre-configure:
+ @cd ${WRKSRC}/sys/unix; ${SH} setup.sh
+
+post-install:
+ @cd ${WRKSRC}/doc; ${CHMOD} 644 *.6
+ @cd ${WRKSRC}/doc; PREFIX=${PREFIX} ${MAKE} manpages
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/nethack
+ ${CP} ${WRKSRC}/doc/Guidebook.txt ${PREFIX}/share/doc/nethack
+.endif
+
+.include <bsd.port.mk>