aboutsummaryrefslogtreecommitdiff
path: root/games/nethack33
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-01-31 10:08:21 +0000
committerJohn Marino <marino@FreeBSD.org>2016-01-31 10:08:21 +0000
commit9ab840624cb92ce376d51996aa95abf017df1131 (patch)
tree08754164e76e50d4fe8ad820c0b6fea811ec41ff /games/nethack33
parent74c871d192c3b9730e6c4abdc658a44648a89233 (diff)
downloadports-9ab840624cb92ce376d51996aa95abf017df1131.tar.gz
ports-9ab840624cb92ce376d51996aa95abf017df1131.zip
nethack33(-nox11): document ncurses requirement (USES+=ncurses)
both ports need to link to ncurses. The -nox11 version wasn't respecting LDFLAGS Finally, link to libncurses over ancient termlib (which is symlinked to libncurses on FreeBSD base anyway) approved by: infrastructure blanket
Notes
Notes: svn path=/head/; revision=407605
Diffstat (limited to 'games/nethack33')
-rw-r--r--games/nethack33/Makefile2
-rw-r--r--games/nethack33/files/patch-sys-unix-Makefile.src28
2 files changed, 22 insertions, 8 deletions
diff --git a/games/nethack33/Makefile b/games/nethack33/Makefile
index c9bd0ff145e9..c19d215726c1 100644
--- a/games/nethack33/Makefile
+++ b/games/nethack33/Makefile
@@ -13,7 +13,7 @@ COMMENT= Dungeon explorin', slashin', hackin' game
WRKSRC= ${WRKDIR}/${TRUEPORTNAME}-${PORTVERSION}
-USES= gmake tar:tgz
+USES= gmake ncurses tar:tgz
MAKE_ENV= GRAPHICS="${GRAPHICS}"
PLIST_SUB= HACKNAME="${HACKNAME}" \
HACKEXT="${HACKEXT}"
diff --git a/games/nethack33/files/patch-sys-unix-Makefile.src b/games/nethack33/files/patch-sys-unix-Makefile.src
index f0f1ab1843ba..d4ccb87cb169 100644
--- a/games/nethack33/files/patch-sys-unix-Makefile.src
+++ b/games/nethack33/files/patch-sys-unix-Makefile.src
@@ -1,6 +1,6 @@
---- sys/unix/Makefile.src.orig Sat Aug 5 19:52:57 2000
-+++ sys/unix/Makefile.src Sat May 18 01:19:31 2002
-@@ -139,19 +139,28 @@
+--- sys/unix/Makefile.src.orig 2000-08-05 10:52:57 UTC
++++ sys/unix/Makefile.src
+@@ -139,19 +139,28 @@ SYSOBJ = ioctl.o unixmain.o unixtty.o un
# directories. The ones given below is the usual spot for linux systems.
# The paths are for glibconfig.h and gnomesupport.h respectively.
#
@@ -33,7 +33,7 @@
#LD=g++
# Set the WINSRC, WINOBJ, and WINLIB lines to correspond to your desired
-@@ -204,7 +213,26 @@
+@@ -204,7 +213,26 @@ WINBEOBJ =
#
#
WINSRC = $(WINTTYSRC)
@@ -60,7 +60,12 @@
# on some systems the termcap library is in -ltermcap or -lcurses
# on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
-@@ -224,19 +252,19 @@
+@@ -220,23 +248,23 @@ WINOBJ = $(WINTTYOBJ)
+ # WINTTYLIB = -lcurses
+ # WINTTYLIB = -lcurses16
+ # WINTTYLIB = -lncurses
+-WINTTYLIB = -ltermlib
++WINTTYLIB = -lncurses
#
# libraries for X11
# If USE_XPM is defined in config.h, you will also need -lXpm here.
@@ -83,7 +88,7 @@
#
# libraries for Gem port
WINGEMLIB = -le_gem -lgem
-@@ -245,6 +273,15 @@
+@@ -245,6 +273,15 @@ WINGEMLIB = -le_gem -lgem
WINBELIB = -lbe
WINLIB = $(WINTTYLIB)
@@ -99,7 +104,16 @@
# any other strange libraries your system needs (for Sysunix only -- the more
# specialized targets should already be right)
-@@ -445,10 +482,10 @@
+@@ -376,7 +413,7 @@ $(GAME): $(SYSTEM)
+
+ Sysunix: $(HOBJ) Makefile
+ @echo "Loading ..."
+- @$(CC) $(LFLAGS) -o $(GAME) $(HOBJ) $(WINLIB) $(LIBS)
++ @$(CC) $(LFLAGS) -o $(GAME) $(HOBJ) $(LDFLAGS) $(WINLIB) $(LIBS)
+ @touch Sysunix
+
+ Sys3B2: $(HOBJ) Makefile
+@@ -445,10 +482,10 @@ objects.o:
# Qt windowport meta-object-compiler output
qt_kde0.moc: ../include/qt_kde0.h