aboutsummaryrefslogtreecommitdiff
path: root/games/nethack36
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2019-09-21 22:00:47 +0000
committerGreg Lewis <glewis@FreeBSD.org>2019-09-21 22:00:47 +0000
commit8b709ede438e6dff453f8e51f02d47c4755be61c (patch)
tree4e4b266945bacdc81027075562c27445fda428dd /games/nethack36
parent3925a8a047b727ec554cbfac1e671ebdf4435a38 (diff)
downloadports-8b709ede438e6dff453f8e51f02d47c4755be61c.tar.gz
ports-8b709ede438e6dff453f8e51f02d47c4755be61c.zip
Update to 3.6.2; preserve scores and config
* Update to 3.6.2 * Remove MARK_JOBS_UNSAFE, I have no problems building this on a MP machine without this. * Preserve the sysconf, logfile, record, and xlogfile files across updates by copying them to *.sample and marking them with @sample in the packing list. This preserves user configuration changes (sysconf) and high score records (logfile, record, xlogfile).
Notes
Notes: svn path=/head/; revision=512542
Diffstat (limited to 'games/nethack36')
-rw-r--r--games/nethack36/Makefile15
-rw-r--r--games/nethack36/distinfo6
-rw-r--r--games/nethack36/files/patch-sys-unix-Makefile.src58
-rw-r--r--games/nethack36/files/patch-sys-unix-setup.sh11
-rw-r--r--games/nethack36/files/patch-util-makedefs.c22
-rw-r--r--games/nethack36/pkg-plist14
6 files changed, 62 insertions, 64 deletions
diff --git a/games/nethack36/Makefile b/games/nethack36/Makefile
index d5f2a08ac2c0..9be5814be06a 100644
--- a/games/nethack36/Makefile
+++ b/games/nethack36/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= nethack36
-PORTVERSION= 3.6.1
-PORTREVISION= 1
+PORTVERSION= 3.6.2
CATEGORIES= games
-MASTER_SITES= SF/${TRUEPORTNAME}/${TRUEPORTNAME}/${PORTVERSION}
+MASTER_SITES= https://nethack.org/download/${PORTVERSION}/
DISTNAME= ${TRUEPORTNAME}-${PORTVERSION:S/.//g}-src
MAINTAINER= glewis@FreeBSD.org
@@ -22,7 +21,6 @@ USES= alias gmake ncurses tar:tgz
MAKE_ENV= GRAPHICS="${GRAPHICS}"
PLIST_SUB= HACKNAME="${HACKNAME}" \
HACKEXT="${HACKEXT}"
-MAKE_JOBS_UNSAFE= yes
TRUEPORTNAME= nethack
# Configure these variables as you want them to be.
@@ -93,7 +91,14 @@ post-install:
.endif
@cd ${WRKSRC}/doc; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} manpages
@${MKDIR} ${STAGEDIR}${DATADIR}/save
- @${CP} ${WRKSRC}/sys/unix/sysconf ${STAGEDIR}${DATADIR}/sysconf
+ @${CP} ${WRKSRC}/sys/unix/sysconf ${STAGEDIR}/${DATADIR}/sysconf
+ # Make sysconf a sample to prevent it being removed if altered
+ @${CP} ${STAGEDIR}/${DATADIR}/sysconf ${STAGEDIR}/${DATADIR}/sysconf.sample
+ # Make "sample" files from records to prevent them being removed
+ # if they have been altered
+ @${CP} ${STAGEDIR}/${DATADIR}/logfile ${STAGEDIR}/${DATADIR}/logfile.sample
+ @${CP} ${STAGEDIR}/${DATADIR}/record ${STAGEDIR}/${DATADIR}/record.sample
+ @${CP} ${STAGEDIR}/${DATADIR}/xlogfile ${STAGEDIR}/${DATADIR}/xlogfile.sample
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/Guidebook.txt ${STAGEDIR}${DOCSDIR}
diff --git a/games/nethack36/distinfo b/games/nethack36/distinfo
index 5863c238a661..ec09801dfcae 100644
--- a/games/nethack36/distinfo
+++ b/games/nethack36/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1552421527
-SHA256 (nethack-361-src.tgz) = 4b8cbf1cc3ad9f6b9bae892d44a9c63106d44782a210906162a7c3be65040ab6
-SIZE (nethack-361-src.tgz) = 4640769
+TIMESTAMP = 1557992328
+SHA256 (nethack-362-src.tgz) = fbd00ada6a4ee347ecd4a350a5b2995b4b4ab5dcc63881b3bc4485b0479ddb1d
+SIZE (nethack-362-src.tgz) = 4908750
diff --git a/games/nethack36/files/patch-sys-unix-Makefile.src b/games/nethack36/files/patch-sys-unix-Makefile.src
index 00bf504b5017..1ac53670fbef 100644
--- a/games/nethack36/files/patch-sys-unix-Makefile.src
+++ b/games/nethack36/files/patch-sys-unix-Makefile.src
@@ -1,6 +1,6 @@
---- sys/unix/Makefile.src.orig 2018-04-27 05:07:22.000000000 -0700
-+++ sys/unix/Makefile.src 2019-03-12 14:55:40.550273000 -0700
-@@ -151,13 +151,24 @@
+--- sys/unix/Makefile.src.orig 2019-05-08 00:00:16.000000000 -0700
++++ sys/unix/Makefile.src 2019-05-16 08:16:17.494864000 -0700
+@@ -165,13 +165,24 @@
# directories. The ones given below is the usual spot for linux systems.
# The paths are for glibconfig.h and gnomesupport.h respectively.
#
@@ -26,12 +26,11 @@
# The Qt and Be window systems are written in C++, while the rest of
# NetHack is standard C. If using Qt, uncomment the LINK line here to get
-@@ -245,8 +256,27 @@
-
- #
- #
--#WINSRC = $(WINTTYSRC)
--#WINOBJ = $(WINTTYOBJ)
+@@ -273,6 +284,29 @@
+ # Curses - Karl Garrison, Tangles
+ #WINSRC = $(WINCURSESSRC)
+ #WINOBJ = $(WINCURSESOBJ)
++
+WINSRC = $(WINTTYSRC)
+ifeq ("$(GRAPHICS)","X11_GRAPHICS")
+WINSRC += $(WINX11SRC)
@@ -53,10 +52,11 @@
+ifeq ("$(GRAPHICS)","GNOME_GRAPHICS")
+WINOBJ += $(WINGNOMEOBJ)
+endif
-
++
+ #
# on some systems the termcap library is in -ltermcap or -lcurses
# on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
-@@ -263,16 +293,19 @@
+@@ -289,6 +323,7 @@
# WINTTYLIB = -lcurses16
# WINTTYLIB = -lncurses
#WINTTYLIB = -ltermlib
@@ -64,21 +64,21 @@
#
# libraries for X11
# If USE_XPM is defined in config.h, you will also need -lXpm here.
--WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11
-+#WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11
-+WINX11LIB = -lXaw -lXmu -lXpm -lXext -lXt -lX11 -lSM -lICE -L${LOCALBASE}/lib
+@@ -296,10 +331,12 @@
# WINX11LIB = -lXaw -lXmu -lXt -lX11
# WINX11LIB = -lXaw -lXmu -lXext -lXt -lXpm -lX11 -lm
# WINX11LIB = -lXaw -lXmu -lXpm -lXext -lXt -lX11 -lSM -lICE -lm # BSD/OS 2.0
++WINX11LIB = -lXaw -lXmu -lXpm -lXext -lXt -lX11 -lSM -lICE -L${LOCALBASE}/lib
+ #
#
# libraries for Qt 3
-WINQTLIB = -L$(QTDIR)/lib -lqt
+#WINQTLIB = -L$(QTDIR)/lib -lqt
-+WINQTLIB = ${QTCFGLIBS} ${LIBQT}
+++WINQTLIB = ${QTCFGLIBS} ${LIBQT}
#
# libraries for Qt 4
WINQT4LIB = `pkg-config QtGui --libs`
-@@ -281,7 +314,8 @@
+@@ -311,7 +348,8 @@
WINKDELIB = -lkdecore -lkdeui -lXext
#
# libraries for Gnome
@@ -88,11 +88,20 @@
#
# libraries for Gem port
WINGEMLIB = -le_gem -lgem
-@@ -289,7 +323,16 @@
- # libraries for BeOS
- WINBELIB = -lbe
-
--#WINLIB = $(WINTTYLIB)
+@@ -321,7 +359,7 @@
+ #
+ # libraries for curses port
+ # link with ncurses
+-WINCURSESLIB = -lncurses
++WINCURSESLIB = -lncurses -L${LOCALBASE}/lib
+ # link with pdcurses for SDL, installed in a separate directory
+ #WINCURSESLIB = -L/usr/local/lib/pdcurses -lpdcurses -lSDL
+ # same as above, for XCurses
+@@ -331,6 +369,18 @@
+ #
+ # For Curses
+ #WINLIB = $(WINCURSESLIB)
++
+WINLIB = $(WINTTYLIB)
+ifeq ("$(GRAPHICS)","X11_GRAPHICS")
+WINLIB += $(WINX11LIB)
@@ -103,10 +112,11 @@
+ifeq ("$(GRAPHICS)","GNOME_GRAPHICS")
+WINLIB += $(WINGNOMELIB)
+endif
-
++
+ #
# any other strange libraries your system needs (for Sysunix only -- the more
# specialized targets should already be right)
-@@ -322,7 +365,7 @@
+@@ -363,7 +413,7 @@
LIBS =
# make NetHack
@@ -115,7 +125,7 @@
# GAME = nethack.prg
# if you defined RANDOM in unixconf.h/tosconf.h since your system did not come
-@@ -548,13 +591,13 @@
+@@ -597,13 +647,13 @@
# Qt 3 windowport meta-object-compiler output
qt_kde0.moc: ../include/qt_kde0.h
diff --git a/games/nethack36/files/patch-sys-unix-setup.sh b/games/nethack36/files/patch-sys-unix-setup.sh
deleted file mode 100644
index 08b973677eaf..000000000000
--- a/games/nethack36/files/patch-sys-unix-setup.sh
+++ /dev/null
@@ -1,11 +0,0 @@
---- sys/unix/setup.sh.orig 2019-03-12 15:54:29.880771000 -0700
-+++ sys/unix/setup.sh 2019-03-12 15:55:10.991928000 -0700
-@@ -26,7 +26,7 @@
- ;;
- esac
-
--if [ ! -f "$hints" ]; then
-+if [ ! -f "$hints" -a "$hints" != "/dev/null" ]; then
- echo "Cannot find hints file $hfile"
- exit 1
- fi
diff --git a/games/nethack36/files/patch-util-makedefs.c b/games/nethack36/files/patch-util-makedefs.c
index 128f837ab879..bce05ffa9b08 100644
--- a/games/nethack36/files/patch-util-makedefs.c
+++ b/games/nethack36/files/patch-util-makedefs.c
@@ -1,14 +1,14 @@
---- util/makedefs.c.orig 2015-11-09 11:13:10 UTC
-+++ util/makedefs.c
-@@ -135,6 +135,7 @@
- /*-end of vision defs-*/
+--- util/makedefs.c.orig 2019-05-08 00:00:16.000000000 -0700
++++ util/makedefs.c 2019-05-16 08:21:09.868001000 -0700
+@@ -139,6 +139,7 @@
+ #define MAXFNAMELEN 600
- static char filename[600];
-+static char tempfilename[600]; /* grep.tmp.<pid> */
+ static char filename[MAXFNAMELEN];
++static char tempfilename[MAXFNAMELEN];
#ifdef FILE_PREFIX
/* if defined, a first argument not starting with - is
-@@ -261,6 +262,12 @@
+@@ -272,6 +273,12 @@
return 1;
}
@@ -21,7 +21,7 @@
#ifdef FILE_PREFIX
if (argc >= 2 && argv[1][0] != '-') {
file_prefix = argv[1];
-@@ -949,9 +956,9 @@
+@@ -967,9 +974,9 @@
}
Fprintf(ofp, "%s", Dont_Edit_Data);
@@ -33,7 +33,7 @@
while ((line = fgetline(ifp)) != 0) {
if (line[0] != '#' && line[0] != '\n')
-@@ -961,7 +968,7 @@
+@@ -979,7 +986,7 @@
Fclose(ifp);
Fclose(ofp);
@@ -42,7 +42,7 @@
return;
}
-@@ -1955,9 +1962,9 @@
+@@ -2230,9 +2237,9 @@
}
Fprintf(ofp, "%s", Dont_Edit_Data);
@@ -54,7 +54,7 @@
while ((line = fgetline(ifp)) != 0) {
SpinCursor(3);
-@@ -1973,7 +1980,7 @@
+@@ -2247,7 +2254,7 @@
Fclose(ifp);
Fclose(ofp);
diff --git a/games/nethack36/pkg-plist b/games/nethack36/pkg-plist
index 4f15a73425f8..1c74b337c426 100644
--- a/games/nethack36/pkg-plist
+++ b/games/nethack36/pkg-plist
@@ -103,9 +103,7 @@ bin/%%HACKNAME%%
%%DATADIR%%/keyhelp
%%DATADIR%%/knox.lev
%%DATADIR%%/license
-@mode 664
-%%DATADIR%%/logfile
-@mode
+@sample(games,games,664) %%DATADIR%%/logfile.sample
%%DATADIR%%/mapbg.xpm
%%DATADIR%%/medusa-1.lev
%%DATADIR%%/medusa-2.lev
@@ -133,9 +131,7 @@ bin/%%HACKNAME%%
%%DATADIR%%/pet_mark.xbm
%%DATADIR%%/pilemark.xbm
%%DATADIR%%/quest.dat
-@mode 664
-%%DATADIR%%/record
-@mode
+@sample(games,games,664) %%DATADIR%%/record.sample
@mode 02755
%%DATADIR%%/recover
@mode
@@ -151,7 +147,7 @@ bin/%%HACKNAME%%
%%DATADIR%%/soko4-1.lev
%%DATADIR%%/soko4-2.lev
%%DATADIR%%/symbols
-%%DATADIR%%/sysconf
+@sample(games,games,) %%DATADIR%%/sysconf.sample
%%DATADIR%%/tower1.lev
%%DATADIR%%/tower2.lev
%%DATADIR%%/tower3.lev
@@ -163,9 +159,7 @@ bin/%%HACKNAME%%
%%DATADIR%%/wizard3.lev
%%DATADIR%%/wizhelp
%%DATADIR%%/x11tiles
-@mode 664
-%%DATADIR%%/xlogfile
-@mode
+@sample(games,games,664) %%DATADIR%%/xlogfile.sample
@owner
@group
man/man6/dgn_comp%%HACKEXT%%.6.gz