aboutsummaryrefslogtreecommitdiff
path: root/games/nextgo
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-11-18 16:31:59 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-11-18 16:31:59 +0000
commitff8bcb8255ccbfd4662c394ac3e22a18763df73f (patch)
treeee183c7e92b7d36d80fdb6ab0127c210421e46a9 /games/nextgo
parentc93268b4f94622f4eb0404e4189137c0d51410dc (diff)
downloadports-ff8bcb8255ccbfd4662c394ac3e22a18763df73f.tar.gz
ports-ff8bcb8255ccbfd4662c394ac3e22a18763df73f.zip
NeXTGo is the classic Go game originally written for the OPENSTEP/Mach
Notes
Notes: svn path=/head/; revision=177512
Diffstat (limited to 'games/nextgo')
-rw-r--r--games/nextgo/Makefile29
-rw-r--r--games/nextgo/distinfo3
-rw-r--r--games/nextgo/files/patch-smartgo.h20
-rw-r--r--games/nextgo/pkg-descr4
-rw-r--r--games/nextgo/pkg-plist19
5 files changed, 75 insertions, 0 deletions
diff --git a/games/nextgo/Makefile b/games/nextgo/Makefile
new file mode 100644
index 000000000000..5dca6c175269
--- /dev/null
+++ b/games/nextgo/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: nextgo
+# Date created: 05 Nov 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= nextgo
+PORTVERSION= 3.0
+CATEGORIES= games
+MASTER_SITES= http://download.savannah.gnu.org/releases/gap/
+DISTNAME= NeXTGo-${PORTVERSION}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= classic Go game for OPENSTEP/GNUstep
+
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+MAKEFILE= GNUmakefile
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|^GNUSTEP_INSTALLATION_DIR|#GNUSTEP_INSTALLATION_DIR|' \
+ ${WRKSRC}/GNUmakefile
+
+.include <bsd.port.mk>
diff --git a/games/nextgo/distinfo b/games/nextgo/distinfo
new file mode 100644
index 000000000000..28fc37db8595
--- /dev/null
+++ b/games/nextgo/distinfo
@@ -0,0 +1,3 @@
+MD5 (NeXTGo-3.0.tar.gz) = 79979e9fe45d83822f583d4a9258a1d0
+SHA256 (NeXTGo-3.0.tar.gz) = 47ae54f0b71b72e7250e3ae97b420fe56ae80ec9b1db7ea272983eeb33ccb146
+SIZE (NeXTGo-3.0.tar.gz) = 197386
diff --git a/games/nextgo/files/patch-smartgo.h b/games/nextgo/files/patch-smartgo.h
new file mode 100644
index 000000000000..77e08ff5e3b8
--- /dev/null
+++ b/games/nextgo/files/patch-smartgo.h
@@ -0,0 +1,20 @@
+--- smartgo.h.orig Sun Jan 12 05:01:52 2003
++++ smartgo.h Sat Nov 18 17:18:57 2006
+@@ -122,7 +122,7 @@
+ extern node* parse_tree(char* inputBuffer);
+
+ /* Routines from smartgoeval.c needed by other routines. */
+-extern void evaluateNode(char *c, unsigned char b[][]);
++extern void evaluateNode(char *c, unsigned char b[19][19]);
+
+
+ /* Routines from smartgotree.c needed by other routines. */
+@@ -134,7 +134,7 @@
+ extern node* forwardOneVariant(node* currentNode);
+ extern node* backOneVariant(node* currentNode);
+ extern void clearNodeFlags(node* currentNode);
+-extern int evaluateSteps(node* currentNode, node* targetNode, unsigned char b[][]);
++extern int evaluateSteps(node* currentNode, node* targetNode, unsigned char b[19][19]);
+ extern void buildToNode(node* targetNode);
+ extern node* stepForward(node* currentNode);
+ extern node* stepBackward(node* currentNode);
diff --git a/games/nextgo/pkg-descr b/games/nextgo/pkg-descr
new file mode 100644
index 000000000000..92a47b6cc2e6
--- /dev/null
+++ b/games/nextgo/pkg-descr
@@ -0,0 +1,4 @@
+NeXTGo is the classic Go game originally written for the OPENSTEP/Mach
+environment.
+
+WWW: http://www.nongnu.org/gap/nextgo/index.html
diff --git a/games/nextgo/pkg-plist b/games/nextgo/pkg-plist
new file mode 100644
index 000000000000..c245294d4711
--- /dev/null
+++ b/games/nextgo/pkg-plist
@@ -0,0 +1,19 @@
+Local/Applications/NeXTGo.app/NeXTGo
+Local/Applications/NeXTGo.app/Resources/Background.tiff
+Local/Applications/NeXTGo.app/Resources/English.lproj/NeXTGo.gorm/data.classes
+Local/Applications/NeXTGo.app/Resources/English.lproj/NeXTGo.gorm/data.info
+Local/Applications/NeXTGo.app/Resources/English.lproj/NeXTGo.gorm/objects.gorm
+Local/Applications/NeXTGo.app/Resources/Info-gnustep.plist
+Local/Applications/NeXTGo.app/Resources/NeXTGo.background-2.0.draw
+Local/Applications/NeXTGo.app/Resources/NeXTGo.background.draw
+Local/Applications/NeXTGo.app/Resources/NeXTGo.desktop
+Local/Applications/NeXTGo.app/Resources/NeXTGo.tiff
+Local/Applications/NeXTGo.app/Resources/NeXTGoFile.tiff
+Local/Applications/NeXTGo.app/Resources/NeXTGoHelp.rtf
+Local/Applications/NeXTGo.app/Resources/intergo.dct
+Local/Applications/NeXTGo.app/library_paths.openapp
+Local/Applications/NeXTGo.app/stamp.make
+@dirrm Local/Applications/NeXTGo.app/Resources/English.lproj/NeXTGo.gorm
+@dirrm Local/Applications/NeXTGo.app/Resources/English.lproj
+@dirrm Local/Applications/NeXTGo.app/Resources
+@dirrm Local/Applications/NeXTGo.app