aboutsummaryrefslogtreecommitdiff
path: root/games/nighthawk
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-07 05:30:42 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-07 05:30:42 +0000
commit12d0201572ad453ae58e4c7810a81491ee581973 (patch)
treeb6b8944a63c67ec51fee6c2d547cea4f7fb92d65 /games/nighthawk
parentcba19b1b911dc59caa4fa56fd3c3707cd2d546e0 (diff)
downloadports-12d0201572ad453ae58e4c7810a81491ee581973.tar.gz
ports-12d0201572ad453ae58e4c7810a81491ee581973.zip
Add nighthawk 2.2, an X11 shoot-'em up which requires some lateral
thinking. PR: 26341 Submitted by: Mark Pulford <mark@kyne.com.au>
Notes
Notes: svn path=/head/; revision=41002
Diffstat (limited to 'games/nighthawk')
-rw-r--r--games/nighthawk/Makefile28
-rw-r--r--games/nighthawk/distinfo1
-rw-r--r--games/nighthawk/files/patch-configure28
-rw-r--r--games/nighthawk/files/patch-src-nighthawk.cc11
-rw-r--r--games/nighthawk/files/patch-src_sound-Makefile.in23
-rw-r--r--games/nighthawk/pkg-comment1
-rw-r--r--games/nighthawk/pkg-descr11
-rw-r--r--games/nighthawk/pkg-install9
-rw-r--r--games/nighthawk/pkg-plist253
9 files changed, 365 insertions, 0 deletions
diff --git a/games/nighthawk/Makefile b/games/nighthawk/Makefile
new file mode 100644
index 000000000000..223c47bcc0f4
--- /dev/null
+++ b/games/nighthawk/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: nighthawk
+# Date created: Apr 4, 2001
+# Whom: Mark Pulford <mark@kyne.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nighthawk
+PORTVERSION= 2.2
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SUNSITE} http://jsno.downunder.net.au/rel/unix_projects/
+MASTER_SITE_SUBDIR= games/arcade
+EXTRACT_SUFX= -1.tar.gz
+
+MAINTAINER= mark@kyne.com.au
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-scores=/var/games/nighthawk.scores --enable-sound
+MAN6= nighthawk.6
+
+post-install:
+ ${CHOWN} root.games ${PREFIX}/bin/nighthawk
+ ${CHMOD} g+s ${PREFIX}/bin/nighthawk
+ ${SH} pkg-install ${PORTNAME} POST-INSTALL
+
+.include <bsd.port.mk>
diff --git a/games/nighthawk/distinfo b/games/nighthawk/distinfo
new file mode 100644
index 000000000000..e719806c8896
--- /dev/null
+++ b/games/nighthawk/distinfo
@@ -0,0 +1 @@
+MD5 (nighthawk-2.2-1.tar.gz) = a737ab6e82df6e077ea59ec7014782ad
diff --git a/games/nighthawk/files/patch-configure b/games/nighthawk/files/patch-configure
new file mode 100644
index 000000000000..bc285597a1e2
--- /dev/null
+++ b/games/nighthawk/files/patch-configure
@@ -0,0 +1,28 @@
+--- configure.orig Wed Apr 4 14:35:14 2001
++++ configure Wed Apr 4 14:35:41 2001
+@@ -3627,15 +3627,15 @@
+ ###
+ ### Status
+ ###
+-echo "$ac_t""### Compile Options ###" 1>&AC_FD_MSG
+-echo "$ac_t""# prefix: $prefix" 1>&AC_FD_MSG
+-echo "$ac_t""# scores file: $SCORES_FILE" 1>&AC_FD_MSG
+-echo "$ac_t""# reduced sprites: $enable_red_sprites" 1>&AC_FD_MSG
+-echo "$ac_t""# sound: $enable_sound" 1>&AC_FD_MSG
++echo "$ac_t""### Compile Options ###"
++echo "$ac_t""# prefix: $prefix"
++echo "$ac_t""# scores file: $SCORES_FILE"
++echo "$ac_t""# reduced sprites: $enable_red_sprites"
++echo "$ac_t""# sound: $enable_sound"
+ if test x"$enable_sound" = xyes; then
+- echo "$ac_t""# mono/stereo: $status_mono_stereo" 1>&AC_FD_MSG
+- echo "$ac_t""# precision: $DEFAULT_PRECISION bit" 1>&AC_FD_MSG
+- echo "$ac_t""# sampling rate: $DEFAULT_SAM_RATE Hz" 1>&AC_FD_MSG
+- echo "$ac_t""# FX channels: $NO_FX_CHANNELS" 1>&AC_FD_MSG
++ echo "$ac_t""# mono/stereo: $status_mono_stereo"
++ echo "$ac_t""# precision: $DEFAULT_PRECISION bit"
++ echo "$ac_t""# sampling rate: $DEFAULT_SAM_RATE Hz"
++ echo "$ac_t""# FX channels: $NO_FX_CHANNELS"
+ fi
+-echo "$ac_t""# make tools: $enable_tools" 1>&AC_FD_MSG
++echo "$ac_t""# make tools: $enable_tools"
diff --git a/games/nighthawk/files/patch-src-nighthawk.cc b/games/nighthawk/files/patch-src-nighthawk.cc
new file mode 100644
index 000000000000..5fcf2957beed
--- /dev/null
+++ b/games/nighthawk/files/patch-src-nighthawk.cc
@@ -0,0 +1,11 @@
+--- src/nighthawk.cc.orig Wed Apr 4 14:23:09 2001
++++ src/nighthawk.cc Wed Apr 4 14:23:19 2001
+@@ -116,7 +116,7 @@
+ FILE *fp;
+
+ if((fp = fopen(filename,mode)) != NULL)
+- flock(fp->_fileno,LOCK_EX);
++ flock(fileno(fp),LOCK_EX);
+ return fp;
+ }
+
diff --git a/games/nighthawk/files/patch-src_sound-Makefile.in b/games/nighthawk/files/patch-src_sound-Makefile.in
new file mode 100644
index 000000000000..6f3fd7d73a44
--- /dev/null
+++ b/games/nighthawk/files/patch-src_sound-Makefile.in
@@ -0,0 +1,23 @@
+--- src_sound/Makefile.in.orig Wed Apr 4 15:30:06 2001
++++ src_sound/Makefile.in Wed Apr 4 15:30:23 2001
+@@ -298,19 +298,7 @@
+ -include $(srcdir)/Make.common
+
+ host_safe:
+- @if [ $(HOST_SAFE) = '1' ]; then \
+- echo "host is safe" >host_safe; \
+- else \
+- echo "***********************************************"; \
+- echo "This is not an INTEL based machine. As the Funktracker"; \
+- echo "format is in Intel byte sex (and i haven't yet made"; \
+- echo "provisions for other processors), trying to play"; \
+- echo "funktracker songs on this machine will be dangerous."; \
+- echo ""; \
+- echo "Refer to INSTALL file."; \
+- echo "***********************************************"; \
+- false; \
+- fi
++ echo "host is safe" >host_safe
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/games/nighthawk/pkg-comment b/games/nighthawk/pkg-comment
new file mode 100644
index 000000000000..70c83487b608
--- /dev/null
+++ b/games/nighthawk/pkg-comment
@@ -0,0 +1 @@
+An X11 shoot-'em up which requires some lateral thinking
diff --git a/games/nighthawk/pkg-descr b/games/nighthawk/pkg-descr
new file mode 100644
index 000000000000..3a1eac2b94e5
--- /dev/null
+++ b/games/nighthawk/pkg-descr
@@ -0,0 +1,11 @@
+Nighthawk is a shoot-'em up which requires thinking more than
+reflexes. Your goal is to destroy droids occupying a fleet of
+reclaimed starships. You start out as a 002 Paradroid with very poor
+firepower and shielding but have the ability to transfer your programs
+over to a new droid, effectively taking it over. As you take control
+of bigger and better droids, you gain better firepower and shielding.
+
+WWW: http://jsno.downunder.net.au/proj_linux/nighthawk.html
+
+- Mark Pulford
+mark@kyne.com.au
diff --git a/games/nighthawk/pkg-install b/games/nighthawk/pkg-install
new file mode 100644
index 000000000000..d147a119debb
--- /dev/null
+++ b/games/nighthawk/pkg-install
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+FILE="/var/games/nighthawk.scores"
+[ "$2" != "POST-INSTALL" -o -f "$FILE" ] && exit 0
+
+echo "===> Creating initial high score file $FILE"
+touch $FILE
+chown root.games $FILE
+chmod 664 $FILE
diff --git a/games/nighthawk/pkg-plist b/games/nighthawk/pkg-plist
new file mode 100644
index 000000000000..94abb1753358
--- /dev/null
+++ b/games/nighthawk/pkg-plist
@@ -0,0 +1,253 @@
+bin/nighthawk
+libexec/nighthawk_sound
+share/nighthawk/data/Anoyle/Bridge.f
+share/nighthawk/data/Anoyle/Bridge.m
+share/nighthawk/data/Anoyle/Engineering.f
+share/nighthawk/data/Anoyle/Engineering.m
+share/nighthawk/data/Anoyle/Gunnery1.f
+share/nighthawk/data/Anoyle/Gunnery1.m
+share/nighthawk/data/Anoyle/Gunnery2.f
+share/nighthawk/data/Anoyle/Gunnery2.m
+share/nighthawk/data/Anoyle/Hull.f
+share/nighthawk/data/Anoyle/Hull.m
+share/nighthawk/data/Anoyle/Medical.f
+share/nighthawk/data/Anoyle/Medical.m
+share/nighthawk/data/Anoyle/chars
+share/nighthawk/data/Anoyle/map.xpm
+share/nighthawk/data/Discovery/Astronomy1.f
+share/nighthawk/data/Discovery/Astronomy1.m
+share/nighthawk/data/Discovery/Astronomy2.f
+share/nighthawk/data/Discovery/Astronomy2.m
+share/nighthawk/data/Discovery/Astrophys.f
+share/nighthawk/data/Discovery/Astrophys.m
+share/nighthawk/data/Discovery/Botany1.f
+share/nighthawk/data/Discovery/Botany1.m
+share/nighthawk/data/Discovery/Botany2.f
+share/nighthawk/data/Discovery/Botany2.m
+share/nighthawk/data/Discovery/Botany3.f
+share/nighthawk/data/Discovery/Botany3.m
+share/nighthawk/data/Discovery/Botany4.f
+share/nighthawk/data/Discovery/Botany4.m
+share/nighthawk/data/Discovery/Bridge.f
+share/nighthawk/data/Discovery/Bridge.m
+share/nighthawk/data/Discovery/Defense.f
+share/nighthawk/data/Discovery/Defense.m
+share/nighthawk/data/Discovery/Engineering.f
+share/nighthawk/data/Discovery/Engineering.m
+share/nighthawk/data/Discovery/chars
+share/nighthawk/data/Discovery/map.xpm
+share/nighthawk/data/Esperence/Bridge.f
+share/nighthawk/data/Esperence/Bridge.m
+share/nighthawk/data/Esperence/Cargo.f
+share/nighthawk/data/Esperence/Cargo.m
+share/nighthawk/data/Esperence/Dock.f
+share/nighthawk/data/Esperence/Dock.m
+share/nighthawk/data/Esperence/Engineering.f
+share/nighthawk/data/Esperence/Engineering.m
+share/nighthawk/data/Esperence/Gunnery1.f
+share/nighthawk/data/Esperence/Gunnery1.m
+share/nighthawk/data/Esperence/Gunnery2.f
+share/nighthawk/data/Esperence/Gunnery2.m
+share/nighthawk/data/Esperence/Gunnery3.f
+share/nighthawk/data/Esperence/Gunnery3.m
+share/nighthawk/data/Esperence/Hull.f
+share/nighthawk/data/Esperence/Hull.m
+share/nighthawk/data/Esperence/chars
+share/nighthawk/data/Esperence/map.xpm
+share/nighthawk/data/Friendship/Bridge.f
+share/nighthawk/data/Friendship/Bridge.m
+share/nighthawk/data/Friendship/Decoy.f
+share/nighthawk/data/Friendship/Decoy.m
+share/nighthawk/data/Friendship/Dock.f
+share/nighthawk/data/Friendship/Dock.m
+share/nighthawk/data/Friendship/Engineering.f
+share/nighthawk/data/Friendship/Engineering.m
+share/nighthawk/data/Friendship/Gunnery1.f
+share/nighthawk/data/Friendship/Gunnery1.m
+share/nighthawk/data/Friendship/Gunnery2.f
+share/nighthawk/data/Friendship/Gunnery2.m
+share/nighthawk/data/Friendship/Gunnery3.f
+share/nighthawk/data/Friendship/Gunnery3.m
+share/nighthawk/data/Friendship/Hull.f
+share/nighthawk/data/Friendship/Hull.m
+share/nighthawk/data/Friendship/chars
+share/nighthawk/data/Friendship/map.xpm
+share/nighthawk/data/Haldeck/Bridge.f
+share/nighthawk/data/Haldeck/Bridge.m
+share/nighthawk/data/Haldeck/Cargo.f
+share/nighthawk/data/Haldeck/Cargo.m
+share/nighthawk/data/Haldeck/Engineering.f
+share/nighthawk/data/Haldeck/Engineering.m
+share/nighthawk/data/Haldeck/Quarters.f
+share/nighthawk/data/Haldeck/Quarters.m
+share/nighthawk/data/Haldeck/chars
+share/nighthawk/data/Haldeck/map.xpm
+share/nighthawk/data/Mearkat/Bridge.f
+share/nighthawk/data/Mearkat/Bridge.m
+share/nighthawk/data/Mearkat/Hull.f
+share/nighthawk/data/Mearkat/Hull.m
+share/nighthawk/data/Mearkat/chars
+share/nighthawk/data/Mearkat/map.xpm
+share/nighthawk/data/Ophukus/Bridge.f
+share/nighthawk/data/Ophukus/Bridge.m
+share/nighthawk/data/Ophukus/Dock.f
+share/nighthawk/data/Ophukus/Dock.m
+share/nighthawk/data/Ophukus/Engineering.f
+share/nighthawk/data/Ophukus/Engineering.m
+share/nighthawk/data/Ophukus/Trauma1.f
+share/nighthawk/data/Ophukus/Trauma1.m
+share/nighthawk/data/Ophukus/Trauma2.f
+share/nighthawk/data/Ophukus/Trauma2.m
+share/nighthawk/data/Ophukus/chars
+share/nighthawk/data/Ophukus/map.xpm
+share/nighthawk/data/Seafarer/Bridge.f
+share/nighthawk/data/Seafarer/Bridge.m
+share/nighthawk/data/Seafarer/Cargo1.f
+share/nighthawk/data/Seafarer/Cargo1.m
+share/nighthawk/data/Seafarer/Cargo2.f
+share/nighthawk/data/Seafarer/Cargo2.m
+share/nighthawk/data/Seafarer/Cargo3.f
+share/nighthawk/data/Seafarer/Cargo3.m
+share/nighthawk/data/Seafarer/Engineering.f
+share/nighthawk/data/Seafarer/Engineering.m
+share/nighthawk/data/Seafarer/Quarters.f
+share/nighthawk/data/Seafarer/Quarters.m
+share/nighthawk/data/Seafarer/chars
+share/nighthawk/data/Seafarer/map.xpm
+share/nighthawk/data/Tobruk/Bridge.f
+share/nighthawk/data/Tobruk/Bridge.m
+share/nighthawk/data/Tobruk/Dock.f
+share/nighthawk/data/Tobruk/Dock.m
+share/nighthawk/data/Tobruk/Hull.f
+share/nighthawk/data/Tobruk/Hull.m
+share/nighthawk/data/Tobruk/chars
+share/nighthawk/data/Tobruk/map.xpm
+share/nighthawk/data/Zaxon/Bridge.f
+share/nighthawk/data/Zaxon/Bridge.m
+share/nighthawk/data/Zaxon/Cargo.f
+share/nighthawk/data/Zaxon/Cargo.m
+share/nighthawk/data/Zaxon/Comms.f
+share/nighthawk/data/Zaxon/Comms.m
+share/nighthawk/data/Zaxon/Decoy.f
+share/nighthawk/data/Zaxon/Decoy.m
+share/nighthawk/data/Zaxon/Dock.f
+share/nighthawk/data/Zaxon/Dock.m
+share/nighthawk/data/Zaxon/Engineering.f
+share/nighthawk/data/Zaxon/Engineering.m
+share/nighthawk/data/Zaxon/Gunnery1.f
+share/nighthawk/data/Zaxon/Gunnery1.m
+share/nighthawk/data/Zaxon/Gunnery2.f
+share/nighthawk/data/Zaxon/Gunnery2.m
+share/nighthawk/data/Zaxon/Hull.f
+share/nighthawk/data/Zaxon/Hull.m
+share/nighthawk/data/Zaxon/Medical.f
+share/nighthawk/data/Zaxon/Medical.m
+share/nighthawk/data/Zaxon/chars
+share/nighthawk/data/Zaxon/map.xpm
+share/nighthawk/data/fx/6xx_voice.8
+share/nighthawk/data/fx/7xx_voice.8
+share/nighthawk/data/fx/8xx_voice.8
+share/nighthawk/data/fx/alert_siren.8
+share/nighthawk/data/fx/door_open.8
+share/nighthawk/data/fx/droid_evase.8
+share/nighthawk/data/fx/droid_hit_1.8
+share/nighthawk/data/fx/explosion_1.8
+share/nighthawk/data/fx/explosion_2.8
+share/nighthawk/data/fx/laser_buzz.8
+share/nighthawk/data/fx/laser_crocoite_benzol.8
+share/nighthawk/data/fx/laser_linarite.8
+share/nighthawk/data/fx/laser_tiger_eye.8
+share/nighthawk/data/fx/laser_uvarovite.8
+share/nighthawk/data/fx/low_shields.8
+share/nighthawk/data/fx/no_weapon.8
+share/nighthawk/data/fx/power_up.8
+share/nighthawk/data/fx/rand.8
+share/nighthawk/data/fx/select.8
+share/nighthawk/data/fx/ship_complete.8
+share/nighthawk/data/fx/snoise1.raw
+share/nighthawk/data/fx/snoise2.raw
+share/nighthawk/data/fx/snoise3.raw
+share/nighthawk/data/fx/snoise4.raw
+share/nighthawk/data/fx/snoise5.raw
+share/nighthawk/data/fx/snoise6.raw
+share/nighthawk/data/fx/snoise7_science.raw
+share/nighthawk/data/fx/trans_terminated.8
+share/nighthawk/data/fx/weapon_reload.8
+share/nighthawk/data/music/Rescue_from_Vega.fnk
+share/nighthawk/data/music/introtune.fnk
+share/nighthawk/data/xpm/standard/credit_1.xpm
+share/nighthawk/data/xpm/standard/credit_2.xpm
+share/nighthawk/data/xpm/standard/credit_3.xpm
+share/nighthawk/data/xpm/standard/credit_4.xpm
+share/nighthawk/data/xpm/standard/credit_5.xpm
+share/nighthawk/data/xpm/standard/credit_6.xpm
+share/nighthawk/data/xpm/standard/demo_mode.xpm
+share/nighthawk/data/xpm/standard/digits.xpm
+share/nighthawk/data/xpm/standard/digits2.xpm
+share/nighthawk/data/xpm/standard/docking_to_ship.xpm
+share/nighthawk/data/xpm/standard/droid_ani.xpm
+share/nighthawk/data/xpm/standard/explosion.xpm
+share/nighthawk/data/xpm/standard/flr_base_cyan.xpm
+share/nighthawk/data/xpm/standard/flr_chair_l_cyan.xpm
+share/nighthawk/data/xpm/standard/flr_con_b_cyan.xpm
+share/nighthawk/data/xpm/standard/flr_con_l_cyan.xpm
+share/nighthawk/data/xpm/standard/flr_con_r_cyan.xpm
+share/nighthawk/data/xpm/standard/flr_con_t_cyan.xpm
+share/nighthawk/data/xpm/standard/flr_crosses_cyan.xpm
+share/nighthawk/data/xpm/standard/flr_dashes_cyan.xpm
+share/nighthawk/data/xpm/standard/flr_door_h_cyan.xpm
+share/nighthawk/data/xpm/standard/flr_door_h_cyan_ani.xpm
+share/nighthawk/data/xpm/standard/flr_door_v_cyan.xpm
+share/nighthawk/data/xpm/standard/flr_door_v_cyan_ani.xpm
+share/nighthawk/data/xpm/standard/flr_elev_cyan.xpm
+share/nighthawk/data/xpm/standard/flr_pattern1_cyan.xpm
+share/nighthawk/data/xpm/standard/flr_pattern2_cyan.xpm
+share/nighthawk/data/xpm/standard/flr_pattern3_cyan.xpm
+share/nighthawk/data/xpm/standard/flr_pattern4_cyan.xpm
+share/nighthawk/data/xpm/standard/flr_sqrs_cyan.xpm
+share/nighthawk/data/xpm/standard/flr_store1_cyan.xpm
+share/nighthawk/data/xpm/standard/flr_wall_bj_cyan.xpm
+share/nighthawk/data/xpm/standard/flr_wall_bl_cyan.xpm
+share/nighthawk/data/xpm/standard/flr_wall_br_cyan.xpm
+share/nighthawk/data/xpm/standard/flr_wall_h_cyan.xpm
+share/nighthawk/data/xpm/standard/flr_wall_v_cyan.xpm
+share/nighthawk/data/xpm/standard/flr_wall_lj_cyan.xpm
+share/nighthawk/data/xpm/standard/flr_wall_rj_cyan.xpm
+share/nighthawk/data/xpm/standard/flr_wall_tj_cyan.xpm
+share/nighthawk/data/xpm/standard/flr_wall_tl_cyan.xpm
+share/nighthawk/data/xpm/standard/flr_wall_tr_cyan.xpm
+share/nighthawk/data/xpm/standard/intro_back_1.xpm
+share/nighthawk/data/xpm/standard/intro_back_2.xpm
+share/nighthawk/data/xpm/standard/intro_back_3.xpm
+share/nighthawk/data/xpm/standard/intro_back_4.xpm
+share/nighthawk/data/xpm/standard/laser_cb.xpm
+share/nighthawk/data/xpm/standard/laser_l.xpm
+share/nighthawk/data/xpm/standard/laser_te.xpm
+share/nighthawk/data/xpm/standard/laser_uv.xpm
+share/nighthawk/data/xpm/standard/neg.xpm
+share/nighthawk/data/xpm/standard/nothing.xpm
+share/nighthawk/data/xpm/standard/ntitle.xpm
+share/nighthawk/data/xpm/standard/paradroid_ani.xpm
+share/nighthawk/data/xpm/standard/paused.xpm
+share/nighthawk/data/xpm/standard/power_bay.xpm
+share/nighthawk/data/xpm/standard/ship_complete.xpm
+share/nighthawk/data/xpm/standard/trans_terminated.xpm
+share/nighthawk/data/xpm/xpm.i
+share/nighthawk/data/ctrl.d
+share/nighthawk/data/demo.d
+@dirrm share/nighthawk/data/Anoyle
+@dirrm share/nighthawk/data/Discovery
+@dirrm share/nighthawk/data/Esperence
+@dirrm share/nighthawk/data/Friendship
+@dirrm share/nighthawk/data/Haldeck
+@dirrm share/nighthawk/data/Mearkat
+@dirrm share/nighthawk/data/Ophukus
+@dirrm share/nighthawk/data/Seafarer
+@dirrm share/nighthawk/data/Tobruk
+@dirrm share/nighthawk/data/Zaxon
+@dirrm share/nighthawk/data/fx
+@dirrm share/nighthawk/data/music
+@dirrm share/nighthawk/data/xpm/standard
+@dirrm share/nighthawk/data/xpm
+@dirrm share/nighthawk/data
+@dirrm share/nighthawk