aboutsummaryrefslogtreecommitdiff
path: root/games/ninix-aya/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-12-06 17:59:43 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-12-06 17:59:43 +0000
commit1fe47cdbc6c3bfa28921fbc93715e422a86282fa (patch)
tree2d91ca1ca983f93e4ef6af1dedaf51883ac7f92a /games/ninix-aya/Makefile
parent566f4b19bdf92d826867da780f148f32b2c77d09 (diff)
Add nanix-aya 2.4.3, is a desktop mascot program which is compatible
with Windows desktop mascot program `Ukagaka'(or well known `Nanika'). Feature: SSTP(Sakura[1] Script Transfer Protocol) SHIORI, core of ghost[2], module (Aya compatible) Kawari8, semi-AI, module SAORI module Communication between ghosts and ghosts. and many many CCCCCUUUUUTTTTTEEEEE features! [1] Card Capter Sakura (http://www.clamp-net.com/main.html) [2] ghost == character's core (maybe, you know Ghost In The Shell) e.g. shell == interface PR: ports/59989 Submitted by: UMENO Takashi <umeno@rr.iij4u.or.jp>
Notes
Notes: svn path=/head/; revision=95195
Diffstat (limited to 'games/ninix-aya/Makefile')
-rw-r--r--games/ninix-aya/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/games/ninix-aya/Makefile b/games/ninix-aya/Makefile
new file mode 100644
index 000000000000..ca0e409b8ee7
--- /dev/null
+++ b/games/ninix-aya/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: ninix-aya
+# Date created: 6 Dec 2003
+# Whom: UMENO Takashi
+#
+# $FreeBSD$
+#
+
+PORTNAME= ninix-aya
+PORTVERSION= 2.4.3
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
+MASTER_SITE_SUBDIR= ninix-aya/7074
+DISTNAME= ninix-aya-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= umeno@rr.iij4u.or.jp
+COMMENT= Ninix-aya is a compatible with desktop mascot program "Ukagaka"
+
+LIB_DEPENDS= png:${PORTSDIR}/graphics/png
+RUN_DEPENDS= unzip:${PORTSDIR}/archivers/unzip \
+ lha:${PORTSDIR}/archivers/lha \
+ ${PYTHON_SITELIBDIR}/japanese.pth:${PORTSDIR}/japanese/pycodec \
+ ${PYTHON_SITELIBDIR}/gtk-2.0/gtk/__init__.py:${PORTSDIR}/x11-toolkits/py-gtk2
+
+PLIST_SUB= LOCALBASE=${LOCALBASE}
+
+USE_PYTHON= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+
+WRKSRC= ${WRKDIR}/ninix-aya-${PORTVERSION}
+
+.include <bsd.port.mk>