aboutsummaryrefslogtreecommitdiff
path: root/games/odamex
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-02-24 17:20:49 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-02-24 17:20:49 +0000
commit6a431e18febdaeb56d740aebed97757a0c736ab2 (patch)
treed3f9a22ebd6d6f6f67552b9b25c305d89c3eeefd /games/odamex
parent9f9a1a0e4da62abc056004ef15f84c5b4e011867 (diff)
downloadports-6a431e18febdaeb56d740aebed97757a0c736ab2.tar.gz
ports-6a431e18febdaeb56d740aebed97757a0c736ab2.zip
- Update to 0.6.2
- Remove unneeded option - Trim Makefile headers PR: ports/174093 Submitted by: Green Dog <fiziologus@gmail.com>
Notes
Notes: svn path=/head/; revision=312882
Diffstat (limited to 'games/odamex')
-rw-r--r--games/odamex/Makefile55
-rw-r--r--games/odamex/distinfo4
-rw-r--r--games/odamex/files/patch-CMakeLists.txt13
-rw-r--r--games/odamex/files/patch-Makefile56
-rw-r--r--games/odamex/files/patch-client-src-cl_download.cpp13
-rw-r--r--games/odamex/files/patch-client__src__d_main.cpp11
-rw-r--r--games/odamex/files/patch-common-d_main.cpp13
-rw-r--r--games/odamex/files/patch-odalaunch-CMakeLists.txt10
-rw-r--r--games/odamex/files/patch-odalaunch-src-dlg_main.cpp11
-rw-r--r--games/odamex/files/patch-odalaunch__Makefile18
-rw-r--r--games/odamex/files/patch-server__src__d_main.cpp11
-rw-r--r--games/odamex/pkg-plist17
12 files changed, 110 insertions, 122 deletions
diff --git a/games/odamex/Makefile b/games/odamex/Makefile
index 427028bd1888..06a709142432 100644
--- a/games/odamex/Makefile
+++ b/games/odamex/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: odamex
-# Date created: 2007-12-06
-# Whom: alepulver
-#
+# Created by: alepulver
# $FreeBSD$
-#
PORTNAME= odamex
-PORTVERSION= 0.5.6
+PORTVERSION= 0.6.2
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Odamex/${PORTVERSION}
DISTNAME= odamex-src-${PORTVERSION}
@@ -15,43 +11,40 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= The Standard in Online Multiplayer Doom
USE_BZIP2= yes
-USE_GMAKE= yes
USE_SDL= sdl mixer
+USE_CMAKE= yes
+USE_DOS2UNIX= CMakeLists.txt odalaunch/CMakeLists.txt common/d_main.cpp
-OPTIONS_DEFINE= LAUNCHER MIDI
+OPTIONS_DEFINE= LAUNCHER
LAUNCHER_DESC= Enable GUI launcher program
-MIDI_DESC= Enable MIDI support (timidity)
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MLAUNCHER}
USE_WX= 2.6+
-MAKE_ENV+= WXRC_CMD="${WXRC_CMD}" WITH_LAUNCHER=yes
+CMAKE_ARGS+= -DODALAUNCH_TARGET=on -DNO_AG-ODALAUNCH_TARGET=off
PLIST_SUB+= LAUNCHER=""
.else
PLIST_SUB+= LAUNCHER="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MMIDI}
-RUN_DEPENDS+= timidity:${PORTSDIR}/audio/timidity
+CMAKE_ARGS+= -DODALAUNCH_TARGET=off
.endif
post-patch:
@${REINPLACE_CMD} -e 's|%%DMDIR%%|${DMDIR}|; \
s|%%DATADIR%%|${DATADIR}|' \
- ${WRKSRC}/client/src/d_main.cpp \
- ${WRKSRC}/server/src/d_main.cpp
-
-.if ${PORT_OPTIONS:MLAUNCHER}
- @${REINPLACE_CMD} -e 's|\./odamex|odamex|' \
- ${WRKSRC}/odalaunch/src/misc.cpp
-.endif
+ ${WRKSRC}/common/d_main.cpp
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' \
+ ${WRKSRC}/odalaunch/src/dlg_main.cpp
+ @${REINPLACE_CMD} -e 's|%%WX_VER%%|${WX_VERSION}|' \
+ -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
+ ${WRKSRC}/odalaunch/CMakeLists.txt
+ @${REINPLACE_CMD} -e 's|-waddir /usr/share/doom||' \
+ ${WRKSRC}/installer/arch/odamex.desktop
do-install:
-.for f in odamex odasrv
- ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
-.endfor
+ ${INSTALL_PROGRAM} ${WRKSRC}/client/odamex ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/server/odasrv ${PREFIX}/bin
.if ${PORT_OPTIONS:MLAUNCHER}
${INSTALL_PROGRAM} ${WRKSRC}/odalaunch/odalaunch ${PREFIX}/bin
.endif
@@ -60,6 +53,20 @@ do-install:
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/LICENSE ${DOCSDIR}
+.endif
+.for f in odamex odasrv
+ ${INSTALL_DATA} ${WRKSRC}/media/icon_${f}_*.png ${PREFIX}/share/pixmaps
+.endfor
+.if ${PORT_OPTIONS:MLAUNCHER}
+ ${INSTALL_DATA} ${WRKSRC}/media/icon_odalaunch_*.png ${PREFIX}/share/pixmaps
+.endif
+ ${MKDIR} ${PREFIX}/share/applications
+.for f in odamex odasrv
+ ${INSTALL_DATA} ${WRKSRC}/installer/arch/${f}.desktop ${PREFIX}/share/applications
+.endfor
+.if ${PORT_OPTIONS:MLAUNCHER}
+ ${INSTALL_DATA} ${WRKSRC}/installer/arch/odalaunch.desktop ${PREFIX}/share/applications
.endif
.include "${.CURDIR}/../doom-data/Makefile.include"
diff --git a/games/odamex/distinfo b/games/odamex/distinfo
index 57a8f4074cef..0dcba6c1b738 100644
--- a/games/odamex/distinfo
+++ b/games/odamex/distinfo
@@ -1,2 +1,2 @@
-SHA256 (odamex-src-0.5.6.tar.bz2) = fc832ac2df2fceeed79b512cd789d0d30c93c46b246f50af973bb867b02a3440
-SIZE (odamex-src-0.5.6.tar.bz2) = 2954090
+SHA256 (odamex-src-0.6.2.tar.bz2) = 70534ee0b88f759269b807190f347acacc1a0ff4f9e9e90edeab9aa99d4f316e
+SIZE (odamex-src-0.6.2.tar.bz2) = 8451290
diff --git a/games/odamex/files/patch-CMakeLists.txt b/games/odamex/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..1a15390df3a1
--- /dev/null
+++ b/games/odamex/files/patch-CMakeLists.txt
@@ -0,0 +1,13 @@
+--- CMakeLists.txt.orig 2012-12-03 15:03:21.000000000 +0400
++++ CMakeLists.txt 2012-12-03 15:05:49.000000000 +0400
+@@ -43,7 +43,9 @@
+ add_subdirectory(client)
+ add_subdirectory(server)
+ add_subdirectory(master)
+-add_subdirectory(odalaunch)
++if(ODALAUNCH_TARGET)
++ add_subdirectory(odalaunch)
++endif()
+
+ # Disable the ag-odalaunch target completely: -DNO_AG-ODALAUNCH_TARGET
+ # This is only really useful when setting up a universal build.
diff --git a/games/odamex/files/patch-Makefile b/games/odamex/files/patch-Makefile
deleted file mode 100644
index 3e795597cafd..000000000000
--- a/games/odamex/files/patch-Makefile
+++ /dev/null
@@ -1,56 +0,0 @@
---- Makefile.orig 2011-11-05 05:00:05.000000000 +0100
-+++ Makefile 2011-12-01 05:33:47.415968992 +0100
-@@ -3,8 +3,8 @@
- OBJDIR = obj
- # denis - fixme - remove mkdir -p
- MKDIR = mkdir -p
--CC = g++
--LD = g++
-+CC = $(CXX)
-+LD = $(CC)
- INSTALL = cp
- DEUTEX = deutex
-
-@@ -62,7 +62,7 @@
- DEUTEX_FLAGS = -rgb 0 255 255
-
- # Platform and sdl-config flags
--X11_LFLAGS = -L/usr/X11R6/lib -lX11
-+X11_LFLAGS = -L$(LOCALBASE)/lib -lX11
-
- SDL_CFLAGS_COMMAND = sdl-config --cflags
- SDL_LFLAGS_COMMAND = sdl-config --libs
-@@ -85,8 +85,8 @@
-
- ifeq ($(strip $(freebsd)), true)
- ifeq ($(SDL_CFLAGS),)
--SDL_CFLAGS_COMMAND = sdl11-config --cflags
--SDL_LFLAGS_COMMAND = sdl11-config --libs
-+SDL_CFLAGS_COMMAND = $(SDL_CONFIG) --cflags
-+SDL_LFLAGS_COMMAND = $(SDL_CONFIG) --libs
- SDL_CFLAGS = $(shell $(SDL_CFLAGS_COMMAND))
- SDL_LFLAGS = $(shell $(SDL_LFLAGS_COMMAND)) $(X11_LFLAGS)
- endif
-@@ -177,7 +177,7 @@
- TARGETS = $(SERVER_TARGET) $(CLIENT_TARGET) $(MASTER_TARGET) $(WADFILE_TARGET)
-
- # denis - fixme - cflags are quite messy, but removing these is a very delicate act, also use -Wall -Werror
--CFLAGS = $(CFLAGS_PLATFORM) -DNOASM -Icommon -g -Wall -O2
-+CFLAGS += $(CFLAGS_PLATFORM) -DNOASM -Icommon -g -Wall -O2
- LFLAGS = $(LFLAGS_PLATFORM)
-
- CFLAGS_RELEASE = $(CFLAGS_PLATFORM) -DNOASM -Icommon -O3
-@@ -213,7 +213,12 @@
- # denis - end fixme
-
- # All
--all: $(SERVER_TARGET) $(CLIENT_TARGET) $(WADFILE_TARGET)
-+all: $(SERVER_TARGET) $(CLIENT_TARGET) $(WADFILE_TARGET) launcher
-+
-+launcher:
-+ifdef WITH_LAUNCHER
-+ $(MAKE) -C odalaunch odalaunch
-+endif
-
- # Textscreen
- $(OBJDIR)/$(TEXTSCREEN_DIR)/%.o: $(TEXTSCREEN_DIR)/%.cpp $(TEXTSCREEN_HEADERS) $(COMMON_HEADERS)
diff --git a/games/odamex/files/patch-client-src-cl_download.cpp b/games/odamex/files/patch-client-src-cl_download.cpp
new file mode 100644
index 000000000000..126391eb5fba
--- /dev/null
+++ b/games/odamex/files/patch-client-src-cl_download.cpp
@@ -0,0 +1,13 @@
+--- client/src/cl_download.cpp.orig 2012-05-11 03:03:43.000000000 +0200
++++ client/src/cl_download.cpp 2013-02-19 23:05:21.932196566 +0100
+@@ -170,8 +170,8 @@
+
+ // Try to save to the wad paths in this order -- Hyper_Eye
+ D_AddSearchDir(dirs, Args.CheckValue("-waddir"), separator);
+- D_AddSearchDir(dirs, getenv("DOOMWADDIR"), separator);
+- D_AddSearchDir(dirs, getenv("DOOMWADPATH"), separator);
++ D_AddSearchDir(dirs, "%%DATADIR%%", separator);
++ D_AddSearchDir(dirs, "%%DMDIR%%", separator);
+ D_AddSearchDir(dirs, waddirs.cstring(), separator);
+ dirs.push_back(startdir);
+ dirs.push_back(progdir);
diff --git a/games/odamex/files/patch-client__src__d_main.cpp b/games/odamex/files/patch-client__src__d_main.cpp
deleted file mode 100644
index ecf11ca67996..000000000000
--- a/games/odamex/files/patch-client__src__d_main.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- client/src/d_main.cpp.orig 2011-11-05 05:00:05.000000000 +0100
-+++ client/src/d_main.cpp 2011-12-01 05:33:47.422967926 +0100
-@@ -843,6 +843,8 @@
- D_AddSearchDir(dirs, Args.CheckValue("-waddir"), separator);
- D_AddSearchDir(dirs, getenv("DOOMWADDIR"), separator);
- D_AddSearchDir(dirs, getenv("DOOMWADPATH"), separator);
-+ D_AddSearchDir(dirs, "/usr/local/share/odamex", separator);
-+ D_AddSearchDir(dirs, "/usr/local/share/doom", separator);
- D_AddSearchDir(dirs, getenv("HOME"), separator);
- D_AddSearchDir(dirs, waddirs.cstring(), separator);
-
diff --git a/games/odamex/files/patch-common-d_main.cpp b/games/odamex/files/patch-common-d_main.cpp
new file mode 100644
index 000000000000..38975b984960
--- /dev/null
+++ b/games/odamex/files/patch-common-d_main.cpp
@@ -0,0 +1,13 @@
+--- common/d_main.cpp.orig 2013-02-20 18:09:33.266196581 +0100
++++ common/d_main.cpp 2013-02-20 18:11:13.271203017 +0100
+@@ -490,8 +490,8 @@
+ dirs.push_back(progdir);
+
+ D_AddSearchDir(dirs, Args.CheckValue("-waddir"), separator);
+- D_AddSearchDir(dirs, getenv("DOOMWADDIR"), separator);
+- D_AddSearchDir(dirs, getenv("DOOMWADPATH"), separator);
++ D_AddSearchDir(dirs, "%%DATADIR%%", separator);
++ D_AddSearchDir(dirs, "%%DMDIR%%", separator);
+ D_AddSearchDir(dirs, getenv("HOME"), separator);
+
+ // [AM] Search additional paths based on platform
diff --git a/games/odamex/files/patch-odalaunch-CMakeLists.txt b/games/odamex/files/patch-odalaunch-CMakeLists.txt
new file mode 100644
index 000000000000..5cca6739b040
--- /dev/null
+++ b/games/odamex/files/patch-odalaunch-CMakeLists.txt
@@ -0,0 +1,10 @@
+--- odalaunch/CMakeLists.txt.orig 2012-12-03 16:15:08.000000000 +0400
++++ odalaunch/CMakeLists.txt 2012-12-03 16:20:04.000000000 +0400
+@@ -30,6 +30,7 @@
+
+ # Odalaunch target
+ if(wxWidgets_FOUND)
++ set(wxWidgets_wxrc_EXECUTABLE %%LOCALBASE%%/bin/wxrc-gtk2-%%WX_VER%%)
+ add_custom_command(
+ OUTPUT ${XRCRES_HEADER}
+ COMMAND ${CMAKE_COMMAND} -E make_directory ${CMAKE_CURRENT_BINARY_DIR}/res
diff --git a/games/odamex/files/patch-odalaunch-src-dlg_main.cpp b/games/odamex/files/patch-odalaunch-src-dlg_main.cpp
new file mode 100644
index 000000000000..ce175729f1f2
--- /dev/null
+++ b/games/odamex/files/patch-odalaunch-src-dlg_main.cpp
@@ -0,0 +1,11 @@
+--- odalaunch/src/dlg_main.cpp.orig 2012-05-31 03:49:32.000000000 +0400
++++ odalaunch/src/dlg_main.cpp 2012-12-03 21:21:50.000000000 +0400
+@@ -193,7 +193,7 @@
+ launchercfg_s.get_list_on_start = 1;
+ launchercfg_s.show_blocked_servers = 0;
+ launchercfg_s.wad_paths = wxGetCwd();
+- launchercfg_s.odamex_directory = wxGetCwd();
++ launchercfg_s.odamex_directory = wxString("%%PREFIX%%/bin");
+
+ m_LstCtrlServers = XRCCTRL(*this, "Id_LstCtrlServers", LstOdaServerList);
+ m_LstCtrlPlayers = XRCCTRL(*this, "Id_LstCtrlPlayers", LstOdaPlayerList);
diff --git a/games/odamex/files/patch-odalaunch__Makefile b/games/odamex/files/patch-odalaunch__Makefile
deleted file mode 100644
index 0329615c46a1..000000000000
--- a/games/odamex/files/patch-odalaunch__Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
---- odalaunch/Makefile.orig 2011-11-05 05:00:03.000000000 +0100
-+++ odalaunch/Makefile 2011-12-01 05:33:47.418968116 +0100
-@@ -23,11 +23,11 @@
- -I./res \
- -I../odalpapi
-
--CC = g++
--LD = g++
-+CC = $(CXX)
-+LD = $(CC)
-
--WXCONFIG = wx-config
--WXRC = wxrc
-+WXCONFIG = $(WX_CONFIG)
-+WXRC = $(WXRC_CMD)
-
- # Sometimes wx-config will use the lowest version available, which is what
- # we do no want! -- GhostlyDeath
diff --git a/games/odamex/files/patch-server__src__d_main.cpp b/games/odamex/files/patch-server__src__d_main.cpp
deleted file mode 100644
index 896d4fd6bd50..000000000000
--- a/games/odamex/files/patch-server__src__d_main.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- server/src/d_main.cpp.orig 2011-11-05 04:59:48.000000000 +0100
-+++ server/src/d_main.cpp 2011-12-01 05:33:47.423967844 +0100
-@@ -627,6 +627,8 @@
- D_AddSearchDir(dirs, Args.CheckValue("-waddir"), separator);
- D_AddSearchDir(dirs, getenv("DOOMWADDIR"), separator);
- D_AddSearchDir(dirs, getenv("DOOMWADPATH"), separator);
-+ D_AddSearchDir(dirs, "/usr/local/share/odamex", separator);
-+ D_AddSearchDir(dirs, "/usr/local/share/doom", separator);
- D_AddSearchDir(dirs, getenv("HOME"), separator);
- D_AddSearchDir(dirs, waddirs.cstring(), separator);
-
diff --git a/games/odamex/pkg-plist b/games/odamex/pkg-plist
index dfbc32d366be..aee8a1efc1c2 100644
--- a/games/odamex/pkg-plist
+++ b/games/odamex/pkg-plist
@@ -1,7 +1,24 @@
%%LAUNCHER%%bin/odalaunch
+%%LAUNCHER%%share/applications/odalaunch.desktop
+%%LAUNCHER%%share/pixmaps/icon_odalaunch_128.png
+%%LAUNCHER%%share/pixmaps/icon_odalaunch_256.png
+%%LAUNCHER%%share/pixmaps/icon_odalaunch_512.png
+%%LAUNCHER%%share/pixmaps/icon_odalaunch_96.png
bin/odamex
bin/odasrv
+share/applications/odamex.desktop
+share/applications/odasrv.desktop
+share/pixmaps/icon_odamex_128.png
+share/pixmaps/icon_odamex_256.png
+share/pixmaps/icon_odamex_512.png
+share/pixmaps/icon_odamex_96.png
+share/pixmaps/icon_odasrv_128.png
+share/pixmaps/icon_odasrv_256.png
+share/pixmaps/icon_odasrv_512.png
+share/pixmaps/icon_odasrv_96.png
%%DATADIR%%/odamex.wad
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
%%PORTDOCS%%%%DOCSDIR%%/README
@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry share/applications