aboutsummaryrefslogtreecommitdiff
path: root/games/odamex
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-12-17 18:16:37 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-12-17 18:16:37 +0000
commited021df9c9ba98f79aa9e853ea56b22cf7af4c3f (patch)
treea274858fdfeb22974e16f27cdd970cecb6a2345d /games/odamex
parent5cf1286163f80f6a61d51b63efbabbdea12e3940 (diff)
downloadports-ed021df9c9ba98f79aa9e853ea56b22cf7af4c3f.tar.gz
ports-ed021df9c9ba98f79aa9e853ea56b22cf7af4c3f.zip
Odamex is a free and open source port for the classic first-person-shooter
Doom. Odamex's goal is to emulate the feel of and retain many aspects of the original Doom executables while offering a broader expanse of security features, personal configuration, gameplay options, and editing features. Odamex can run on a wide range of operating systems and hardware, so players should be able to play on almost any platform. Features: * The popular ZDoom 1.22 core engine and CSDoom 0.62 core netcode. * Compatability with many major operating systems, including Windows, Linux, FreeBSD and Mac OSX. * Core gameplay modeled on the original doom2.exe. * Streamlined WAD loading, allowing the server and clients to load WAD files on the fly without needing to restart the client or server. * Compatability with Boom, MBF and CTF Standard maps. * Deathmatch, Cooperative, Team Deathmatch and CTF gametypes. * Jumping, Mouselook and other non-standard features available as server-side options. * Comprehensive cheat and exploit countermeasures. * An open source code base licensed under the GPL, available for anyone to examine, compile, or modify to their liking. WWW: http://odamex.net/
Notes
Notes: svn path=/head/; revision=203939
Diffstat (limited to 'games/odamex')
-rw-r--r--games/odamex/Makefile41
-rw-r--r--games/odamex/distinfo3
-rw-r--r--games/odamex/files/patch-client__src__d_main.cpp12
-rw-r--r--games/odamex/pkg-descr22
-rw-r--r--games/odamex/pkg-plist7
5 files changed, 85 insertions, 0 deletions
diff --git a/games/odamex/Makefile b/games/odamex/Makefile
new file mode 100644
index 000000000000..511468386149
--- /dev/null
+++ b/games/odamex/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: odamex
+# Date created: 2007-12-06
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= odamex
+PORTVERSION= 0.3
+CATEGORIES= games
+MASTER_SITES= SF
+DISTNAME= Odamex-${PORTVERSION}-src
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= The Standard in Online Multiplayer Doom
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_SDL= sdl mixer
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|g++|${CXX}|; s|-DUNIX|${CFLAGS} &|; \
+ s|sdl11-config|sdl-config|; s|/usr/X11R6|${LOCALBASE}|' \
+ ${WRKSRC}/${MAKEFILE}
+ @${REINPLACE_CMD} -e 's|%%DMDIR%%|${DMDIR}|; \
+ s|%%DATADIR%%|${DATADIR}|' ${WRKSRC}/client/src/d_main.cpp
+
+do-install:
+.for f in odamaster odamex odasrv
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
+.endfor
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/odamex.wad ${DATADIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include "${.CURDIR}/../doom-data/Makefile.include"
+
+.include <bsd.port.mk>
diff --git a/games/odamex/distinfo b/games/odamex/distinfo
new file mode 100644
index 000000000000..a3e6948972b0
--- /dev/null
+++ b/games/odamex/distinfo
@@ -0,0 +1,3 @@
+MD5 (Odamex-0.3-src.tar.bz2) = 6b9eb253813a835b7761424f62514cec
+SHA256 (Odamex-0.3-src.tar.bz2) = 616fc68848ffb13fe05e2017f2d21e9fb1a1b538be02715ea4b33f72b9867e1e
+SIZE (Odamex-0.3-src.tar.bz2) = 1095587
diff --git a/games/odamex/files/patch-client__src__d_main.cpp b/games/odamex/files/patch-client__src__d_main.cpp
new file mode 100644
index 000000000000..aea1616077ce
--- /dev/null
+++ b/games/odamex/files/patch-client__src__d_main.cpp
@@ -0,0 +1,12 @@
+--- ./client/src/d_main.cpp.orig Sun Nov 4 12:21:20 2007
++++ ./client/src/d_main.cpp Thu Dec 6 13:58:25 2007
+@@ -727,6 +727,9 @@
+ AddSearchDir(dirs, Args.CheckValue("-waddir"), separator);
+ AddSearchDir(dirs, getenv("-DOOMWADDIR"), separator);
+ AddSearchDir(dirs, getenv("-DOOMWADPATH"), separator);
++ AddSearchDir(dirs, "%%DATADIR%%", separator);
++ AddSearchDir(dirs, "%%DMDIR%%", separator);
++
+
+ dirs.push_back(startdir);
+ dirs.push_back(progdir);
diff --git a/games/odamex/pkg-descr b/games/odamex/pkg-descr
new file mode 100644
index 000000000000..63ebd8a8b432
--- /dev/null
+++ b/games/odamex/pkg-descr
@@ -0,0 +1,22 @@
+Odamex is a free and open source port for the classic first-person-shooter
+Doom. Odamex's goal is to emulate the feel of and retain many aspects of the
+original Doom executables while offering a broader expanse of security
+features, personal configuration, gameplay options, and editing features.
+Odamex can run on a wide range of operating systems and hardware, so players
+should be able to play on almost any platform. Features:
+
+* The popular ZDoom 1.22 core engine and CSDoom 0.62 core netcode.
+* Compatability with many major operating systems, including Windows, Linux,
+ FreeBSD and Mac OSX.
+* Core gameplay modeled on the original doom2.exe.
+* Streamlined WAD loading, allowing the server and clients to load WAD files
+ on the fly without needing to restart the client or server.
+* Compatability with Boom, MBF and CTF Standard maps.
+* Deathmatch, Cooperative, Team Deathmatch and CTF gametypes.
+* Jumping, Mouselook and other non-standard features available as server-side
+ options.
+* Comprehensive cheat and exploit countermeasures.
+* An open source code base licensed under the GPL, available for anyone to
+ examine, compile, or modify to their liking.
+
+WWW: http://odamex.net/
diff --git a/games/odamex/pkg-plist b/games/odamex/pkg-plist
new file mode 100644
index 000000000000..c3909b249137
--- /dev/null
+++ b/games/odamex/pkg-plist
@@ -0,0 +1,7 @@
+bin/odamaster
+bin/odamex
+bin/odasrv
+%%DATADIR%%/odamex.wad
+%%PORTDOCS%%%%DOCSDIR%%/README
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%