aboutsummaryrefslogtreecommitdiff
path: root/games/open-adventure
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2017-10-20 06:52:03 +0000
committerStefan Eßer <se@FreeBSD.org>2017-10-20 06:52:03 +0000
commitd22425e337b065778c687665fa52baafff496a84 (patch)
treec89ec1d82b2df8f2796eed85190cc9058465b902 /games/open-adventure
parentf1f3eba77ec66fe9c1e6dfb37812ddcd90c2eaac (diff)
downloadports-d22425e337b065778c687665fa52baafff496a84.tar.gz
ports-d22425e337b065778c687665fa52baafff496a84.zip
New port of the "Colossal Cave Adventure", based on the last version
released by the initial authors (Crowther & Woods). Also known as the 430-point adventure. Approved by: antoine (mentor)
Notes
Notes: svn path=/head/; revision=452503
Diffstat (limited to 'games/open-adventure')
-rw-r--r--games/open-adventure/Makefile39
-rw-r--r--games/open-adventure/distinfo3
-rw-r--r--games/open-adventure/pkg-descr8
3 files changed, 50 insertions, 0 deletions
diff --git a/games/open-adventure/Makefile b/games/open-adventure/Makefile
new file mode 100644
index 000000000000..1deeac54c5a5
--- /dev/null
+++ b/games/open-adventure/Makefile
@@ -0,0 +1,39 @@
+# Created by: Stefan Esser <se@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= open-adventure
+PORTVERSION= 1.4
+CATEGORIES= games
+MASTER_SITES= https://gitlab.com/${GL_ACCOUNT}/${GL_PROJECT}/repository/archive${EXTRACT_SUFX}?ref=${GL_COMMIT};/
+
+MAINTAINER= se@FreeBSD.org
+COMMENT= Modernized version of the original Colossal Cave Adventure game
+
+LICENSE= BSD2CLAUSE
+
+BUILD_DEPENDS= ${PYTHONPREFIX_SITELIBDIR}/yaml/__init__.py:devel/py-yaml \
+ a2x:textproc/asciidoc
+
+ALL_TARGET= advent
+MAKE_ENV= CCFLAGS="${CFLAGS}"
+
+USES= gmake pkgconfig libedit python:build
+#USE_GITLAB= yes # When USE_GITLAB has become available, MASTER_SITES and WRKSRC should be obsolete
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${GL_COMMIT}-${GL_COMMIT}
+
+GL_ACCOUNT= esr
+GL_PROJECT= ${PORTNAME}
+GL_COMMIT= d51238481a6a752adc8ad4d8893209d13bb7ea91
+
+PLIST_FILES= bin/advent man/man6/advent.6.gz
+
+pre-build:
+ cd ${WRKSRC}; ${PYTHON_CMD} make_dungeon.py; a2x -f manpage advent.adoc
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/advent ${STAGEDIR}${PREFIX}/bin
+ #${MKDIR} ${STAGEDIR}${MANPREFIX}/man/man6
+ ${INSTALL_MAN} ${WRKSRC}/advent.6 ${STAGEDIR}${MANPREFIX}/man/man6
+
+.include <bsd.port.mk>
diff --git a/games/open-adventure/distinfo b/games/open-adventure/distinfo
new file mode 100644
index 000000000000..1d061f4123a3
--- /dev/null
+++ b/games/open-adventure/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1508308584
+SHA256 (open-adventure-1.4.tar.gz) = 1ad9246f6b34c6dc5affff908932eaf8d76e62d60a5b871edaedd1ab4f588eed
+SIZE (open-adventure-1.4.tar.gz) = 421941
diff --git a/games/open-adventure/pkg-descr b/games/open-adventure/pkg-descr
new file mode 100644
index 000000000000..13e2e7149341
--- /dev/null
+++ b/games/open-adventure/pkg-descr
@@ -0,0 +1,8 @@
+The original Colossal Cave Adventure from 1976 was the origin of all text
+adventures, dungeon-crawl (computer) games, and computer-hosted role-playing
+games.
+
+This is the last version released by Crowther & Woods, its original authors,
+in 1995. It has been known as "adventure 2.5" and "430-point adventure".
+
+WWW: http://www.catb.org/~esr/open-adventure/