aboutsummaryrefslogtreecommitdiff
path: root/games/openbor
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-08-23 15:17:19 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-08-23 15:17:19 +0000
commitc2617c47c45771e1e835a089915aa347deae5420 (patch)
tree5d7058a4d4d27417ef36e93bc6bd0e897f68bce8 /games/openbor
parent1d4b5c3aeeaf55140e6b99acae82293e6c74125c (diff)
downloadports-c2617c47c45771e1e835a089915aa347deae5420.tar.gz
ports-c2617c47c45771e1e835a089915aa347deae5420.zip
games/openbor: unbreak with Clang 11
ld: error: duplicate symbol: anim_list >>> defined at openbor.c >>> openbor.o:(anim_list) >>> defined at openborscript.c >>> openborscript.o:(.bss+0xD80) ld: error: duplicate symbol: model_cache >>> defined at openbor.c >>> openbor.o:(model_cache) >>> defined at openborscript.c >>> openborscript.o:(.bss+0x4B0) ld: error: duplicate symbol: anim_list >>> defined at openbor.c >>> openbor.o:(anim_list) >>> defined at control.c >>> sdl/control.o:(.bss+0x68) ld: error: duplicate symbol: model_cache >>> defined at openbor.c >>> openbor.o:(model_cache) >>> defined at control.c >>> sdl/control.o:(.bss+0x70) ld: error: duplicate symbol: anim_list >>> defined at openbor.c >>> openbor.o:(anim_list) >>> defined at menu.c >>> sdl/menu.o:(.bss+0x30) ld: error: duplicate symbol: model_cache >>> defined at openbor.c >>> openbor.o:(model_cache) >>> defined at menu.c >>> sdl/menu.o:(.bss+0x38) ld: error: duplicate symbol: anim_list >>> defined at openbor.c >>> openbor.o:(anim_list) >>> defined at translation.c >>> source/gamelib/translation.o:(.bss+0x18) ld: error: duplicate symbol: model_cache >>> defined at openbor.c >>> openbor.o:(model_cache) >>> defined at translation.c >>> source/gamelib/translation.o:(.bss+0x20) ld: error: duplicate symbol: anim_list >>> defined at openbor.c >>> openbor.o:(anim_list) >>> defined at models.c >>> source/gamelib/models.o:(.bss+0x408) ld: error: duplicate symbol: model_cache >>> defined at openbor.c >>> openbor.o:(model_cache) >>> defined at models.c >>> source/gamelib/models.o:(.bss+0x410) ld: error: duplicate symbol: anim_list >>> defined at openbor.c >>> openbor.o:(anim_list) >>> defined at utils.c >>> source/utils.o:(.bss+0x850) ld: error: duplicate symbol: model_cache >>> defined at openbor.c >>> openbor.o:(model_cache) >>> defined at utils.c >>> source/utils.o:(.bss+0x858) ld: error: duplicate symbol: anim_list >>> defined at openbor.c >>> openbor.o:(anim_list) >>> defined at animation.c >>> source/openborscript/animation.o:(.bss+0x0) ld: error: duplicate symbol: model_cache >>> defined at openbor.c >>> openbor.o:(model_cache) >>> defined at animation.c >>> source/openborscript/animation.o:(.bss+0x8) ld: error: duplicate symbol: anim_list >>> defined at openbor.c >>> openbor.o:(anim_list) >>> defined at axis.c >>> source/openborscript/axis.o:(.bss+0x0) ld: error: duplicate symbol: model_cache >>> defined at openbor.c >>> openbor.o:(model_cache) >>> defined at axis.c >>> source/openborscript/axis.o:(.bss+0x8) ld: error: duplicate symbol: anim_list >>> defined at openbor.c >>> openbor.o:(anim_list) >>> defined at binding.c >>> source/openborscript/binding.o:(.bss+0x0) ld: error: duplicate symbol: model_cache >>> defined at openbor.c >>> openbor.o:(model_cache) >>> defined at binding.c >>> source/openborscript/binding.o:(.bss+0x8) ld: error: duplicate symbol: anim_list >>> defined at openbor.c >>> openbor.o:(anim_list) >>> defined at drawmethod.c >>> source/openborscript/drawmethod.o:(.bss+0x0) ld: error: duplicate symbol: model_cache >>> defined at openbor.c >>> openbor.o:(model_cache) >>> defined at drawmethod.c >>> source/openborscript/drawmethod.o:(.bss+0x8) ld: error: too many errors emitted, stopping now (use -error-limit=0 to see all errors) Reported by: pkg-fallout
Notes
Notes: svn path=/head/; revision=545824
Diffstat (limited to 'games/openbor')
-rw-r--r--games/openbor/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/games/openbor/Makefile b/games/openbor/Makefile
index 28f6c16a183e..e0d7ebe43921 100644
--- a/games/openbor/Makefile
+++ b/games/openbor/Makefile
@@ -57,6 +57,7 @@ MAKE_ENV= BUILD_LINUX=1 SDKPATH="${LOCALBASE}" \
MAKE_ARGS= CC="${CC}" LIBRARIES="${LOCALBASE}/lib" \
TARGET_ARCH=${ARCH:S/i386/x86/} ARCHFLAGS="" \
TARGET_FINAL='${TARGET}' BUILD_MMX="" ECHO="${ECHO}"
+CFLAGS+= -fcommon # https://github.com/DCurrent/openbor/issues/206
LDFLAGS+= -Wl,--as-needed # ogg, pthread, zlib
SUB_FILES= pkg-message
SUB_LIST= PKGBASE=${PKGBASE}