aboutsummaryrefslogtreecommitdiff
path: root/games/openbor
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-07-07 00:40:09 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-07-07 00:40:09 +0000
commitd35cb075e17e98d24183251b5de8547cdbb7cb74 (patch)
treed61ebf2fed3ef7a78483091c2d4c9418579760e1 /games/openbor
parentc50874e1a0b07c80c3eaf755f8e75811012e3c1c (diff)
downloadports-d35cb075e17e98d24183251b5de8547cdbb7cb74.tar.gz
ports-d35cb075e17e98d24183251b5de8547cdbb7cb74.zip
Notes
Diffstat (limited to 'games/openbor')
-rw-r--r--games/openbor/Makefile4
-rw-r--r--games/openbor/distinfo6
-rw-r--r--games/openbor/files/patch-source_ramlib_ram.c6
3 files changed, 8 insertions, 8 deletions
diff --git a/games/openbor/Makefile b/games/openbor/Makefile
index dbb44bd2fde8..782cd04cc679 100644
--- a/games/openbor/Makefile
+++ b/games/openbor/Makefile
@@ -2,7 +2,7 @@
PORTNAME= openbor
# Hint: svn revision is git rev-list --count ${GH_TAGNAME}
-PORTVERSION?= 6235
+PORTVERSION?= 6263
.ifndef PKGNAMESUFFIX
PORTREVISION= 0
.endif
@@ -31,7 +31,7 @@ PORTSCOUT= ignore:1
USE_GITHUB= yes
GH_ACCOUNT= DCurrent
-GH_TAGNAME?= 66ce9c7b
+GH_TAGNAME?= cd8df016
USES+= gmake pkgconfig
.if ${PORTVERSION} < 4433
diff --git a/games/openbor/distinfo b/games/openbor/distinfo
index 50a88c1d6ac9..c9cc952e0a5a 100644
--- a/games/openbor/distinfo
+++ b/games/openbor/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1530539213
-SHA256 (DCurrent-openbor-6235-66ce9c7b_GH0.tar.gz) = 8e1b896e0e3c24fd44fb6a13a0e7c9c5ba8060a06257757f204bde18498309b4
-SIZE (DCurrent-openbor-6235-66ce9c7b_GH0.tar.gz) = 154356541
+TIMESTAMP = 1530889996
+SHA256 (DCurrent-openbor-6263-cd8df016_GH0.tar.gz) = 11493892eecfe5a570e52fa175fec90bdab290f2f1c337acf60f2001ae80da57
+SIZE (DCurrent-openbor-6263-cd8df016_GH0.tar.gz) = 154488044
diff --git a/games/openbor/files/patch-source_ramlib_ram.c b/games/openbor/files/patch-source_ramlib_ram.c
index b4abb51dec7d..d689f496916b 100644
--- a/games/openbor/files/patch-source_ramlib_ram.c
+++ b/games/openbor/files/patch-source_ramlib_ram.c
@@ -98,9 +98,9 @@ Implement Linux-like memory stats for BSDs
struct sysinfo info;
sysinfo(&info);
@@ -133,11 +197,29 @@ void setSystemRam()
- stat.dwLength = sizeof(MEMORYSTATUS);
- GlobalMemoryStatus(&stat);
- systemRam = stat.dwTotalPhys;
+ stat.dwLength = sizeof(MEMORYSTATUSEX);
+ GlobalMemoryStatusEx(&stat);
+ systemRam = stat.ullTotalPhys;
-#elif DARWIN
- u64 mem;
- size_t len = sizeof(mem);