aboutsummaryrefslogtreecommitdiff
path: root/games/openbor
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2024-04-13 00:56:30 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-04-13 00:57:37 +0000
commitf4675059d0c86c43fb8c1dfd1141af845d627a0b (patch)
tree85699e8d80032ac75af3a5ce21c8d2fa244b47ad /games/openbor
parentdf91ee38d7394293021b24ea50bf5519c64bd559 (diff)
downloadports-f4675059d0c86c43fb8c1dfd1141af845d627a0b.tar.gz
ports-f4675059d0c86c43fb8c1dfd1141af845d627a0b.zip
Diffstat (limited to 'games/openbor')
-rw-r--r--games/openbor/Makefile4
-rw-r--r--games/openbor/distinfo6
-rw-r--r--games/openbor/files/patch-source_utils.c12
3 files changed, 10 insertions, 12 deletions
diff --git a/games/openbor/Makefile b/games/openbor/Makefile
index 1121f0c5f6e3..7c43372a2aff 100644
--- a/games/openbor/Makefile
+++ b/games/openbor/Makefile
@@ -1,6 +1,6 @@
PORTNAME= openbor
# Hint: svn revision is git rev-list --count ${GH_TAGNAME}
-PORTVERSION?= 7610
+PORTVERSION?= 7633
PORTREVISION?= 0
CATEGORIES= games
@@ -35,7 +35,7 @@ PORTSCOUT= ignore:1
USE_GITHUB= yes
GH_ACCOUNT= DCurrent
-GH_TAGNAME?= f4510854
+GH_TAGNAME?= ec0f4446
USES+= cpe gmake pkgconfig sdl
.if ${PORTVERSION} < 4433
diff --git a/games/openbor/distinfo b/games/openbor/distinfo
index a803a4d63f53..100f97644623 100644
--- a/games/openbor/distinfo
+++ b/games/openbor/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1707519600
-SHA256 (DCurrent-openbor-7610-f4510854_GH0.tar.gz) = 0fe777b69a23e2913a37260dbf9c9c680a0376acfe0f2402a7b7fe6281bcfe0b
-SIZE (DCurrent-openbor-7610-f4510854_GH0.tar.gz) = 212696672
+TIMESTAMP = 1712969790
+SHA256 (DCurrent-openbor-7633-ec0f4446_GH0.tar.gz) = bcf54a39e5c49e1f8cd2d677f35947c331cd15e2743953a49fc8a0f8c2412de5
+SIZE (DCurrent-openbor-7633-ec0f4446_GH0.tar.gz) = 212701948
diff --git a/games/openbor/files/patch-source_utils.c b/games/openbor/files/patch-source_utils.c
index 8558a0074446..374b62fd35bf 100644
--- a/games/openbor/files/patch-source_utils.c
+++ b/games/openbor/files/patch-source_utils.c
@@ -9,7 +9,7 @@ source/utils.c:303:64: error: member reference base type 'int' is not a structur
writeToLogFile("Memory usage at exit: %u\n", mallinfo().arena);
~~~~~~~~~~^~~~~~
---- source/utils.c.orig 2024-02-01 15:55:11 UTC
+--- source/utils.c.orig 2024-04-11 18:46:01 UTC
+++ source/utils.c
@@ -14,7 +14,7 @@
#include <locale.h>
@@ -20,14 +20,12 @@ source/utils.c:303:64: error: member reference base type 'int' is not a structur
#include <features.h>
#endif
-@@ -307,9 +307,7 @@ void *checkAlloc(void *ptr, size_t size, const char *f
+@@ -307,7 +307,7 @@ void *checkAlloc(void *ptr, size_t size, const char *f
"\n* Shutting Down *\n\n");
writeToLogFile("Out of memory!\n");
writeToLogFile("Allocation of size %i failed in function '%s' at %s:%i.\n", size, func, file, line);
--#ifndef WIN
-- writeToLogFile("Memory usage at exit: %u\n", mallinfo().arena);
--#elif LINUX
+-#if LINUX && !DARWIN
+#if defined(__GLIBC__) || defined(ANDROID) || defined(VITA)
writeToLogFile("Memory usage at exit: %u\n", mallinfo2().arena);
- #endif
- borExit(2);
+ #else
+ writeToLogFile("Memory usage at exit: %u\n", getUsedRam(BYTES));