aboutsummaryrefslogtreecommitdiff
path: root/games/openbubbles
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-02-04 01:30:08 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-02-04 01:30:08 +0000
commit90f50c8b1ec2ce0d4e84f3d7bda21c91510c125b (patch)
tree83633a493875d100dde4c2a337f90b990f51bc68 /games/openbubbles
parent3dffd6c4add3fc4c1984fe14fe6056fed9212552 (diff)
downloadports-90f50c8b1ec2ce0d4e84f3d7bda21c91510c125b.tar.gz
ports-90f50c8b1ec2ce0d4e84f3d7bda21c91510c125b.zip
OpenBubbles is a clone of Evan Bailey's game Bubbles.
WWW: http://www.freewebs.com/lasindi/openbubbles/ PR: ports/179944 Submitted by: nemysis (self)
Notes
Notes: svn path=/head/; revision=342482
Diffstat (limited to 'games/openbubbles')
-rw-r--r--games/openbubbles/Makefile44
-rw-r--r--games/openbubbles/distinfo4
-rw-r--r--games/openbubbles/pkg-descr3
-rw-r--r--games/openbubbles/pkg-plist78
4 files changed, 129 insertions, 0 deletions
diff --git a/games/openbubbles/Makefile b/games/openbubbles/Makefile
new file mode 100644
index 000000000000..824a26bc81a3
--- /dev/null
+++ b/games/openbubbles/Makefile
@@ -0,0 +1,44 @@
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= openbubbles
+PORTVERSION= 1.2
+CATEGORIES= games
+MASTER_SITES= http://www.freewebs.com/lasindi/${PORTNAME}/ \
+ SF/nemysisfreebsdp/${CATEGORIES}/:icons
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}_icons${EXTRACT_SUFX}:icons
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= Clone of Evan Bailey's game Bubbles
+
+LICENSE= GPLv2
+
+USE_BZIP2= yes
+USE_SDL= sdl gfx image
+GNU_CONFIGURE= yes
+CFLAGS+= -w
+
+PORTDOCS= AUTHORS ChangeLog NEWS README
+
+OPTIONS_DEFINE= DOCS
+
+INSTALLS_ICONS= yes
+ICON_SIZES= 32x32 48x48 64x64 72x72 96x96 128x128
+
+DESKTOP_ENTRIES="OpenBubbles" "" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" ""
+
+post-install:
+.for s in ${ICON_SIZES}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+.endfor
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/games/openbubbles/distinfo b/games/openbubbles/distinfo
new file mode 100644
index 000000000000..27afd730ac7e
--- /dev/null
+++ b/games/openbubbles/distinfo
@@ -0,0 +1,4 @@
+SHA256 (openbubbles-1.2.tar.bz2) = 7d5d4633a4881559f475b0b9e3778d593f856dd1dbf0acf979b79852f8d63dbb
+SIZE (openbubbles-1.2.tar.bz2) = 1090220
+SHA256 (openbubbles_icons.tar.bz2) = 7c2f931abf581a9461d4373bb33390febb1cfed86d1eb9acac973ae97dbc14de
+SIZE (openbubbles_icons.tar.bz2) = 35383
diff --git a/games/openbubbles/pkg-descr b/games/openbubbles/pkg-descr
new file mode 100644
index 000000000000..066c0d754092
--- /dev/null
+++ b/games/openbubbles/pkg-descr
@@ -0,0 +1,3 @@
+OpenBubbles is a clone of Evan Bailey's game Bubbles.
+
+WWW: http://www.freewebs.com/lasindi/openbubbles/
diff --git a/games/openbubbles/pkg-plist b/games/openbubbles/pkg-plist
new file mode 100644
index 000000000000..f01c5bd5f651
--- /dev/null
+++ b/games/openbubbles/pkg-plist
@@ -0,0 +1,78 @@
+bin/openbubbles
+share/icons/hicolor/128x128/apps/openbubbles.png
+share/icons/hicolor/32x32/apps/openbubbles.png
+share/icons/hicolor/48x48/apps/openbubbles.png
+share/icons/hicolor/64x64/apps/openbubbles.png
+share/icons/hicolor/72x72/apps/openbubbles.png
+share/icons/hicolor/96x96/apps/openbubbles.png
+%%DATADIR%%/abubble.png
+%%DATADIR%%/blank.png
+%%DATADIR%%/blankscore.png
+%%DATADIR%%/bonus1.png
+%%DATADIR%%/bonus2.png
+%%DATADIR%%/bounce.wav
+%%DATADIR%%/bouncer.png
+%%DATADIR%%/bubble.png
+%%DATADIR%%/bubble.wav
+%%DATADIR%%/cancel.png
+%%DATADIR%%/cancel_hilight.png
+%%DATADIR%%/cancel_pressed.png
+%%DATADIR%%/check.png
+%%DATADIR%%/check_hilight.png
+%%DATADIR%%/check_pressed.png
+%%DATADIR%%/checkbox.png
+%%DATADIR%%/checkbox_hilight.png
+%%DATADIR%%/checkboxshot.png
+%%DATADIR%%/checkshot.png
+%%DATADIR%%/clear.png
+%%DATADIR%%/clear_hilight.png
+%%DATADIR%%/clear_pressed.png
+%%DATADIR%%/clearshot.png
+%%DATADIR%%/copyright.png
+%%DATADIR%%/cursor.png
+%%DATADIR%%/digits.png
+%%DATADIR%%/enterback.png
+%%DATADIR%%/fire.wav
+%%DATADIR%%/font.png
+%%DATADIR%%/font2.png
+%%DATADIR%%/gameover.png
+%%DATADIR%%/gameover.wav
+%%DATADIR%%/gameshot.png
+%%DATADIR%%/highback.png
+%%DATADIR%%/highbanner.png
+%%DATADIR%%/highscores.png
+%%DATADIR%%/highscores_hilight.png
+%%DATADIR%%/highscores_pressed.png
+%%DATADIR%%/highshot.png
+%%DATADIR%%/icon.xpm
+%%DATADIR%%/icon59.png
+%%DATADIR%%/instructions.png
+%%DATADIR%%/instructions_button.png
+%%DATADIR%%/instructions_hilight.png
+%%DATADIR%%/instructions_pressed.png
+%%DATADIR%%/instructionsshot.png
+%%DATADIR%%/labels.png
+%%DATADIR%%/logo.png
+%%DATADIR%%/menushot.png
+%%DATADIR%%/missle.png
+%%DATADIR%%/ok.png
+%%DATADIR%%/ok_hilight.png
+%%DATADIR%%/ok_pressed.png
+%%DATADIR%%/pi.png
+%%DATADIR%%/player.png
+%%DATADIR%%/quit.png
+%%DATADIR%%/quit_hilight.png
+%%DATADIR%%/quit_pressed.png
+%%DATADIR%%/return.png
+%%DATADIR%%/return_hilight.png
+%%DATADIR%%/return_pressed.png
+%%DATADIR%%/returnshot.png
+%%DATADIR%%/sharky.png
+%%DATADIR%%/start.png
+%%DATADIR%%/start_hilight.png
+%%DATADIR%%/start_pressed.png
+%%DATADIR%%/version.png
+%%DATADIR%%/visit.png
+%%DATADIR%%/youwin.png
+share/pixmaps/openbubbles.png
+@dirrm %%DATADIR%%