aboutsummaryrefslogtreecommitdiff
path: root/games/opencity
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-06-06 17:41:37 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-06-06 17:41:37 +0000
commitff043ce6d6e407e08e963dcada211edff4a97e0c (patch)
tree71af47fd3bffc8f0364509cd66de648ca257e7af /games/opencity
parente9de97cd0a1b7507719f33b0ea7d4641d1651939 (diff)
downloadports-ff043ce6d6e407e08e963dcada211edff4a97e0c.tar.gz
ports-ff043ce6d6e407e08e963dcada211edff4a97e0c.zip
- Mark with USE_GCC
- Remove obsolete patch and OSVERSION check
Notes
Notes: svn path=/head/; revision=320118
Diffstat (limited to 'games/opencity')
-rw-r--r--games/opencity/Makefile9
-rw-r--r--games/opencity/files/extra-patch-src-macros.h16
2 files changed, 3 insertions, 22 deletions
diff --git a/games/opencity/Makefile b/games/opencity/Makefile
index e99a34e23527..36a4d2ee07d7 100644
--- a/games/opencity/Makefile
+++ b/games/opencity/Makefile
@@ -16,16 +16,13 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_SDL= sdl mixer image net
USE_GL= gl glu
+USE_GCC= any
PORTDOCS= *
MAN6= opencity.6
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 802502
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-src-macros.h
-.endif
+.include <bsd.port.options.mk>
.if ! ${PORT_OPTIONS:MDOCS}
post-patch:
@@ -33,4 +30,4 @@ post-patch:
${WRKSRC}/docs/Makefile.in
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/opencity/files/extra-patch-src-macros.h b/games/opencity/files/extra-patch-src-macros.h
deleted file mode 100644
index 7611bf07b26b..000000000000
--- a/games/opencity/files/extra-patch-src-macros.h
+++ /dev/null
@@ -1,16 +0,0 @@
---- src/macros.h.orig 2008-10-28 21:23:51.000000000 +0300
-+++ src/macros.h 2008-11-05 03:52:54.000000000 +0300
-@@ -87,12 +87,10 @@
- #define strcasecmp _stricmp
- #endif
-
-- /* C99 standard has this
-+ #endif // #if defined(__WIN32__)
- // log2 workaround
- #if !defined(log2)
- #define log2(value) log((double)value)/log(2.0)
- #endif
-- */
-- #endif // #if defined(__WIN32__)
- #endif
-