aboutsummaryrefslogtreecommitdiff
path: root/games/openclonk
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-11-04 19:21:51 +0000
committerJohn Marino <marino@FreeBSD.org>2014-11-04 19:21:51 +0000
commit8f0d71dbb9db4e87c508be59c21b89d97b991dfd (patch)
treee4531e7135b5bdb56565a1e41b8136c4cce526fc /games/openclonk
parenteac5b043849f31e907f2374b4aa1ea6ed06c2376 (diff)
downloadports-8f0d71dbb9db4e87c508be59c21b89d97b991dfd.tar.gz
ports-8f0d71dbb9db4e87c508be59c21b89d97b991dfd.zip
Add new ports games/openclock
PR: 194617 Submitted by: Kevin Zheng OpenClonk is a free multiplayer action game in which you control clonks, small but witty and nimble humanoid beings. The game is mainly about mining, settling and fast-paced melees. OpenClonk is not just a game but also a versatile 2D game engine that allows the creation of mods. It is the successor of the shareware game series Clonk and thus inherits many of its features.
Notes
Notes: svn path=/head/; revision=372165
Diffstat (limited to 'games/openclonk')
-rw-r--r--games/openclonk/Makefile36
-rw-r--r--games/openclonk/distinfo2
-rw-r--r--games/openclonk/pkg-descr9
-rw-r--r--games/openclonk/pkg-plist20
4 files changed, 67 insertions, 0 deletions
diff --git a/games/openclonk/Makefile b/games/openclonk/Makefile
new file mode 100644
index 000000000000..5aa42bc8e8d8
--- /dev/null
+++ b/games/openclonk/Makefile
@@ -0,0 +1,36 @@
+# Created by: Kevin Zheng <kevinz5000@gmail.com>
+# $FreeBSD$
+
+PORTNAME= openclonk
+PORTVERSION= 5.1
+DISTVERSIONPREFIX= 5.
+DISTVERSIONSUFFIX= -src
+CATEGORIES= games
+MASTER_SITES= http://www.openclonk.org/builds/release/${DISTVERSION}/
+
+MAINTAINER= kevinz5000@gmail.com
+COMMENT= Multiplayer action game involving small and nimble humanoids
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libogg.so:${PORTSDIR}/audio/libogg \
+ libpng.so:${PORTSDIR}/graphics/png \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis
+
+USES= cmake iconv pkgconfig tar:bzip2
+USE_GL= glew
+USE_GNOME= gtk20
+USE_SDL= sdl mixer
+USE_XORG= x11 xpm
+
+WRKSRC= ${WRKDIR}/openclonk-release-${DISTVERSIONPREFIX}${DISTVERSION}-src
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|DESTINATION games|DESTINATION bin|' \
+ ${WRKSRC}/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/games/openclonk/distinfo b/games/openclonk/distinfo
new file mode 100644
index 000000000000..26329a04bddf
--- /dev/null
+++ b/games/openclonk/distinfo
@@ -0,0 +1,2 @@
+SHA256 (openclonk-5.5.1-src.tar.bz2) = c038d6dc2ef9a3d7966b18ba6147b9dd136f353dfaa5796455f9917b79255743
+SIZE (openclonk-5.5.1-src.tar.bz2) = 65383438
diff --git a/games/openclonk/pkg-descr b/games/openclonk/pkg-descr
new file mode 100644
index 000000000000..0f0ca0085157
--- /dev/null
+++ b/games/openclonk/pkg-descr
@@ -0,0 +1,9 @@
+OpenClonk is a free multiplayer action game in which you control clonks,
+small but witty and nimble humanoid beings. The game is mainly about
+mining, settling and fast-paced melees.
+
+OpenClonk is not just a game but also a versatile 2D game engine that
+allows the creation of mods. It is the successor of the shareware game
+series Clonk and thus inherits many of its features.
+
+WWW: http://www.openclonk.org/
diff --git a/games/openclonk/pkg-plist b/games/openclonk/pkg-plist
new file mode 100644
index 000000000000..d4efbb463501
--- /dev/null
+++ b/games/openclonk/pkg-plist
@@ -0,0 +1,20 @@
+bin/c4group
+bin/openclonk
+share/applications/openclonk.desktop
+share/games/openclonk/Arena.ocf
+share/games/openclonk/Decoration.ocd
+share/games/openclonk/Graphics.ocg
+share/games/openclonk/Material.ocg
+share/games/openclonk/Missions.ocf
+share/games/openclonk/Music.ocg
+share/games/openclonk/Objects.ocd
+share/games/openclonk/Parkour.ocf
+share/games/openclonk/Sound.ocg
+share/games/openclonk/System.ocg
+share/games/openclonk/Tutorial.ocf
+share/games/openclonk/Worlds.ocf
+share/icons/hicolor/128x128/apps/openclonk.png
+share/icons/hicolor/256x256/apps/openclonk.png
+share/icons/hicolor/32x32/apps/openclonk.png
+share/icons/hicolor/512x512/apps/openclonk.png
+share/icons/hicolor/64x64/apps/openclonk.png